aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail/Makefile
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-09-10 01:28:30 +0800
committercrees <crees@FreeBSD.org>2011-09-10 01:28:30 +0800
commit387174d11ff4d7b8bfd5c6f9bfe5dbde473e8330 (patch)
tree41c0f748f69c6920b3799e7cc362f84f1f4c5827 /mail/qmail/Makefile
parent74b8436059c44d480d616588e114d9900d69571a (diff)
downloadfreebsd-ports-gnome-387174d11ff4d7b8bfd5c6f9bfe5dbde473e8330.tar.gz
freebsd-ports-gnome-387174d11ff4d7b8bfd5c6f9bfe5dbde473e8330.tar.zst
freebsd-ports-gnome-387174d11ff4d7b8bfd5c6f9bfe5dbde473e8330.zip
- Add SMTPAUTHUSER and SRS support
- While here, use WANT_QMAIL rather than hideous relative include PR: ports/159964 Submitted by: Nicolas de Bari Embriz <nbari@dalmp.com> Approved by: garga (carte blanche via email)
Diffstat (limited to 'mail/qmail/Makefile')
-rw-r--r--mail/qmail/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 27f6b9a2576f..658dc1ad1c79 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -178,7 +178,9 @@ OPTIONS+= TLS "SMTP TLS support" on \
XF_QUITASAP "Close SMTP session ASAP (SMTPEXTFORK)" off \
SENDERCHECK4 "LOOSE checks exclusively for RELAY clients" off \
ENHACELOGS "Enhace qmail-smtpd logs (spamcontrol-like)" off \
- GRTDELAY "Add jms1's Greet Delay feature" off
+ GRTDELAY "Add jms1's Greet Delay feature" off \
+ SMTPAUTHUSER "create env SMTPAUTHUSER containing authuser" off\
+ SRS "Sender Rewriting Scheme support" off
LDAP_PARAMS= ALTQUEUE BIGBROTHER BIGTODO BIND_8_COMPAT\
CLEARTEXTPASSWD DASH_EXT DATA_COMPRESS\
@@ -305,16 +307,16 @@ BOOTFILES= home home+df proc proc+df binm1 binm1+df \
CONFIGUREPROGRAMS= install dnsfq hostname dnsip ipmeprint dnsptr
CONFIGURESCRIPTS= config config-fast
-.include "${.CURDIR}/../../Mk/bsd.mail.mk"
+WANT_QMAIL= yes
-.if (${PREFIX} != ${LOCALBASE})
+.include <bsd.port.pre.mk>
+
+.if ${PREFIX} != ${LOCALBASE}
DOCSDIR= ${PREFIX}/doc
.endif
NO_MTREE= yes
-.include <bsd.port.pre.mk>
-
.if ${OSVERSION} >= 900007
. if defined(SLAVE_LDAP)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-utmpx-ldap
@@ -349,6 +351,13 @@ PLIST_SUB+= EXTERNAL_TODO=""
PLIST_SUB+= EXTERNAL_TODO="@comment "
. endif
+. if defined(WITH_SRS)
+BUILD_DEPENDS= srs:${PORTSDIR}/mail/libsrs2
+MASTER_SITES+= http://qmail-ldap-smtpauthuser.googlecode.com/svn/trunk/:srs_ldap
+SRS_LDAP_PATCH = qmail-ldap-1.03-20060201-SRS.patch
+DISTFILES+= ${SRS_LDAP_PATCH}:srs_ldap
+. endif
+
.endif
.if defined(WITH_SMTP_AUTH_PATCH) && !defined(BARRIER_SMTP_AUTH_PATCH)
@@ -515,6 +524,17 @@ PATCH_SITE_SUBDIR+= garga/qmail/:ldapenhacelog
PATCHFILES+= enhacelogging-ldap-${LDAP_PATCH_DATE}_4.patch:ldapenhacelog
.endif
+.if defined(SLAVE_LDAP) && defined(WITH_SMTPAUTHUSER)
+PATCH_SITES+= http://qmail-ldap-smtpauthuser.googlecode.com/svn/trunk/:smtpauthuser \
+ ${MASTER_SITE_LOCAL:S/$/:smtpauthuser/}
+PATCH_SITE_SUBDIR+= garga/qmail/:smtpauthuser
+. if defined(WITH_ENHACELOGS)
+PATCHFILES+= qmail-1.03-enhaceloggingSMTPAUTHUSER:smtpauthuser
+. else
+PATCHFILES+= SMTPAUTHUSER.patch:smtpauthuser
+. endif
+.endif
+
.if defined(SLAVE_SPAMCONTROL)
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:ucspi_ssl/} \
http://www.superscript.com/ucspi-ssl/:ucspi_ssl \
@@ -708,6 +728,9 @@ post-patch:
@${REINPLACE_CMD} "s|^#LDAPFLAGS=.*$$|LDAPFLAGS=${LDAPFLAGS}|" \
${WRKSRC}/Makefile
. endif
+. if defined(WITH_SRS)
+ @${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SRS_LDAP_PATCH}
+. endif
.endif
.if defined(EXT_BIG_TODO_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${EXT_BIG_TODO_PATCH}