aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-03-01 23:48:31 +0800
committerasami <asami@FreeBSD.org>2000-03-01 23:48:31 +0800
commiteae580adbc3da9f4f1a10f925a0bc7b11a8273e1 (patch)
tree0a78875edd3c25feb966755b7a687a2b738467a0 /mail/qmail
parent16f892ed181f6a2a9a6907ca7acd78c966589b76 (diff)
downloadfreebsd-ports-gnome-eae580adbc3da9f4f1a10f925a0bc7b11a8273e1.tar.gz
freebsd-ports-gnome-eae580adbc3da9f4f1a10f925a0bc7b11a8273e1.tar.zst
freebsd-ports-gnome-eae580adbc3da9f4f1a10f925a0bc7b11a8273e1.zip
Don't use ${INSTALL_PROGRAM} to install a shell script. While I'm here,
take out a bunch of @'s, this Makefile is so hard to debug because the log contained no meaningful output. PR: 17090 (report only, no fix)
Diffstat (limited to 'mail/qmail')
-rw-r--r--mail/qmail/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index cce2eacb38bc..89f1b83773cf 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -78,9 +78,9 @@ BOOTFILES= ${WRKSRC}/home ${WRKSRC}/home+df ${WRKSRC}/proc \
# Supplied by Stuart Henderson <stuart@internationalschool.co.uk>
BOOTFILES+= ${FILESDIR}/maildir
-CONFIGUREFILES= ${WRKSRC}/install ${WRKSRC}/dnsfq ${WRKSRC}/hostname \
- ${WRKSRC}/dnsip ${WRKSRC}/ipmeprint ${WRKSRC}/dnsptr \
- ${WRKSRC}/config-fast
+CONFIGUREPROGS= ${WRKSRC}/install ${WRKSRC}/dnsfq ${WRKSRC}/hostname \
+ ${WRKSRC}/dnsip ${WRKSRC}/ipmeprint ${WRKSRC}/dnsptr
+CONFIGUREFILES= ${WRKSRC}/config ${WRKSRC}/config-fast
.if (${PREFIX} == "/usr/local")
DOCDIR= share/doc/qmail
@@ -106,17 +106,17 @@ do-install:
@PKG_PREFIX=${PREFIX} ${PERL5} ${PKGDIR}/INSTALL
@${MKDIR} ${PREFIX}/${DOCDIR} ${PREFIX}/configure
@cd ${WRKSRC} ; ./install
- @${INSTALL_PROGRAM} ${CONFIGUREFILES} ${PREFIX}/configure
- @${INSTALL_SCRIPT} ${WRKSRC}/config ${PREFIX}/configure
- @${INSTALL_SCRIPT} ${BOOTFILES} ${PREFIX}/boot
+ ${INSTALL_PROGRAM} ${CONFIGUREPROGS} ${PREFIX}/configure
+ ${INSTALL_SCRIPT} ${CONFIGUREFILES} ${PREFIX}/configure
+ ${INSTALL_SCRIPT} ${BOOTFILES} ${PREFIX}/boot
.for i in 1 5 7 8
@${MKDIR} ${PREFIX}/man/man$i
.for j in ${MAN${i}}
- @${INSTALL_MAN} ${WRKSRC}/$j ${PREFIX}/man/man${i}
+ ${INSTALL_MAN} ${WRKSRC}/$j ${PREFIX}/man/man${i}
.endfor
.endfor
.if !defined(NOPORTDOCS)
- @${INSTALL_DATA} ${DOCFILES} ${PREFIX}/${DOCDIR}
+ ${INSTALL_DATA} ${DOCFILES} ${PREFIX}/${DOCDIR}
.endif
.if defined(PACKAGE_BUILDING)
@${ECHO} "FreeBSD Binary package QMail installation" \
@@ -129,7 +129,7 @@ do-install:
@${TOUCH} ${PREFIX}/alias/.qmail-${i}
.endfor
@# This is not part of qmail proper, hence the 2nd class citizenship
- @${INSTALL_SCRIPT} ${FILESDIR}/mkaliasdir ${PREFIX}/${DOCDIR}
+ ${INSTALL_SCRIPT} ${FILESDIR}/mkaliasdir ${PREFIX}/${DOCDIR}
@cd ${PREFIX}/configure ; ./config
@${MKDIR} /usr/local/etc/rc.d
@${LN} -sf ${PREFIX}/rc /usr/local/etc/rc.d/qmail.sh