aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
committerknu <knu@FreeBSD.org>2002-01-29 19:48:57 +0800
commit5b243306947e74184be0fc39cd0f0d1eb8063940 (patch)
treecea3c8a6099c3422b99712692a2c3e0e2964a6d2 /mail/qmail
parentf6e00c6523a54ccae8d9221d4c43c1bebbe1592d (diff)
downloadfreebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.gz
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.tar.zst
freebsd-ports-gnome-5b243306947e74184be0fc39cd0f0d1eb8063940.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Diffstat (limited to 'mail/qmail')
-rw-r--r--mail/qmail/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 6736e725c198..a9c203910b84 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -226,14 +226,14 @@ post-post-patch:
do-configure:
@# Create/Check the necessary groups/users
@PKG_PREFIX=${PREFIX} ${PERL5} ${PKGINSTALL}
- @${ECHO} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
- @${ECHO} ${PREFIX} > ${WRKSRC}/conf-qmail
+ @${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
+ @${ECHO_CMD} ${PREFIX} > ${WRKSRC}/conf-qmail
.if defined(WITH_BIG_CONCURRENCY_PATCH) \
&& !defined(MAIN_QMAIL_PORT_WITH_BIG_CONCURRENCY_PATCH_BARRIER) \
&& defined(WITH_BIG_CONCURRENCY_PATCH_CONCURRENCY_LIMIT)
@if [ ${WITH_BIG_CONCURRENCY_PATCH_CONCURRENCY_LIMIT} -gt 0 ]; \
then \
- ${ECHO} "${WITH_BIG_CONCURRENCY_PATCH_CONCURRENCY_LIMIT}" \
+ ${ECHO_CMD} "${WITH_BIG_CONCURRENCY_PATCH_CONCURRENCY_LIMIT}" \
> ${WRKSRC}/conf-spawn ; \
fi
.endif # MAIN_QMAIL_PORT_WITH_BIG_CONCURRENCY_PATCH_BARRIER
@@ -258,7 +258,7 @@ do-install:
${INSTALL_DATA} ${DOCFILES} ${PREFIX}/${DOCDIR}
.endif
.if defined(PACKAGE_BUILDING)
- @${ECHO} "FreeBSD Binary package qmail installation" \
+ @${ECHO_CMD} "FreeBSD Binary package qmail installation" \
> ${PREFIX}/${DOCDIR}/SYSDEPS
.else
@cd ${WRKSRC} && ${CAT} `${CAT} SYSDEPS` \
@@ -287,10 +287,10 @@ thereal-post-patch:
.for i in ${BOOTFILES}
@if [ -f ${i}.sh ] ; \
then \
- ${PERL} -p -ne 's!QMAIL/!${PREFIX}/!;s!^(exec)!case "\$$1" in\nstart)\n\t\1!;s!(qmail)$$!\1\&\n\texit 0\n\t;;\nstop)\n\texec killall qmail-send\n\t;;\n*)\n\t${ECHO} "Usage: `basename \$$0` {start|stop}" >&2\n\texit 64\n\t;;\nesac!' $i.sh > ${WRKDIR}/${i:T} ; \
+ ${PERL} -p -ne 's!QMAIL/!${PREFIX}/!;s!^(exec)!case "\$$1" in\nstart)\n\t\1!;s!(qmail)$$!\1\&\n\texit 0\n\t;;\nstop)\n\texec killall qmail-send\n\t;;\n*)\n\t${ECHO_CMD} "Usage: `basename \$$0` {start|stop}" >&2\n\texit 64\n\t;;\nesac!' $i.sh > ${WRKDIR}/${i:T} ; \
elif [ -f ${i} ] ; \
then \
- ${PERL} -p -ne 's!QMAIL/!${PREFIX}/!;s!^(exec)!case "\$$1" in\nstart)\n\t\1!;s!(qmail)$$!\1\&\n\texit 0\n\t;;\nstop)\n\texec killall qmail-send\n\t;;\n*)\n\t${ECHO} "Usage: `basename \$$0` {start|stop}" >&2\n\texit 64\n\t;;\nesac!' $i > ${WRKDIR}/${i:T} ; \
+ ${PERL} -p -ne 's!QMAIL/!${PREFIX}/!;s!^(exec)!case "\$$1" in\nstart)\n\t\1!;s!(qmail)$$!\1\&\n\texit 0\n\t;;\nstop)\n\texec killall qmail-send\n\t;;\n*)\n\t${ECHO_CMD} "Usage: `basename \$$0` {start|stop}" >&2\n\texit 64\n\t;;\nesac!' $i > ${WRKDIR}/${i:T} ; \
fi
.endfor
@${SED} s!/var/qmail/!${PREFIX}/!g ${FILESDIR}/mailer.conf.sample > \
@@ -327,7 +327,7 @@ disable-sendmail: thereal-disable-sendmail
@${ECHO_MSG} "===> (i.e., added sendmail_enable=\¨NO\¨ to rc.conf)"
@if [ -f ${RC_CONF_FILE} ]; \
then \
- ${ECHO} sendmail_enable=\"NO\" >> ${RC_CONF_FILE} ; \
+ ${ECHO_CMD} sendmail_enable=\"NO\" >> ${RC_CONF_FILE} ; \
fi
enable-sendmail: thereal-disable-sendmail