aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmail
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-28 03:20:22 +0800
committergarga <garga@FreeBSD.org>2006-07-28 03:20:22 +0800
commite8e0209ce7d753c62c0148189f6e163d5466c856 (patch)
treec92711c9a7b6a689404c041593b6c54eb57af840 /mail/qmail
parentc373f08933c71395da6655f85c97d5421fc2c798 (diff)
downloadfreebsd-ports-gnome-e8e0209ce7d753c62c0148189f6e163d5466c856.tar.gz
freebsd-ports-gnome-e8e0209ce7d753c62c0148189f6e163d5466c856.tar.zst
freebsd-ports-gnome-e8e0209ce7d753c62c0148189f6e163d5466c856.zip
Add ext_todo patch, and external high performance todo manager.
Diffstat (limited to 'mail/qmail')
-rw-r--r--mail/qmail/Makefile39
-rw-r--r--mail/qmail/distinfo9
-rw-r--r--mail/qmail/pkg-plist1
3 files changed, 48 insertions, 1 deletions
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index a5a6171e442a..db5db33cffd2 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -38,6 +38,7 @@ BARRIER_SPF_PATCH= yes
.if defined(SLAVE_LDAP)
BARRIER_BIG_CONCURRENCY_PATCH= yes
BARRIER_DNS_PATCH= yes
+BARRIER_EXTTODO_PATCH= yes
.endif
.if defined(SLAVE_LDAP) || \
@@ -140,6 +141,9 @@ OPTIONS+= SPF_PATCH "Implement SPF checker" off
.if !defined(BARRIER_TARPIT_PATCH)
OPTIONS+= TARPIT_PATCH "Implement TARPIT functions" off
.endif
+.if !defined(BARRIER_EXTTODO_PATCH)
+OPTIONS+= EXTTODO_PATCH "extern high-perform. todo processing" off
+.endif
.if defined(SLAVE_TLS)
OPTIONS+= TLS_DEBUG "enable additional debug information" off
.elif defined(SLAVE_LDAP)
@@ -360,6 +364,33 @@ PATCHFILES+= qmail-spf-rc5.patch:spf
. endif
.endif
+.if defined(WITH_EXTTODO_PATCH) && !defined(BARRIER_EXTTODO_PATCH)
+PLIST_SUB+= EXTTODO=""
+DOCFILES_WRKSRC+= EXTTODO
+
+. if defined(WITH_SPF_PATCH) && !defined(BARRIER_SPF_PATCH)
+. if defined(SLAVE_TLS)
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:exttodo/}
+MASTER_SITE_SUBDIR+= garga/qmail/:exttodo
+EXTTODO_PATCH= ext_todo-20030105_spf.patch
+DISTFILES+= ${EXTTODO_PATCH}:exttodo
+. else
+PATCH_SITES+= ${MASTER_SITE_LOCAL:S/$/:exttodo/}
+PATCHFILES+= ext_todo-20030105_spf.patch:exttodo
+PATCH_SITE_SUBDIR+= garga/qmail/:exttodo
+. endif
+. elif defined(SLAVE_MYSQL)
+PATCH_SITES+= ${MASTER_SITE_LOCAL:S/$/:exttodo/}
+PATCHFILES+= ext_todo-20030105_mysql.patch:exttodo
+PATCH_SITE_SUBDIR+= garga/qmail/:exttodo
+. else
+PATCH_SITES+= http://www.nrg4u.com/qmail/:exttodo
+PATCHFILES+= ext_todo-20030105.patch:exttodo
+. endif
+.else
+PLIST_SUB+= EXTTODO="@comment "
+.endif
+
.if !defined(BARRIER_DNS_PATCH) \
||(defined(WITH_QMAILQUEUE_PATCH) && !defined(BARRIER_QMAILQUEUE_PATCH)) \
||(defined(WITH_BIG_TODO_PATCH) && !defined(BARRIER_BIG_TODO_PATCH)) \
@@ -482,12 +513,18 @@ post-patch:
@${PATCH} -d ${SMTP_AUTH_DIR} < ${FILESDIR}/auth.patch.patch
. endif
@${PATCH} -d ${WRKSRC} < ${SMTP_AUTH_DIR}/auth.patch
-. if defined(WITH_SPF_PATCH) && defined(SLAVE_TLS)
+. if defined(SLAVE_TLS) && defined(WITH_SPF_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SPF_TLS_PATCH}
+. if defined(WITH_EXTTODO_PATCH) && defined(EXTTODO_PATCH)
+ @${PATCH} -p1 -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${EXTTODO_PATCH}
+. endif
. endif
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/qmail-smtpd-auth-close3.patch
.elif defined(SLAVE_TLS) && defined(WITH_SPF_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SPF_TLS_PATCH}
+. if defined(WITH_EXTTODO_PATCH) && defined(EXTTODO_PATCH)
+ @${PATCH} -p1 -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${EXTTODO_PATCH}
+. endif
.endif
.if defined(SLAVE_MYSQL)
@${REINPLACE_CMD} 's|/opt/mysql|${LOCALBASE}|' \
diff --git a/mail/qmail/distinfo b/mail/qmail/distinfo
index 4b57308c24ee..f29ba89f9c67 100644
--- a/mail/qmail/distinfo
+++ b/mail/qmail/distinfo
@@ -70,3 +70,12 @@ SIZE (qmail/qmail-smtpd-auth-close3.patch) = 520
MD5 (qmail/tarpit.patch) = 49a2c0a445981deb09f3af73041d75f5
SHA256 (qmail/tarpit.patch) = de94abbb71ef5d25e168725e435edd96ce3b14b7347440e0805dcb919b9d9604
SIZE (qmail/tarpit.patch) = 3089
+MD5 (qmail/ext_todo-20030105.patch) = 99070bb55cac5ad61f8fb203422e651e
+SHA256 (qmail/ext_todo-20030105.patch) = d46d0225360c0477f93e2990637ebf912b2a86e494f424ef2952ee11ab533ac7
+SIZE (qmail/ext_todo-20030105.patch) = 33763
+MD5 (qmail/ext_todo-20030105_spf.patch) = 4d760732c92c01bd14d9957257ca4c1a
+SHA256 (qmail/ext_todo-20030105_spf.patch) = 544629c0003d01d27a5a45508e84332f247ed54ece57ff22c0c7c3a56ba086d6
+SIZE (qmail/ext_todo-20030105_spf.patch) = 33781
+MD5 (qmail/ext_todo-20030105_mysql.patch) = ecddff9ba6d725ec3be61843bc8007a7
+SHA256 (qmail/ext_todo-20030105_mysql.patch) = 3fc65b91faaaae147dbf6264f9381664819ef2f236532764309d174f29919ff1
+SIZE (qmail/ext_todo-20030105_mysql.patch) = 33797
diff --git a/mail/qmail/pkg-plist b/mail/qmail/pkg-plist
index bd82b52d1593..62a85bd3d959 100644
--- a/mail/qmail/pkg-plist
+++ b/mail/qmail/pkg-plist
@@ -58,6 +58,7 @@ bin/qmail-smtpd
bin/qmail-start
bin/qmail-tcpok
bin/qmail-tcpto
+%%EXTTODO%%bin/qmail-todo
%%LDAP%%%%EXTERNAL_TODO%%bin/qmail-todo
%%LDAP%%bin/qmail-verify
bin/qreceipt