aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmailadmin/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2002-09-05 23:09:24 +0800
committerroam <roam@FreeBSD.org>2002-09-05 23:09:24 +0800
commit511ed8fa0644d82cc391a76aea816cee7dec3d12 (patch)
tree4af46c3f56a2aaa1437aa62f7c2432960ec8f1e9 /mail/qmailadmin/Makefile
parenta91fd0bada16035c5d0978ed91b737f63a734140 (diff)
downloadfreebsd-ports-gnome-511ed8fa0644d82cc391a76aea816cee7dec3d12.tar.gz
freebsd-ports-gnome-511ed8fa0644d82cc391a76aea816cee7dec3d12.tar.zst
freebsd-ports-gnome-511ed8fa0644d82cc391a76aea816cee7dec3d12.zip
Update to qmailadmin-1.0.6, containing a couple of security fixes.
There are two new knobs: - WITHOUT_IPAUTH disables the IP authentication: by default, qmailadmin "remembers" your IP address after a successful login, and then logs the session out if you try to access a page from a different address, even with the same session ID; - WITHOUT_USER_INDEX disables the user index display, which might confuse earlier versions of Internet Explorer. Prompted by: David Phillips <david@acz.org>
Diffstat (limited to 'mail/qmailadmin/Makefile')
-rw-r--r--mail/qmailadmin/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
index 92b0cc0e0e25..d60d42c3081c 100644
--- a/mail/qmailadmin/Makefile
+++ b/mail/qmailadmin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qmailadmin
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.6
CATEGORIES= mail www
MASTER_SITES= http://www.inter7.com/qmailadmin/
@@ -35,6 +35,10 @@ USE_GMAKE= YES
# WEBDATADIR - location of your html files
# WEBDATASUBDIR - subdirectory to place html files in (not working yet)
#
+# WITHOUT_IPAUTH - disable the IP address check after login
+# WITHOUT_USER_INDEX - disable the user index display, which might
+# confuse earlier versions of Internet Explorer
+#
CGIBINDIR?= www/cgi-bin.default
CGIBINSUBDIR?= qmailadmin
@@ -69,6 +73,14 @@ CONFIGURE_ARGS+= \
--enable-cgipath=/${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
--enable-ezmlmidx=y
+.if defined(WITHOUT_IPAUTH)
+CONFIGURE_ARGS+= --enable-ipauth=n
+.endif
+
+.if defined(WITHOUT_USER_INDEX)
+CONFIGURE_ARGS+= --enable-user-index=n
+.endif
+
pre-install:
@${MKDIR} ${PREFIX}/share/qmailadmin/html