aboutsummaryrefslogtreecommitdiffstats
path: root/mail/qmailadmin/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2000-09-23 22:40:34 +0800
committernbm <nbm@FreeBSD.org>2000-09-23 22:40:34 +0800
commitb789fa22aa7491459b4ef01c0e27be4aa3af2de5 (patch)
tree69a9a5c69269f4981d060db0fba8fd2c153814f1 /mail/qmailadmin/Makefile
parente2091833bb2ad89f01dbdef4c98c1acb4dcdf89a (diff)
downloadfreebsd-ports-gnome-b789fa22aa7491459b4ef01c0e27be4aa3af2de5.tar.gz
freebsd-ports-gnome-b789fa22aa7491459b4ef01c0e27be4aa3af2de5.tar.zst
freebsd-ports-gnome-b789fa22aa7491459b4ef01c0e27be4aa3af2de5.zip
Add qmailadmin, a web-based vpopmail mail server administrator, which
allows you to set up POP accounts, forwarders, mailing lists, and such from the web.
Diffstat (limited to 'mail/qmailadmin/Makefile')
-rw-r--r--mail/qmailadmin/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/mail/qmailadmin/Makefile b/mail/qmailadmin/Makefile
new file mode 100644
index 000000000000..e1a1f75d7381
--- /dev/null
+++ b/mail/qmailadmin/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: qmailadmin
+# Date created: 23 Sep 2000
+# Whom: Neil Blakey-Milner
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmailadmin
+PORTVERSION= 0.35
+CATEGORIES= mail www
+MASTER_SITES= http://www.inter7.com/qmailadmin/
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= \
+ ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
+ autorespond:${PORTSDIR}/mail/autorespond \
+ ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx \
+ ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+RUN_DEPENDS= \
+ ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail \
+ autorespond:${PORTSDIR}/mail/autorespond \
+ ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx \
+ ${LOCALBASE}/vpopmail/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+#
+# User-configurable variables
+#
+# CGIBINDIR - location of your cgi directory
+# CGIBINSUBDIR - subdirectory to place cgi scripts in
+# CGIBINURL - location of your cgi directory in a URL
+# WEBDATADIR - location of your html files
+# WEBDATASUBDIR - subdirectory to place html files in (not working yet)
+#
+
+CGIBINDIR?= ${PREFIX}/www/cgi-bin.default
+CGIBINSUBDIR?= qmailadmin
+CGIBINURL?= cgi-bin
+WEBDATADIR?= ${PREFIX}/www/data.default
+WEBDATASUBDIR?=
+
+#
+# QMAIL_DIR - location of qmail directory
+#
+
+.if exists(${LOCALBASE}/qmail/bin/qmail-send)
+QMAIL_DIR?= ${LOCALBASE}/qmail
+.else
+QMAIL_DIR?= /var/qmail
+.endif
+
+# End of user-configurable variables
+
+CONFIGURE_ARGS+= \
+ --enable-htmldir=${WEBDATADIR}/${WEBDATASUBDIR} \
+ --enable-cgibindir=${CGIBINDIR}/${CGIBINSUBDIR} \
+ --with-htmllibdir=${PREFIX}/share/qmailadmin \
+ --enable-cgipath=/${CGIBINURL}/${CGIBINSUBDIR}/qmailadmin \
+ --enable-ezmlmidx=y
+
+pre-install:
+ @${MKDIR} ${PREFIX}/share/qmailadmin/html
+
+.include <bsd.port.mk>