aboutsummaryrefslogtreecommitdiffstats
path: root/mail/queue-repair/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-10-14 21:31:21 +0800
committerijliao <ijliao@FreeBSD.org>2002-10-14 21:31:21 +0800
commitefe27befec8da9bf0af6aade3bf30385855db90d (patch)
tree6ca32624f4cbee2aeab843aa9ede14f73cdd7583 /mail/queue-repair/Makefile
parent3b49001e92e4aa7a03e0ecd47d00c4f94719bf10 (diff)
downloadfreebsd-ports-gnome-efe27befec8da9bf0af6aade3bf30385855db90d.tar.gz
freebsd-ports-gnome-efe27befec8da9bf0af6aade3bf30385855db90d.tar.zst
freebsd-ports-gnome-efe27befec8da9bf0af6aade3bf30385855db90d.zip
- Default to RUN_DEPEND on mail/qmail port (can be turned off -
define WITHOUT_QMAIL_PORT); patch source for nofiles->qnofiles group used by the qmail port (suggested by Kevin M. Dulzo <kdulzo@sockpuppet.org>) - Bump PORTREVISION - Do not install yet another copy of GPL (COPYING) PR: 44022 Submitted by: maintainer
Diffstat (limited to 'mail/queue-repair/Makefile')
-rw-r--r--mail/queue-repair/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
index 3968684716d8..c1d848757224 100644
--- a/mail/queue-repair/Makefile
+++ b/mail/queue-repair/Makefile
@@ -7,24 +7,33 @@
PORTNAME= queue-repair
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= http://www.qcc.ca/~charlesc/software/queue_repair/
MAINTAINER= sergei@kolobov.com
+.if !defined(WITHOUT_QMAIL_PORT)
+RUN_DEPENDS= ${QMAIL_DIR}/bin/qmail-send:${PORTSDIR}/mail/qmail
+QMAIL_DIR?= /var/qmail
+.endif
+
USE_PYTHON= yes
USE_REINPLACE= yes
-DOCS= BLURB CHANGELOG COPYING TODO docs.txt
+DOCS= BLURB CHANGELOG TODO docs.txt
do-build:
${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
${WRKSRC}/queue_repair.py
+.if !defined(WITHOUT_QMAIL_PORT)
+ ${REINPLACE_CMD} -e 's,nofiles,qnofiles,' ${WRKSRC}/queue_repair.py
+.endif
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/queue_repair.py ${PREFIX}/bin/queue-repair
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for file in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor