aboutsummaryrefslogtreecommitdiffstats
path: root/mail/queue-repair
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-03-18 08:20:56 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-03-18 08:20:56 +0800
commit07b9d4a9b816f1cd34390ee1421ea68634e406e1 (patch)
tree7bf7a1778d6a38508e716baabdb38357ad8f6253 /mail/queue-repair
parent3dda24b7a2c7780330456b9252eea2de8f3e8d64 (diff)
downloadfreebsd-ports-gnome-07b9d4a9b816f1cd34390ee1421ea68634e406e1.tar.gz
freebsd-ports-gnome-07b9d4a9b816f1cd34390ee1421ea68634e406e1.tar.zst
freebsd-ports-gnome-07b9d4a9b816f1cd34390ee1421ea68634e406e1.zip
- Rename and add missing description for QMAIL_PORT
This is kept mostly for backwards compatibility. Our mail/qmail uses 'qnofiles' group instead of qmail's default 'nofiles'. Using QMAIL_PORT means you want to use the ports version of qmail and not a custom install
Diffstat (limited to 'mail/queue-repair')
-rw-r--r--mail/queue-repair/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/mail/queue-repair/Makefile b/mail/queue-repair/Makefile
index 3563fc29b100..dcf817a223de 100644
--- a/mail/queue-repair/Makefile
+++ b/mail/queue-repair/Makefile
@@ -12,12 +12,13 @@ COMMENT= Qmail queue diagnostic and repair tool
USE_PYTHON= yes
-OPTIONS_DEFINE= DOCS QMAIL
-OPTIONS_DEFAULT= QMAIL
+OPTIONS_DEFINE= DOCS QMAIL_PORT
+OPTIONS_DEFAULT= QMAIL_PORT
+QMAIL_PORT_DESC= Depend on qmail port
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MQMAIL}
+.if ${PORT_OPTIONS:MQMAIL_PORT}
USES= qmail:run
.endif
@@ -27,7 +28,7 @@ PORTDOCS= BLURB CHANGELOG TODO
do-build:
${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
${WRKSRC}/queue_repair.py
-.if ${PORT_OPTIONS:MQMAIL}
+.if ${PORT_OPTIONS:MQMAIL_PORT}
${REINPLACE_CMD} -e 's,nofiles,qnofiles,' ${WRKSRC}/queue_repair.py
.endif