aboutsummaryrefslogtreecommitdiffstats
path: root/mail/roundcube-html5_notifier
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-05 17:19:16 +0800
committermiwi <miwi@FreeBSD.org>2014-06-05 17:19:16 +0800
commit08d11723c95acb1c848ed8f2e6fa9724aa976414 (patch)
treef616685ba149704e615f46f74e2b96ed8d350d71 /mail/roundcube-html5_notifier
parentb4b75196a19b5f8763007791e3197a3cc77818e4 (diff)
downloadfreebsd-ports-gnome-08d11723c95acb1c848ed8f2e6fa9724aa976414.tar.gz
freebsd-ports-gnome-08d11723c95acb1c848ed8f2e6fa9724aa976414.tar.zst
freebsd-ports-gnome-08d11723c95acb1c848ed8f2e6fa9724aa976414.zip
HTML5_Notifier is a Roundcube plugin. It displays Desktop Notifications
like the ones you might know from Google Mail. Just keep Roundcube opened in a (minimized) tab and enjoy getting notifications every time a new mail arrives. WWW: http://stremlau.net/html5_notifier/ PR: ports/190053 Submitted by: Koichiro IWAO <meta+ports@vmeta.jp>
Diffstat (limited to 'mail/roundcube-html5_notifier')
-rw-r--r--mail/roundcube-html5_notifier/Makefile39
-rw-r--r--mail/roundcube-html5_notifier/distinfo2
-rw-r--r--mail/roundcube-html5_notifier/pkg-descr6
-rw-r--r--mail/roundcube-html5_notifier/pkg-plist19
4 files changed, 66 insertions, 0 deletions
diff --git a/mail/roundcube-html5_notifier/Makefile b/mail/roundcube-html5_notifier/Makefile
new file mode 100644
index 000000000000..5d75ea7c0dac
--- /dev/null
+++ b/mail/roundcube-html5_notifier/Makefile
@@ -0,0 +1,39 @@
+# Created by: Koichiro IWAO <meta+ports@vmeta.jp>
+# $FreeBSD$
+
+PORTNAME= html5_notifier
+PORTVERSION= 0.5.2
+CATEGORIES= mail
+PKGNAMEPREFIX= roundcube-
+
+MAINTAINER= meta+ports@vmeta.jp
+COMMENT= HTML5 desktop notifier plugin for roundcube
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= roundcube>=1.0:${PORTSDIR}/mail/roundcube
+BUILD_DEPENDS= roundcube>=1.0:${PORTSDIR}/mail/roundcube
+
+USE_GITHUB= yes
+GH_ACCOUNT= kitist
+GH_PROJECT= html5_notifier
+GH_TAGNAME= v${PORTVERSION}
+GH_COMMIT= 968f570
+
+NO_BUILD= yes
+
+WWWDIR= ${PREFIX}/www/roundcube/plugins/${PORTNAME}
+
+x-generate-plist: build
+ cd ${WRKSRC}; \
+ ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," >${WRKDIR}/pkg-plist.tmp ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
+ -e "s,^\.,@dirrm %%WWWDIR%%," >>${WRKDIR}/pkg-plist.tmp
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-html5_notifier/distinfo b/mail/roundcube-html5_notifier/distinfo
new file mode 100644
index 000000000000..ce5a4fb62499
--- /dev/null
+++ b/mail/roundcube-html5_notifier/distinfo
@@ -0,0 +1,2 @@
+SHA256 (html5_notifier-0.5.2.tar.gz) = 99df20dd8dbecb4bded8da7574f9c9e9605df68a8b2f5cf5fda2927959d5e5af
+SIZE (html5_notifier-0.5.2.tar.gz) = 8002
diff --git a/mail/roundcube-html5_notifier/pkg-descr b/mail/roundcube-html5_notifier/pkg-descr
new file mode 100644
index 000000000000..c756eceaff1d
--- /dev/null
+++ b/mail/roundcube-html5_notifier/pkg-descr
@@ -0,0 +1,6 @@
+HTML5_Notifier is a Roundcube plugin. It displays Desktop Notifications
+like the ones you might know from Google Mail. Just keep Roundcube
+opened in a (minimized) tab and enjoy getting notifications every
+time a new mail arrives.
+
+WWW: http://stremlau.net/html5_notifier/
diff --git a/mail/roundcube-html5_notifier/pkg-plist b/mail/roundcube-html5_notifier/pkg-plist
new file mode 100644
index 000000000000..458b4811c41e
--- /dev/null
+++ b/mail/roundcube-html5_notifier/pkg-plist
@@ -0,0 +1,19 @@
+%%WWWDIR%%/.gitignore
+%%WWWDIR%%/README.md
+%%WWWDIR%%/changelog.txt
+%%WWWDIR%%/composer.json
+%%WWWDIR%%/config/config.inc.php.dist
+%%WWWDIR%%/html5_notifier.js
+%%WWWDIR%%/html5_notifier.php
+%%WWWDIR%%/images/new_mail.png
+%%WWWDIR%%/localization/de_DE.inc
+%%WWWDIR%%/localization/en_US.inc
+%%WWWDIR%%/localization/es_ES.inc
+%%WWWDIR%%/localization/fr_FR.inc
+%%WWWDIR%%/localization/ja_JP.inc
+%%WWWDIR%%/localization/nl_NL.inc
+%%WWWDIR%%/localization/sk_SK.inc
+@dirrm %%WWWDIR%%/localization
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/config
+@dirrmtry %%WWWDIR%%