aboutsummaryrefslogtreecommitdiffstats
path: root/mail/roundcube
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-03-06 14:28:02 +0800
committerlinimon <linimon@FreeBSD.org>2007-03-06 14:28:02 +0800
commite57886b074a698119693e24cee5963c3b3627954 (patch)
treea571ee3db5061e2d4a3329e73930432969ba48ce /mail/roundcube
parente8d109eb4834142d5f00defae6ed7da5e4961289 (diff)
downloadfreebsd-ports-gnome-e57886b074a698119693e24cee5963c3b3627954.tar.gz
freebsd-ports-gnome-e57886b074a698119693e24cee5963c3b3627954.tar.zst
freebsd-ports-gnome-e57886b074a698119693e24cee5963c3b3627954.zip
Use the new facility of bsd.port.mk to be able to simplify the interaction
of USE_PHP and OPTIONS. PR: ports/106557 Submitted by: ale Hat: portmgr
Diffstat (limited to 'mail/roundcube')
-rw-r--r--mail/roundcube/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index ae6752ab50ba..3767021727b1 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -49,18 +49,11 @@ REINPLACE_ARGS= -i ""
MAIL= mail
.endif
PLIST_SUB+= MAIL=${MAIL}
-LOCALBASE?= /usr/local
-
-.if exists(${LOCALBASE}/etc/php.conf)
-.include "${LOCALBASE}/etc/php.conf"
-.endif
OPTIONS= MYSQL "Use MySQL backend" on \
- PGSQL "Use PostgreSQL backend" off
-.if defined(PHP_VER) && ${PHP_VER} == 5
-OPTIONS+= SQLITE "Use SQLite backend" off
-.endif
-OPTIONS+= SPELLCHECK "Enable spellchecking" off \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend (php5 only)" off \
+ SPELLCHECK "Enable spellchecking" off \
LOCALCHECK "Install internal spellchecker" off
.include <bsd.port.pre.mk>
@@ -93,11 +86,6 @@ PLIST_SUB+= SPELLCHECK=""
PLIST_SUB+= SPELLCHECK="@comment "
.endif
-# Avoid INDEX breakage when WITHOUT_MYSQL is defined.
-USE_PHP?= yes
-
-.include "${PORTSDIR}/Mk/bsd.php.mk"
-
.if defined(WITH_LOCALCHECK)
post-extract:
@${CP} ${FILESDIR}/spellchecker.php ${WRKSRC}