aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sendmail
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-06-15 12:37:19 +0800
committerdinoex <dinoex@FreeBSD.org>2006-06-15 12:37:19 +0800
commit5fb0d52ffb2f4fc53c0ac04b208a00a3d1d2fdd5 (patch)
tree68a24917fed512568cf67aa368b1a07cbfb41228 /mail/sendmail
parent42fcb22c40df9f0e71c870762a071b0156e09e4f (diff)
downloadfreebsd-ports-gnome-5fb0d52ffb2f4fc53c0ac04b208a00a3d1d2fdd5.tar.gz
freebsd-ports-gnome-5fb0d52ffb2f4fc53c0ac04b208a00a3d1d2fdd5.tar.zst
freebsd-ports-gnome-5fb0d52ffb2f4fc53c0ac04b208a00a3d1d2fdd5.zip
- Apply Patch for shared memory
http://www.sendmail.org/releases/8.13.7.html#ERRATA
Diffstat (limited to 'mail/sendmail')
-rw-r--r--mail/sendmail/Makefile1
-rw-r--r--mail/sendmail/files/patch-queue.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 39fbbc11567f..4c1cbb81616b 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sendmail
PORTVERSION= 8.13.7
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
diff --git a/mail/sendmail/files/patch-queue.c b/mail/sendmail/files/patch-queue.c
new file mode 100644
index 000000000000..3c059265f939
--- /dev/null
+++ b/mail/sendmail/files/patch-queue.c
@@ -0,0 +1,18 @@
+Index: queue.c
+===================================================================
+RCS file: /cvs/sendmail/queue.c,v
+retrieving revision 8.954
+retrieving revision 8.954.2.2
+diff -u -r8.954 -r8.954.2.2
+--- sendmail/queue.c 22 Apr 2006 01:07:00 -0000 8.954
++++ sendmail/queue.c 14 Jun 2006 21:50:56 -0000 8.954.2.2
+@@ -6695,8 +6695,7 @@
+ static time_t nextupdate = 0;
+
+ #if SM_CONF_SHM
+- /* only the daemon updates this structure */
+- if (ShmId == SM_SHM_NO_ID || DaemonPid != CurrentPid)
++ if (ShmId == SM_SHM_NO_ID && DaemonPid != CurrentPid)
+ return;
+ #endif /* SM_CONF_SHM */
+ now = curtime();