aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sentinel/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2003-09-07 22:09:23 +0800
committerache <ache@FreeBSD.org>2003-09-07 22:09:23 +0800
commit980ae151e8e4b35a2868b521895503709526d673 (patch)
tree18e77b2ffdb7e014b9477f683b27a42250bc5b28 /mail/sentinel/Makefile
parenta1d09837a8842522e6a9fd00bd2037b328a9e477 (diff)
downloadfreebsd-ports-gnome-980ae151e8e4b35a2868b521895503709526d673.tar.gz
freebsd-ports-gnome-980ae151e8e4b35a2868b521895503709526d673.tar.zst
freebsd-ports-gnome-980ae151e8e4b35a2868b521895503709526d673.zip
Add pkg-message about INPUT_MAIL_FILTER
Check for libmilter.a presence Remove 000. prefix on rc.d script installation
Diffstat (limited to 'mail/sentinel/Makefile')
-rw-r--r--mail/sentinel/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index b89a108b4f2e..bc0433dee513 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sentinel
PORTVERSION= 1.6.5b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= smfilter
@@ -19,6 +19,10 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_REINPLACE= yes
+.if !exists(/usr/lib/libmilter.a)
+IGNORE= requires Sendmail 8.12; upgrade the base system
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|:/var|:${PREFIX}/var|g' ${WRKSRC}/sentinel.cf.SAMPLE
@@ -33,11 +37,14 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sentinel ${PREFIX}/sbin
@${MKDIR} ${PREFIX}/var/sentinel
${CHOWN} smmsp:smmsp ${PREFIX}/var/sentinel
- ${INSTALL_DATA} ${FILESDIR}/000.sentinel.sh ${PREFIX}/etc/rc.d/000.sentinel.sh-dist
+ ${INSTALL_DATA} ${FILESDIR}/000.sentinel.sh ${PREFIX}/etc/rc.d/sentinel.sh-dist
${INSTALL_DATA} ${WRKSRC}/sentinel.cf.SAMPLE ${PREFIX}/etc/sentinel.cf.dist
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>