aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sentinel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-25 19:41:17 +0800
committermarino <marino@FreeBSD.org>2015-03-25 19:41:17 +0800
commit7a3c09c8629c7b7c365ea80e46d946d1da82663c (patch)
tree6d2ffbb1407cdb4a2e3486ad1b3832d701cce999 /mail/sentinel
parent2cdc49d75ec39e3aa9a1f18bc0ccd327f6c00e99 (diff)
downloadfreebsd-ports-gnome-7a3c09c8629c7b7c365ea80e46d946d1da82663c.tar.gz
freebsd-ports-gnome-7a3c09c8629c7b7c365ea80e46d946d1da82663c.tar.zst
freebsd-ports-gnome-7a3c09c8629c7b7c365ea80e46d946d1da82663c.zip
mail category: Remove $PTHREAD_LIBS
Note: The following ports did not pass check-plist (CP) or stage-qa (QA) tests. The sendmail port has many problems, but this was already known by myself as I fixed it properly on DPorts last week. It's a forward action to submit a PR against mail/sendmail. * antivirus-milter (CP) * dk-milter (CP) * milter-regex (CP) * sendmail (CP, QA) approved by: PTHREAD blanket
Diffstat (limited to 'mail/sentinel')
-rw-r--r--mail/sentinel/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index 0eb54d9332da..c5c5e4c729dd 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -28,10 +28,9 @@ CFLAGS+= -DDO_NOT_DECODE_SUBJECT
.endif
do-build:
- cd ${WRKSRC} && \
- ${CC} ${CFLAGS} ${PTHREAD_CFLAGS} \
- -o ${PORTNAME} ${PORTNAME}.c ${LDFLAGS} \
- -lmilter -lpcre -lpcreposix ${PTHREAD_LIBS}
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${CC} ${CFLAGS} -o ${PORTNAME} sentinel.c ${LDFLAGS} \
+ -lmilter -lpcre -lpcreposix -lpthread)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sentinel ${STAGEDIR}${PREFIX}/sbin/