aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamdyke/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-03-22 19:59:29 +0800
committerwxs <wxs@FreeBSD.org>2008-03-22 19:59:29 +0800
commitfa1788fe207bc349489e93e56be7c2dd1e6b3e8c (patch)
tree1e6b31c5006b3299acf96a2cda180a09a2ab5b52 /mail/spamdyke/Makefile
parent4abac3c29205b4986e5bc4c45db8b8b4893d255f (diff)
downloadfreebsd-ports-gnome-fa1788fe207bc349489e93e56be7c2dd1e6b3e8c.tar.gz
freebsd-ports-gnome-fa1788fe207bc349489e93e56be7c2dd1e6b3e8c.tar.zst
freebsd-ports-gnome-fa1788fe207bc349489e93e56be7c2dd1e6b3e8c.zip
spamdyke is a filter for monitoring and intercepting SMTP
connections between a remote host and a qmail server. Spam is blocked while the remote server (spammer) is still connected; no additional processing or storage is needed. In addition to all of its anti-spam filters, spamdyke also includes a number of features to enhance qmail. Best of all, using spamdyke does not require patching or recompiling qmail! PR: ports/119579 Submitted by: Peter Kieser <peter@kieser.ca> Approved by: garga (mentor)
Diffstat (limited to 'mail/spamdyke/Makefile')
-rw-r--r--mail/spamdyke/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/mail/spamdyke/Makefile b/mail/spamdyke/Makefile
new file mode 100644
index 000000000000..835e00752bd9
--- /dev/null
+++ b/mail/spamdyke/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: spamdyke
+# Date created: 11 January 2007
+# Whom: Peter Kieser <peter@kieser.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamdyke
+PORTVERSION= 3.1.6
+CATEGORIES= mail
+MASTER_SITES= http://www.spamdyke.org/releases/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= peter@kieser.ca
+COMMENT= A filter for monitoring and intercepting SMTP connections on qmail
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/spamdyke
+
+USE_QMAIL= yes
+GNU_CONFIGURE= yes
+
+ALL_TARGET= spamdyke
+
+PLIST_FILES= bin/spamdyke
+
+OPTIONS= TLS "Enable TLS support" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_TLS)
+CONFIGURE_ARGS+= --disable-tls
+.else
+CONFIGURE_ARGS+= --enable-tls
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changelog.txt FAQ.html GNUGPL.txt INSTALL.txt \
+ README.html README_ip_file_format.html \
+ README_rdns_directory_format.html README_rdns_file_format.html \
+ UPGRADING.txt
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR}/${DISTNAME}/documentation && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#^CFLAGS :=.*#CFLAGS = ${CFLAGS}#' ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/spamdyke ${PREFIX}/bin
+
+.include <bsd.port.post.mk>