aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamdyke/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2012-01-10 10:54:08 +0800
committerwxs <wxs@FreeBSD.org>2012-01-10 10:54:08 +0800
commite9d90f3daf3422c50ed1eabc7f52d12487357a25 (patch)
tree892e1ebd5a8c9265e831986e179175a3e265ce2d /mail/spamdyke/Makefile
parent447a526e3c7675a6bc66def9c523e12d5659a63e (diff)
downloadfreebsd-ports-gnome-e9d90f3daf3422c50ed1eabc7f52d12487357a25.tar.gz
freebsd-ports-gnome-e9d90f3daf3422c50ed1eabc7f52d12487357a25.tar.zst
freebsd-ports-gnome-e9d90f3daf3422c50ed1eabc7f52d12487357a25.zip
Set IGNORE if building with clang. This port uses nested functions which
are a gcc extension and not supported by clang yet (if ever).
Diffstat (limited to 'mail/spamdyke/Makefile')
-rw-r--r--mail/spamdyke/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/mail/spamdyke/Makefile b/mail/spamdyke/Makefile
index df7ebf784108..01e02fd3ef4e 100644
--- a/mail/spamdyke/Makefile
+++ b/mail/spamdyke/Makefile
@@ -29,6 +29,10 @@ OPTIONS= TLS "Enable TLS support" On \
.include <bsd.port.pre.mk>
+.if ${CC:T:Mclang} == "clang"
+IGNORE= uses nested functions, not supported by clang
+.endif
+
.if defined(WITHOUT_TLS)
CONFIGURE_ARGS+= --disable-tls
.else