aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamilter/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-06-11 13:54:37 +0800
committerdinoex <dinoex@FreeBSD.org>2004-06-11 13:54:37 +0800
commit8a3599c6799a09972ed8c444b7241c3ae3ff6490 (patch)
tree3ecc4ef7929da235564a9eb592fca6d46187f6bf /mail/spamilter/Makefile
parentfcfb9a7deea4b3d2dd604ed11cb994f32d2cc4a2 (diff)
downloadfreebsd-ports-gnome-8a3599c6799a09972ed8c444b7241c3ae3ff6490.tar.gz
freebsd-ports-gnome-8a3599c6799a09972ed8c444b7241c3ae3ff6490.tar.zst
freebsd-ports-gnome-8a3599c6799a09972ed8c444b7241c3ae3ff6490.zip
Spamilter is a Sendmail milter written entierly in C, and therefore
is faster and less cpu intensive than other interperative based solutions. It blocks spam using the following methods; * Configurable Realtime DNS Blacklists * Sender Address verification * Configurable Black and White lists * Invalid MTA hostname verfication * Basic Virus/Worm file attachment rejection for files ending in .pif, .scr, etc.. via MsExtChk filter * SPF via libspf Also; * Realtime firewall blocking of MTA hosts with invalid host names via MtaHostIpfw filter * Realtime rate limited connection blocking via firewall rule injection All actions are logged via syslog with both the sender and the recipient. From this, report generation and notification to recipients showing activity becomes extremely simple. WWW: http://www.wanlink.com/spamilter/index.php
Diffstat (limited to 'mail/spamilter/Makefile')
-rw-r--r--mail/spamilter/Makefile100
1 files changed, 100 insertions, 0 deletions
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
new file mode 100644
index 000000000000..3df7e1ec1cb6
--- /dev/null
+++ b/mail/spamilter/Makefile
@@ -0,0 +1,100 @@
+# New ports collection makefile for: spamilter
+# Date created: 21. Apr 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamilter
+PORTVERSION= 0.59
+CATEGORIES= mail
+MASTER_SITES= http://www.wanlink.com/spamilter/download/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= A Sendmail LibMilter filter to block spam
+
+.if !defined(SENDMAIL_MILTER_IN_BASE)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
+LDFLAGS+= ${PTHREAD_LIBS}
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+BINFILES= spamilter-system-report spamilter-user-report
+DOCSFILES= Changelog INSTALL LICENSE docs/docs.html docs/docs.txt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+ALL_TARGET= spamilter dnsblchk mxlookup iflookup
+.else
+PLIST_FILES+= bin/ipfwmtad
+.endif
+.if ${OSVERSION} > 501000
+BROKEN= resource starvation in threads
+.endif
+
+.if !defined(SENDMAIL_MILTER_IN_BASE)
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --sendmail_dir ${LOCALBASE}
+.endif
+#CFLAGS+= -DDEBUG_TIMESTAMP
+
+PLIST_FILES+= bin/dnsblchk bin/mxlookup bin/spamilter \
+ bin/spamilter-system-report bin/spamilter-user-report \
+ etc/rc.d/milter-spamilter.sh.sample
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%DOCSDIR%%/Changelog %%DOCSDIR%%/INSTALL %%DOCSDIR%%/LICENSE
+PLIST_FILES+= %%DOCSDIR%%/docs.html %%DOCSDIR%%/docs.txt
+PLIST_DIRS+= %%DOCSDIR%%
+.endif
+
+.if defined(SENDMAIL_WITHOUT_MILTER)
+pre-fetch:
+ @${ECHO_MSG}
+ @${ECHO_MSG} You must unset variable SENDMAIL_WITHOUT_MILTER,
+ @${ECHO_MSG} and rebuild sendmail in the ports
+ @${FALSE}
+.endif
+
+pre-configure:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=" ${FILESDIR}/spamilter.sh \
+ > ${WRKSRC}/spamilter.sh
+ ${REINPLACE_CMD} \
+ -e "s=/etc/spamilter.rc=${PREFIX}/etc/spamilter.rc=" \
+ ${WRKSRC}/spamilter.c \
+ ${WRKSRC}/docs/docs.html ${WRKSRC}/docs/docs.txt
+
+post-configure:
+ ${REINPLACE_CMD} \
+ -e "s|^CFLAGS=|#CFLAGS=|" \
+ -e "s|^LDFLAGS=|#LDFLAGS=|" \
+ -e "s|^LIBDIRS=|#LIBDIRS=|" \
+ -e "s|/usr/local/bind|${LOCALBASE}/bind|" \
+ -e "s|/usr/local/|${PREFIX}/|" \
+ ${WRKSRC}/Makefile
+.if ${OSVERSION} > 500000
+ ${REINPLACE_CMD} \
+ -e "s| install-ipfwmtad | |" \
+ ${WRKSRC}/Makefile
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/spamilter.sh \
+ ${PREFIX}/etc/rc.d/milter-spamilter.sh.sample
+.for i in ${BINFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCSFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.post.mk>