aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spampd
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2015-09-09 22:02:06 +0800
committerdes <des@FreeBSD.org>2015-09-09 22:02:06 +0800
commit15caa8e3a5bbee409d90484144d28b8c42215808 (patch)
tree2ce71c6de16ce9e085104aab48f261e7aff81ee4 /mail/spampd
parent609e3fd3df0a59b4bc27156e3397fd3d51a4bb39 (diff)
downloadfreebsd-ports-gnome-15caa8e3a5bbee409d90484144d28b8c42215808.tar.gz
freebsd-ports-gnome-15caa8e3a5bbee409d90484144d28b8c42215808.tar.zst
freebsd-ports-gnome-15caa8e3a5bbee409d90484144d28b8c42215808.zip
Fix rc script so status and restart work.
Diffstat (limited to 'mail/spampd')
-rw-r--r--mail/spampd/Makefile2
-rw-r--r--mail/spampd/files/spampd.in22
2 files changed, 3 insertions, 21 deletions
diff --git a/mail/spampd/Makefile b/mail/spampd/Makefile
index 7e9a6c445097..ed6b1d73f71f 100644
--- a/mail/spampd/Makefile
+++ b/mail/spampd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= spampd
PORTVERSION= 2.42
+PORTREVISION= 1
CATEGORIES= mail perl5
MAINTAINER= des@FreeBSD.org
@@ -17,6 +18,7 @@ NO_BUILD= yes
PLIST_FILES= sbin/spampd
USES= perl5 shebangfix
SHEBANG_FILES= spampd.pl
+SUB_LIST= PERL=${PERL}
USE_RC_SUBR= spampd
USE_GITHUB= yes
diff --git a/mail/spampd/files/spampd.in b/mail/spampd/files/spampd.in
index ce60c2c7e0c6..3e96197e5517 100644
--- a/mail/spampd/files/spampd.in
+++ b/mail/spampd/files/spampd.in
@@ -24,27 +24,7 @@ load_rc_config $name
command="%%PREFIX%%/sbin/$name"
command_args="--pid=${spampd_pidfile}"
+command_interpreter=%%PERL%%
pidfile="${spampd_pidfile}"
-sig_stop="KILL"
-stop_cmd="stop_cmd"
-status_cmd="status_cmd"
-
-stop_cmd()
-{
- if [ -f "$pidfile" ]; then
- kill `cat $pidfile`
- rm -f $pidfile
- echo -n " spampd"
- fi
-}
-
-status_cmd()
-{
- if [ -f "$pidfile" ]; then
- echo "${name} is running as pid `cat $pidfile`."
- else
- echo "${name} is not running."
- fi
-}
run_rc_command $1