aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamstats/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-04-07 14:51:44 +0800
committerleeym <leeym@FreeBSD.org>2003-04-07 14:51:44 +0800
commit9b10b44668e9db6dd62cab2084564da8d357b59e (patch)
tree53587db5bc2116f00a37cf90621943200c4a5ade /mail/spamstats/Makefile
parent89620e7ada0da5cefcb64f1c2dd7e148136f7d1c (diff)
downloadfreebsd-ports-gnome-9b10b44668e9db6dd62cab2084564da8d357b59e.tar.gz
freebsd-ports-gnome-9b10b44668e9db6dd62cab2084564da8d357b59e.tar.zst
freebsd-ports-gnome-9b10b44668e9db6dd62cab2084564da8d357b59e.zip
add spamstats-0.4b
a tool to generate statistics on a {exim/postfix/sendmail}/spamd system.
Diffstat (limited to 'mail/spamstats/Makefile')
-rw-r--r--mail/spamstats/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/spamstats/Makefile b/mail/spamstats/Makefile
new file mode 100644
index 000000000000..d3318659e6bd
--- /dev/null
+++ b/mail/spamstats/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: spamstats
+# Date created: 14 March 2003
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamstats
+PORTVERSION= 0.4b
+CATEGORIES= mail
+MASTER_SITES= http://www.gryzor.com/tools/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A tool to generate statistics for spamd of Mail::SpamAssassin
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's,/mail.log,/maillog,g' ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl ${PREFIX}/bin/${PORTNAME}.pl
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in QUICK README copyright
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>