aboutsummaryrefslogtreecommitdiffstats
path: root/mail/spamstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-26 15:33:41 +0800
committeraz <az@FreeBSD.org>2013-07-26 15:33:41 +0800
commit665183f53eb74ec3fb00d82d5e4d998804f85ad2 (patch)
treee2c71147def7c03ff268350288657b4e7692d180 /mail/spamstats
parente80ef1fc474e04a3b1999f45fd39114572d34f44 (diff)
downloadfreebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.tar.gz
freebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.tar.zst
freebsd-ports-gnome-665183f53eb74ec3fb00d82d5e4d998804f85ad2.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'mail/spamstats')
-rw-r--r--mail/spamstats/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/spamstats/Makefile b/mail/spamstats/Makefile
index 8a0546119ee5..fa4bfab53b54 100644
--- a/mail/spamstats/Makefile
+++ b/mail/spamstats/Makefile
@@ -19,9 +19,12 @@ USE_PERL5= yes
NO_BUILD= yes
PORTDOCS= QUICK README copyright
PLIST_FILES= bin/spamstats.pl
+USES= shebangfix
+SHEBANG_FILES= ${PORTNAME}${PORTVERSION}.pl
post-patch:
- @${PERL} -pi.bak -e 's,/mail.log,/maillog,g' ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
+ @${REINPLACE_CMD} -i '' -e 's|mail.log|maillog|g' \
+ ${WRKSRC}/${PORTNAME}${PORTVERSION}.pl
.include <bsd.port.options.mk>