aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail-newuser_wiz-plugin
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-27 00:35:16 +0800
committerpav <pav@FreeBSD.org>2006-06-27 00:35:16 +0800
commitc2339b1604fa170caea8bbe5ea1e194ce90bfc05 (patch)
treeb4a14ea0e4f07c42991a8423615c8d167a8a4c11 /mail/squirrelmail-newuser_wiz-plugin
parenta371ae7ae0bb94ad6aec9c40dba506a61caa17d8 (diff)
downloadfreebsd-ports-gnome-c2339b1604fa170caea8bbe5ea1e194ce90bfc05.tar.gz
freebsd-ports-gnome-c2339b1604fa170caea8bbe5ea1e194ce90bfc05.tar.zst
freebsd-ports-gnome-c2339b1604fa170caea8bbe5ea1e194ce90bfc05.zip
User is forced to enter Full Name and Email Address prior to reading
or composing after logging in. This is used for users who log in for the first time and need to set up their prefs prior to getting started. WWW: http://www.squirrelmail.org/plugin_view.php?id=181 PR: ports/99213 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
Diffstat (limited to 'mail/squirrelmail-newuser_wiz-plugin')
-rw-r--r--mail/squirrelmail-newuser_wiz-plugin/Makefile72
-rw-r--r--mail/squirrelmail-newuser_wiz-plugin/distinfo3
-rw-r--r--mail/squirrelmail-newuser_wiz-plugin/pkg-descr6
-rw-r--r--mail/squirrelmail-newuser_wiz-plugin/pkg-plist13
4 files changed, 94 insertions, 0 deletions
diff --git a/mail/squirrelmail-newuser_wiz-plugin/Makefile b/mail/squirrelmail-newuser_wiz-plugin/Makefile
new file mode 100644
index 000000000000..3764e105800e
--- /dev/null
+++ b/mail/squirrelmail-newuser_wiz-plugin/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: squirrelmail-newuser_wiz-plugin
+# Date created: 2006-06-20
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.3.2
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= Force user to enter Full name and Email address at initial logon
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= newuser_wiz
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+.ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+.else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+.endif
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-newuser_wiz-plugin/distinfo b/mail/squirrelmail-newuser_wiz-plugin/distinfo
new file mode 100644
index 000000000000..574632bdc4ca
--- /dev/null
+++ b/mail/squirrelmail-newuser_wiz-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/newuser_wiz-1.3.2.tar.gz) = 2615bf52679c5e577b7aba4949aa3e36
+SHA256 (squirrelmail/newuser_wiz-1.3.2.tar.gz) = 2e02d39f70751342f71a9ce0850083b9fa204738425ac4e979ad827bdc16dec7
+SIZE (squirrelmail/newuser_wiz-1.3.2.tar.gz) = 3563
diff --git a/mail/squirrelmail-newuser_wiz-plugin/pkg-descr b/mail/squirrelmail-newuser_wiz-plugin/pkg-descr
new file mode 100644
index 000000000000..0871dac5baa5
--- /dev/null
+++ b/mail/squirrelmail-newuser_wiz-plugin/pkg-descr
@@ -0,0 +1,6 @@
+User is forced to enter Full Name and Email Address prior to reading
+or composing after logging in. This is used for users who log in
+for the first time and need to set up their prefs prior to getting
+started.
+
+WWW: http://www.squirrelmail.org/plugin_view.php?id=181
diff --git a/mail/squirrelmail-newuser_wiz-plugin/pkg-plist b/mail/squirrelmail-newuser_wiz-plugin/pkg-plist
new file mode 100644
index 000000000000..bc1147ae0cfd
--- /dev/null
+++ b/mail/squirrelmail-newuser_wiz-plugin/pkg-plist
@@ -0,0 +1,13 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin newuser_wiz; fi
+%%SQUIRRELDIR%%/plugins/newuser_wiz/functions.php
+%%SQUIRRELDIR%%/plugins/newuser_wiz/setup.php
+%%SQUIRRELDIR%%/plugins/newuser_wiz/README
+%%SQUIRRELDIR%%/plugins/newuser_wiz/version
+%%SQUIRRELDIR%%/plugins/newuser_wiz/index.php
+%%SQUIRRELDIR%%/plugins/newuser_wiz/INSTALL
+%%SQUIRRELDIR%%/plugins/newuser_wiz/xgetpot
+%%SQUIRRELDIR%%/plugins/newuser_wiz/wiz_submit.php
+%%SQUIRRELDIR%%/plugins/newuser_wiz/newuser_wiz_sample.po
+%%SQUIRRELDIR%%/plugins/newuser_wiz/newuser_wiz.pot
+@dirrm %%SQUIRRELDIR%%/plugins/newuser_wiz
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin newuser_wiz; fi