aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail-qmailadmin_login-plugin
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2012-11-10 09:37:24 +0800
committeradamw <adamw@FreeBSD.org>2012-11-10 09:37:24 +0800
commitadf70ef576bab82cebe6e9a082774e31c9125a3b (patch)
tree45fdb1d9af176a1041803788fbf5c9c2a0db4cbd /mail/squirrelmail-qmailadmin_login-plugin
parentf6bb6044d9f5ffd5d278869f2d514524111c1b83 (diff)
downloadfreebsd-ports-gnome-adf70ef576bab82cebe6e9a082774e31c9125a3b.tar.gz
freebsd-ports-gnome-adf70ef576bab82cebe6e9a082774e31c9125a3b.tar.zst
freebsd-ports-gnome-adf70ef576bab82cebe6e9a082774e31c9125a3b.zip
Convert remaining squirrelmail plugins to bsd.squirrelmail.mk. Because they
were duplicating the content there, php version mismatches were created and package building broke. Also includes a few whitespace and header fixes due to OCD. Feature safe: yes
Diffstat (limited to 'mail/squirrelmail-qmailadmin_login-plugin')
-rw-r--r--mail/squirrelmail-qmailadmin_login-plugin/Makefile75
-rw-r--r--mail/squirrelmail-qmailadmin_login-plugin/files/pkg-message.in4
2 files changed, 11 insertions, 68 deletions
diff --git a/mail/squirrelmail-qmailadmin_login-plugin/Makefile b/mail/squirrelmail-qmailadmin_login-plugin/Makefile
index 383ec961b5a5..4dcc62a08453 100644
--- a/mail/squirrelmail-qmailadmin_login-plugin/Makefile
+++ b/mail/squirrelmail-qmailadmin_login-plugin/Makefile
@@ -1,75 +1,18 @@
-# New ports collection makefile for: squirrelmail-qmailadmin_login-plugin
-# Date created: 9 Dec 2006
-# Whom: Gerrit Beine <gerrit.beine@gmx.de>
-#
+# Created by: Gerrit Beine <gerrit.beine@gmx.de>
# $FreeBSD$
-PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
-PORTVERSION= 1.1
+PORTNAME= qmailadmin_login
+PORTVERSION= 1.1
PORTREVISION= 2
-CATEGORIES= mail www
-MASTER_SITES= http://www.squirrelmail.org/plugins/
-DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}-1.4.3
-DIST_SUBDIR= squirrelmail
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1.4.3
+DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Using the QmailAdmin cgi interface from SquirrelMail
-RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
+SQUIRREL_PLUGIN_NAME= ${PORTNAME}
-SQUIRREL_PLUGIN_NAME= qmailadmin_login
-.ifdef SQUIRRELDIR
-PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
-SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
-.else
-. ifndef WITHOUT_WWWDIR
-SQUIRRELDIR= ${PREFIX}/www/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
-SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
-. else
-SQUIRRELDIR= ${PREFIX}/squirrelmail
-PLIST_SUB+= SQUIRRELDIR=squirrelmail
-SUB_LIST+= "SQUIRRELDIR=squirrelmail"
-. endif
-.endif
-
-SUB_FILES= pkg-message
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_PERL5_BUILD= yes
-USE_PHP= yes
-WANT_PHP_WEB= yes
-
-pre-everything::
- @${ECHO} ""
-.ifndef WITHOUT_ACTIVATE
- @${ECHO} "Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you don't want to automatically activate the plug-in set"
- @${ECHO} "WITHOUT_ACTIVATE=yes"
-.else
- @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
- @${ECHO} "If you want to automatically activate the plug-in unset"
- @${ECHO} "WITHOUT_ACTIVATE"
-.endif
- @${ECHO} ""
-
-do-install:
- ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
-
-post-install:
-.ifndef WITHOUT_ACTIVATE
-.if exists( ${SQUIRRELDIR}/config/config.php )
- @${ECHO} "Activating plug-in in SquirrelMail"
- ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
-.endif
-.else
- @${ECHO} "To activate the plug-in in SquirrelMail use"
- @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
-.endif
- @${ECHO} ""
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/mail/squirrelmail/bsd.squirrelmail.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-qmailadmin_login-plugin/files/pkg-message.in b/mail/squirrelmail-qmailadmin_login-plugin/files/pkg-message.in
index d2f34e38e113..e34a820fe51e 100644
--- a/mail/squirrelmail-qmailadmin_login-plugin/files/pkg-message.in
+++ b/mail/squirrelmail-qmailadmin_login-plugin/files/pkg-message.in
@@ -1,5 +1,5 @@
For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/qmailadmin_login/config_default.php
+%%SQUIRRELDIR%%/plugins/qmailadmin_login/config_default.php
to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/qmailadmin_login/config.php
+%%SQUIRRELDIR%%/plugins/qmailadmin_login/config.php
and edit the configuration to meet your needs.