aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail-websearch-plugin
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2013-12-09 02:59:35 +0800
committeradamw <adamw@FreeBSD.org>2013-12-09 02:59:35 +0800
commitefae09a75e40b7650cf41636fa0e8699ef9ae31d (patch)
treebc716771127abae434b8aff46551e491a89f926c /mail/squirrelmail-websearch-plugin
parent5a9f52b808240fff65ed9a1897f73b4291434bad (diff)
downloadfreebsd-ports-gnome-efae09a75e40b7650cf41636fa0e8699ef9ae31d.tar.gz
freebsd-ports-gnome-efae09a75e40b7650cf41636fa0e8699ef9ae31d.tar.zst
freebsd-ports-gnome-efae09a75e40b7650cf41636fa0e8699ef9ae31d.zip
Create a generic PKGMESSAGE, and use it where appropriate.
Make sure that bsd.port.pre.mk is included before bsd.squirrelmail.mk. For ports with maintainers, I haven't switched you to the new PKGMESSAGE, but I have corrected paths in pkg-message.in where necessary. I also got a little over-zealous in cleaning redundant definitions from the headers. Apologies in advance if this rubs you the wrong way.
Diffstat (limited to 'mail/squirrelmail-websearch-plugin')
-rw-r--r--mail/squirrelmail-websearch-plugin/Makefile12
-rw-r--r--mail/squirrelmail-websearch-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-websearch-plugin/pkg-plist2
3 files changed, 10 insertions, 9 deletions
diff --git a/mail/squirrelmail-websearch-plugin/Makefile b/mail/squirrelmail-websearch-plugin/Makefile
index 80d13cf5c92a..82f2f25a5af9 100644
--- a/mail/squirrelmail-websearch-plugin/Makefile
+++ b/mail/squirrelmail-websearch-plugin/Makefile
@@ -5,17 +5,23 @@ PORTNAME= websearch
PORTVERSION= 0.1.6
PORTREVISION= 1
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
-DIST_SUBDIR= squirrelmail
MAINTAINER= ports@FreeBSD.org
COMMENT= Plugin for Websearch
LICENSE= GPLv2
-RUN_DEPENDS+= ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+USE_SM_COMPAT= yes
+USE_GENERIC_PKGMESSAGE= yes
SQUIRREL_PLUGIN_NAME= web_search
+SQUIRREL_PLUGIN_CONFIG= ${SQUIRREL_PLUGIN_NAME}.conf.php
NO_STAGE= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/${_SMSRCDIR}/${SQUIRREL_PLUGIN_CONFIG}.dist ${WRKSRC}/${_SMSRCDIR}/${SQUIRREL_PLUGIN_CONFIG}.sample
+
+.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-websearch-plugin/files/pkg-message.in b/mail/squirrelmail-websearch-plugin/files/pkg-message.in
deleted file mode 100644
index fa109fa20163..000000000000
--- a/mail/squirrelmail-websearch-plugin/files/pkg-message.in
+++ /dev/null
@@ -1,5 +0,0 @@
-For the port to work properly you must copy the file
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
-to
-%%PREFIX%%/%%SQUIRRELDIR%%/plugins/web_search/config.php
-and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-websearch-plugin/pkg-plist b/mail/squirrelmail-websearch-plugin/pkg-plist
index 1ae0dd952326..80fa64ab3fb1 100644
--- a/mail/squirrelmail-websearch-plugin/pkg-plist
+++ b/mail/squirrelmail-websearch-plugin/pkg-plist
@@ -4,6 +4,6 @@
%%SQUIRRELDIR%%/plugins/web_search/hooks.php
%%SQUIRRELDIR%%/plugins/web_search/setup.php
%%SQUIRRELDIR%%/plugins/web_search/version
-%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.dist
+%%SQUIRRELDIR%%/plugins/web_search/web_search.conf.php.sample
@dirrm %%SQUIRRELDIR%%/plugins/web_search/
@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin web_search; fi