aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-01-13 23:59:50 +0800
committerclement <clement@FreeBSD.org>2004-01-13 23:59:50 +0800
commit84b8f2b46782ffbec1e1bc1327d8c98dac9f526a (patch)
tree2098824cdbec9ba8623e8fc44e4a7154538245cf /mail/squirrelmail/Makefile
parent4711b959b3b08d276fb6fa620f40a2bf69986859 (diff)
downloadfreebsd-ports-gnome-84b8f2b46782ffbec1e1bc1327d8c98dac9f526a.tar.gz
freebsd-ports-gnome-84b8f2b46782ffbec1e1bc1327d8c98dac9f526a.tar.zst
freebsd-ports-gnome-84b8f2b46782ffbec1e1bc1327d8c98dac9f526a.zip
- fix *squirrelmail ports.
- add slaveport-target - fix INDEX build - add forgotten file Approved by: erwin (mentor)
Diffstat (limited to 'mail/squirrelmail/Makefile')
-rw-r--r--mail/squirrelmail/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 075c18a5df72..c7136f84e9c6 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -38,22 +38,30 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB+= PORTVERSION=${PORTVERSION} \
SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}"
+.if !defined(MASTERDIR)
+MASTERDIR= ${.CURDIR}
+.endif
+
pre-everything::
@${ECHO_CMD} "SquirrelMail is installed into ${SQUIRRELDIR}"
@${ECHO_CMD} "To use the old location ${PREFIX}/squirrelmail define"
@${ECHO_CMD} "WITHOUT_WWWDIR when patching or installing"
@${ECHO_CMD}
-post-patch:
+.if !target(slaveport-post-patch)
+slaveport-post-patch:
+.endif
+
+post-patch: slaveport-post-patch
.ifndef PATCH_DEBUG
- @${RM} ${WRKSRC}/config/config_default.php.orig
+ @${RM} -f ${WRKSRC}/config/config_default.php.orig
.endif
@${SED} -e "s;%%SQUIRRELDIR%%;${SQUIRRELDIR};g" \
- ${.CURDIR}/pkg-install > ${PKGINSTALL}
+ ${MASTERDIR}/pkg-install > ${PKGINSTALL}
@${SED} -e "s;%%SQUIRRELDIR%%;${SQUIRRELDIR};g" \
- ${.CURDIR}/pkg-deinstall > ${PKGDEINSTALL}
+ ${MASTERDIR}/pkg-deinstall > ${PKGDEINSTALL}
@${SED} -e "s;%%SQUIRRELDIR%%;${SQUIRRELDIR};g" \
- ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+ ${MASTERDIR}/pkg-message > ${PKGMESSAGE}
# Rearrange the documentation
do-build: