aboutsummaryrefslogtreecommitdiffstats
path: root/mail/squirrelmail
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-03-01 03:28:23 +0800
committeradamw <adamw@FreeBSD.org>2014-03-01 03:28:23 +0800
commit5f08829b7e5f0291fe968657e74eb95deadc3852 (patch)
tree7560807c410a4588aa29ba1df455028cf7553013 /mail/squirrelmail
parentabbd6a7d9f09bf065d72dd9c97a0117c753fdafa (diff)
downloadfreebsd-ports-gnome-5f08829b7e5f0291fe968657e74eb95deadc3852.tar.gz
freebsd-ports-gnome-5f08829b7e5f0291fe968657e74eb95deadc3852.tar.zst
freebsd-ports-gnome-5f08829b7e5f0291fe968657e74eb95deadc3852.zip
STAGE makes it a bit tricky to specify permissions and ownership
on directories. It looks like chown in the plist and chmod in do-install does the right thing. PORTREVISION bump as ownership on some folders has changed. The chmod in the plist seems to be a NO-OP but I'm leaving them in in case they magically work in the future.
Diffstat (limited to 'mail/squirrelmail')
-rw-r--r--mail/squirrelmail/Makefile6
-rw-r--r--mail/squirrelmail/pkg-plist4
2 files changed, 8 insertions, 2 deletions
diff --git a/mail/squirrelmail/Makefile b/mail/squirrelmail/Makefile
index 33df747c5588..ea007467b4e3 100644
--- a/mail/squirrelmail/Makefile
+++ b/mail/squirrelmail/Makefile
@@ -3,6 +3,7 @@
PORTNAME= squirrelmail
PORTVERSION= 20131229
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= adamw/squirrelmail
@@ -38,7 +39,9 @@ USERS= ${SMUSER}
GROUPS= ${SMGROUP}
PLIST_SUB= PORTVERSION=${PORTVERSION} \
- SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}" \
+ SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}" \
+ SMUSER=${SMUSER} \
+ SMGROUP=${SMGROUP}
SUB_FILES= pkg-message
SUB_LIST= SQUIRRELDIR=${SQUIRRELDIR} SMUSER=${SMUSER} SMGROUP=${SMGROUP}
@@ -99,7 +102,6 @@ do-install:
cd ${WRKSRC} && \
${FIND} attach class config data functions help images include locale plugins po scripts src themes \
| ${CPIO} -pdmu --quiet ${STAGEDIR}${SQUIRRELDIR}
- ${CHOWN} ${SMUSER}:${SMGROUP} ${STAGEDIR}${SQUIRRELDIR}/data ${STAGEDIR}${SQUIRRELDIR}/attach
${CHMOD} 730 ${STAGEDIR}${SQUIRRELDIR}/attach
${CHMOD} 750 ${STAGEDIR}${SQUIRRELDIR}/data
diff --git a/mail/squirrelmail/pkg-plist b/mail/squirrelmail/pkg-plist
index 24d950db4f66..f9a792580161 100644
--- a/mail/squirrelmail/pkg-plist
+++ b/mail/squirrelmail/pkg-plist
@@ -1,5 +1,7 @@
etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/attach/.htaccess
+@exec chown %%SMUSER%%:%%SMGROUP%% %B
+@exec chmod 730 %B
%%SQUIRRELDIR%%/class/.htaccess
%%SQUIRRELDIR%%/class/deliver/Deliver.class.php
%%SQUIRRELDIR%%/class/deliver/Deliver_IMAP.class.php
@@ -32,6 +34,8 @@ etc/periodic/daily/111.clean-squirrelmail
%%SQUIRRELDIR%%/data/default_pref-dist
@exec if [ ! -f %D/www/squirrelmail/data/default_pref ]; then cp -p %D/%F %B/default_pref; fi
%%SQUIRRELDIR%%/data/index.php
+@exec chown %%SMUSER%%:%%SMGROUP%% %B
+@exec chmod 750 %B
%%SQUIRRELDIR%%/functions/.htaccess
%%SQUIRRELDIR%%/functions/abook_database.php
%%SQUIRRELDIR%%/functions/abook_ldap_server.php