aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sqwebmail
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-03-21 22:37:46 +0800
committeroliver <oliver@FreeBSD.org>2006-03-21 22:37:46 +0800
commit466ff63de62174888e7bd724f3dd8c5f4e834973 (patch)
treee4cfa36a50152e5fc5076fcd51d07789982e359a /mail/sqwebmail
parent6eabc84d56d7564a3c4e318e0148e7b3b2b95f00 (diff)
downloadfreebsd-ports-gnome-466ff63de62174888e7bd724f3dd8c5f4e834973.tar.gz
freebsd-ports-gnome-466ff63de62174888e7bd724f3dd8c5f4e834973.tar.zst
freebsd-ports-gnome-466ff63de62174888e7bd724f3dd8c5f4e834973.zip
make gdbm chooseable (OPTIONS)
use a cache file to speed up configure
Diffstat (limited to 'mail/sqwebmail')
-rw-r--r--mail/sqwebmail/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index 7491c99f75b5..0f238dcb420b 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -14,13 +14,15 @@ MASTER_SITE_SUBDIR= courier
MAINTAINER= oliver@FreeBSD.org
COMMENT= CGI Webmail client for Maildirs
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include"
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
OPTIONS= CACHEDIR "Cache logins" on \
+ GDBM "Use gdbm db instead of system bdb" off \
GZIP "Compress messages with gzip" on \
HTTPS "Generate https:// URLs for all accesses" off \
HTTPS_LOGIN "Generate https:// URLs only for login" off \
@@ -81,7 +83,8 @@ CONFIGURE_ARGS= --enable-cgibindir=${PREFIX}/${CGIBINDIR}/${CGIBINSUBDIR} \
--enable-imageurl=/${IMAGEURL} \
--with-locking-method=fcntl \
--with-libintl-prefix=${LOCALBASE} \
- --with-libiconv-prefix=${LOCALBASE}
+ --with-libiconv-prefix=${LOCALBASE} \
+ --cache-file=${WRKDIR}/sqwebmail.cache
PLIST_SUB+= CGIBINDIR=${CGIBINDIR} \
CGIBINSUBDIR=${CGIBINSUBDIR} \
@@ -188,6 +191,13 @@ CONFIGURE_ARGS+= --enable-autopurge=${WITH_AUTOPURGE}
CONFIGURE_ARGS+= --enable-maxpurge=${WITH_MAXPURGE}
.endif
+.if defined(WITH_GDBM)
+CONFIGURE_ARGS+=--with-db=gdbm
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+.else
+CONFIGURE_ARGS+=--with-db=db
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|LIBPCRE=-lpcre|LIBPCRE="-L${LOCALBASE}/lib -lpcre"|g' \
${WRKSRC}/maildir/configure