aboutsummaryrefslogtreecommitdiffstats
path: root/mail/swaks
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-11-28 18:35:42 +0800
committermiwi <miwi@FreeBSD.org>2006-11-28 18:35:42 +0800
commita0c8610efe7a24ba625121c6b03926dee4ef5016 (patch)
tree6bb7f6127e6d35afe28df7e34d5b2177cc96797e /mail/swaks
parent85d35b2b2e021bf21275ae49921849ccd68fdfde (diff)
downloadfreebsd-ports-gnome-a0c8610efe7a24ba625121c6b03926dee4ef5016.tar.gz
freebsd-ports-gnome-a0c8610efe7a24ba625121c6b03926dee4ef5016.tar.zst
freebsd-ports-gnome-a0c8610efe7a24ba625121c6b03926dee4ef5016.zip
- Add OPTIONS to the Makefile with optional dependencies for
MX lookup, TLS and AUTH NTLM support PR: 105944 Submitted by: "Beat Gaetzi" <beat@chruetertee.ch> (maintainer)
Diffstat (limited to 'mail/swaks')
-rw-r--r--mail/swaks/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/mail/swaks/Makefile b/mail/swaks/Makefile
index a0ddce62f6ea..7068d4b70a90 100644
--- a/mail/swaks/Makefile
+++ b/mail/swaks/Makefile
@@ -17,8 +17,26 @@ COMMENT= Swiss Army Knife SMTP transaction tester
PLIST_FILES= bin/${PORTNAME}
+OPTIONS= PERL_NET_DNS "Add MX lookup support" off \
+ PERL_NET_SSLEAY "Add TLS support" off \
+ PERL_AUTHEN_NTLM "Add support for AUTH NTLM" off
+
USE_PERL5_RUN= yes
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERL_NET_DNS)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+.endif
+
+.if defined(WITH_PERL_NET_SSLEAY)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+.endif
+
+.if defined(WITH_PERL_AUTHEN_NTLM)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Authen/NTLM.pm:${PORTSDIR}/security/p5-Authen-NTLM
+.endif
+
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKSRC}
@@ -33,4 +51,4 @@ do-install:
${DESTDIR}${PREFIX}/bin/${PORTNAME}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>