aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sylpheed/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-11-24 05:33:32 +0800
committeralane <alane@FreeBSD.org>2002-11-24 05:33:32 +0800
commitbb4f4376141a3c3d835d55911200e1f8e5cae7b0 (patch)
tree8ccd427572fd412cb66005df9f63e047ae54f9be /mail/sylpheed/Makefile
parente4ceb30013411e1c0246569601c0ebe14ccfdb70 (diff)
downloadfreebsd-ports-gnome-bb4f4376141a3c3d835d55911200e1f8e5cae7b0.tar.gz
freebsd-ports-gnome-bb4f4376141a3c3d835d55911200e1f8e5cae7b0.tar.zst
freebsd-ports-gnome-bb4f4376141a3c3d835d55911200e1f8e5cae7b0.zip
Maintainer update.
- move the manual to a proper location ($DOCSDIR [/usr/X11R6/share/doc/sylpheed] instead of /usr/X11R6/share/sylpheed) - install manual and faq only if NOPORTDOCS isn't specified PR: 45654 Submitted by: maintainer
Diffstat (limited to 'mail/sylpheed/Makefile')
-rw-r--r--mail/sylpheed/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 137ccdd214e9..ed00bca9ba21 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -71,6 +71,11 @@ CONFIGURE_ARGS+=--enable-ssl
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
+
+MAKEFILES= Makefile.in ac/Makefile.in faq/Makefile.in faq/de/Makefile.in \
+ faq/en/Makefile.in faq/es/Makefile.in faq/fr/Makefile.in \
+ faq/it/Makefile.in manual/Makefile.in manual/en/Makefile.in \
+ manual/ja/Makefile.in src/Makefile.in
pre-everything::
@${ECHO} ""
@@ -91,6 +96,17 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-lresolv||g' ${WRKSRC}/configure
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = ac po intl src manual faq$$|SUBDIRS = ac po intl src|g' \
+ ${WRKSRC}/Makefile.in
+.else
+.for i in ${MAKEFILES}
+ @${REINPLACE_CMD} -e 's|^faqdir = @faqdir@$$|faqdir = ${DOCSDIR}/faq|g; \
+ s|^manualdir = @manualdir@$$|manualdir = ${DOCSDIR}/manual|g' \
+ ${WRKSRC}/${i}
+.endfor
+.endif
+
pre-build:
${LN} -sf ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}/libtool