aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sylpheed/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-02-07 00:51:19 +0800
committeroliver <oliver@FreeBSD.org>2005-02-07 00:51:19 +0800
commitc28aac04511acd47f5190fb1be11513d1d522b6e (patch)
treee384aa48ca9e0dbb4613b75f939914ebe0b474b6 /mail/sylpheed/Makefile
parent30775797bf89035f9cd53f98ef2130757e6c7e12 (diff)
downloadfreebsd-ports-gnome-c28aac04511acd47f5190fb1be11513d1d522b6e.tar.gz
freebsd-ports-gnome-c28aac04511acd47f5190fb1be11513d1d522b6e.tar.zst
freebsd-ports-gnome-c28aac04511acd47f5190fb1be11513d1d522b6e.zip
update to 1.0.1
Diffstat (limited to 'mail/sylpheed/Makefile')
-rw-r--r--mail/sylpheed/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 283d945f5b35..23ac45b4c9e5 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= sylpheed
-PORTVERSION= 1.0.0.r.1
-PORTREVISION= 1
+PORTVERSION= 1.0.1
+PORTREVISION= 0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:mime/} \
http://sylpheed.good-day.net/sylpheed/:source \
@@ -27,7 +27,7 @@ USE_GMAKE= yes
USE_ICONV= yes
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme03.9:${PORTSDIR}/security/gpgme03
+LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
@@ -106,8 +106,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lresolv||g; s|-lpisock\"|-liconv &|g; \
- s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
+ s|-lresolv||g; s|-lpisock\"|-liconv &|g; ' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|mime\.types|sylpheed-mime\.types|g' \
${WRKSRC}/src/procmime.c