aboutsummaryrefslogtreecommitdiffstats
path: root/mail/sylpheed
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /mail/sylpheed
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'mail/sylpheed')
-rw-r--r--mail/sylpheed/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 9225e945602f..8928ed784570 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -26,9 +26,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
# Sylpheed needs pthread if GnomeVFS is installed (GtkFileChooser uses it)
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ARGS= --enable-ipv6 \
--prefix=${PREFIX} \
--with-libintl-prefix=${LOCALBASE} \