aboutsummaryrefslogtreecommitdiffstats
path: root/mail/teapop
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-28 20:19:12 +0800
committeredwin <edwin@FreeBSD.org>2003-08-28 20:19:12 +0800
commit4c35139a56ea5e0f472ae9d102f6c57fa9a98c4f (patch)
treeb5d96f930a250171d3730f38be2022baa1413d86 /mail/teapop
parent7a8b461f063552e354d87136add5881a7d4fc3ed (diff)
downloadfreebsd-ports-gnome-4c35139a56ea5e0f472ae9d102f6c57fa9a98c4f.tar.gz
freebsd-ports-gnome-4c35139a56ea5e0f472ae9d102f6c57fa9a98c4f.tar.zst
freebsd-ports-gnome-4c35139a56ea5e0f472ae9d102f6c57fa9a98c4f.zip
[orphaned port] mail/teapop: use USE_OPENLDAP and USE_MYSQL
Use new USE_OPENLDAP and USE_MYSQL in mail/teapop Makefile PR: ports/56027 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'mail/teapop')
-rw-r--r--mail/teapop/Makefile34
1 files changed, 5 insertions, 29 deletions
diff --git a/mail/teapop/Makefile b/mail/teapop/Makefile
index cc9615b947b7..c7a5b78d6f57 100644
--- a/mail/teapop/Makefile
+++ b/mail/teapop/Makefile
@@ -55,48 +55,24 @@ CONFIGURE_ARGS+= --enable-popauth-file=${POPAUTH_FILE}
MAN8= teapop.8
-.include <bsd.port.pre.mk>
-
## Authentication backend
-## WITH_LDAP: add support for authentication through OpenLDAP server
-## WITH_LDAP_VER: OpenLDAP version to use (can be: 20 for 2.0, 21 for 2.1, 22 for 2.2 ; default 21)
+## WITH_OPENLDAP: add support for authentication through OpenLDAP server
## WITH_MYSQL: enable support for authentication from MySQL database
-## WITH_MYSQL_VER: MySQL version to use (can be: 323 for 3.23, 40 for 4.0, 4.1 for 4.1 ; default 323)
## WITH_PGSQL: enable support for authentication from PostgreSQL database
-MYSQL323_LIBVER=10
-MYSQL40_LIBVER= 12
-MYSQL41_LIBVER= 14
-WITH_LDAP_VER?= 21
-
-# MySQL deps hack (revision 2)
-.if defined(WITH_MYSQL_VER)
-MYSQL_VER= ${WITH_MYSQL_VER}
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL_323_LIBVER})
-MYSQL_VER= 323
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL40_LIBVER})
-MYSQL_VER= 40
-.elif exists(${LOCALBASE}/lib/mysql/libmysqlclient.so.${MYSQL41_LIBVER})
-MYSQL_VER= 41
-.else
-MYSQL_VER= 323
-.endif
-
-LDAP_VER= ${WITH_LDAP_VER}
-
.if defined(WITH_PGSQL)
CONFIGURE_ARGS+= --with-pgsql
LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
.endif
.if defined(WITH_MYSQL)
+USE_MYSQL= YES
CONFIGURE_ARGS+= --with-mysql
-LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
.endif
-.if defined(WITH_LDAP)
+.if defined(WITH_OPENLDAP)
+USE_OPENLDAP= YES
CONFIGURE_ARGS+= --with-ldap=openldap
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap${LDAP_VER}-client
.endif
show-options:
@@ -110,4 +86,4 @@ post-install:
@${ECHO} "------------------------------------------------------------------------"
@${ECHO} ""
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>