aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird-esr/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-25 02:15:44 +0800
committermarcus <marcus@FreeBSD.org>2004-06-25 02:15:44 +0800
commit3db81da34bc6dcbab9b509563cf76280365af0a4 (patch)
tree6f262882127fbd324a600f483712ef7ad289ab5d /mail/thunderbird-esr/Makefile
parentc02a4c7b317f851ded81d61d97149ff4196ca468 (diff)
downloadfreebsd-ports-gnome-3db81da34bc6dcbab9b509563cf76280365af0a4.tar.gz
freebsd-ports-gnome-3db81da34bc6dcbab9b509563cf76280365af0a4.tar.zst
freebsd-ports-gnome-3db81da34bc6dcbab9b509563cf76280365af0a4.zip
Update to 0.7. A list of what's new can be found at
http://www.mozilla.org/products/thunderbird/releases. This has the same limitation that Firefox 0.9 had where it needs to be run as root first. I applied the same hacks to workaround that; however, some users may need to run thunderbird twice before it starts correctly.
Diffstat (limited to 'mail/thunderbird-esr/Makefile')
-rw-r--r--mail/thunderbird-esr/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 16a037b562b8..1048d307ddc6 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= thunderbird
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
@@ -35,6 +34,7 @@ HAS_CONFIGURE= yes
ALL_TARGET= default
USE_GNOME= gtk20 libidl
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+PKGINSTALL= ${WRKDIR}/pkg-install
NO_MTREE= yes
WRKSRC= ${WRKDIR}/mozilla
@@ -44,10 +44,6 @@ ESD_LIB= libesd.so.2
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-CONFIGURE_ENV+= WITH_REORDER=yes
-.endif # ${ARCH} == "i386"
-
.if ${ARCH} == "alpha" && ${OSVERSION} < 500035
IGNORE= "core dumps at runtime"
.endif # ${ARCH} == "alpha" && ${OSVERSION} < 500035
@@ -59,6 +55,9 @@ CONFIGURE_ENV+= WITH_DEBUG=yes
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O2
+.else
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O
.endif # defined(WITH_OPTIMIZED_CFLAGS)
.if defined(WITH_LOGGING)
@@ -104,7 +103,7 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
- @${REINPLACE_CMD} -e 's|libesd\.so\.0|${ESD_LIB}|g' \
+ @${REINPLACE_CMD} -E -e 's|libesd\.so\.[0-9]+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
${WRKSRC}/modules/libpref/src/init/all.js \
@@ -114,6 +113,8 @@ post-patch:
${WRKSRC}/configure \
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}|g' \
+ < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
@@ -121,23 +122,32 @@ pre-configure:
${FALSE}; \
fi
+post-build:
+# XXX This works around an install problem that is triggered when
+# toolkit/profile/src is built after profile/src.
+ @${TOUCH} -f ${WRKSRC}/profile/build/libprofile.so
+
pre-install:
${RM} -fr ${LOCAL_PREFIX}
+ ${MKDIR} ${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
${RM} -f ${PREFIX}/bin/thunderbird
${LN} -s ${LOCAL_PREFIX}/bin/thunderbird \
${PREFIX}/bin/thunderbird
${RM} -f ${PREFIX}/bin/thunderbird-config
- ${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
+ ${LN} -s ${LOCAL_PREFIX}/bin/thunderbird-config \
${PREFIX}/bin/thunderbird-config
${RM} -fr ${LOCAL_PREFIX}/share/idl
${RM} -fr ${LOCAL_PREFIX}/include
.for ii in mac win
.for jj in / .jar
- ${RM} -fr ${LOCAL_PREFIX}/lib/mozilla-1.6/chrome/en-${ii}${jj}
+ ${RM} -fr ${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
+ @${INSTALL_DATA} ${FILESDIR}/Extensions.rdf \
+ ${LOCAL_PREFIX}/lib/${PORTNAME}-${PORTVERSION}/extensions.port
cons-plist:
-${RM} -f ${PLIST}