aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird/files
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2012-04-25 12:51:59 +0800
committerbeat <beat@FreeBSD.org>2012-04-25 12:51:59 +0800
commit5184298a805c597276d9be495463d18a874acc73 (patch)
tree2de4cf23074750151419ef3f3cf84c58794405ae /mail/thunderbird/files
parenta32f7892de37466bc0f5640f8e4d060ff7071a00 (diff)
downloadfreebsd-ports-gnome-5184298a805c597276d9be495463d18a874acc73.tar.gz
freebsd-ports-gnome-5184298a805c597276d9be495463d18a874acc73.tar.zst
freebsd-ports-gnome-5184298a805c597276d9be495463d18a874acc73.zip
- Update to 12.0
Security: http://www.vuxml.org/freebsd/380e8c56-8e32-11e1-9580-4061862b8c22.html
Diffstat (limited to 'mail/thunderbird/files')
-rw-r--r--mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp34
-rw-r--r--mail/thunderbird/files/patch-mozilla-js-src-Makefile.in26
2 files changed, 47 insertions, 13 deletions
diff --git a/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp b/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp
new file mode 100644
index 000000000000..e7dc51335465
--- /dev/null
+++ b/mail/thunderbird/files/patch-mozilla-gfx-thebes-gfxPlatform.cpp
@@ -0,0 +1,34 @@
+--- mozilla/gfx/thebes/gfxPlatform.cpp~ 2012-02-07 11:59:39.717184907 +0000
++++ mozilla/gfx/thebes/gfxPlatform.cpp 2012-02-07 13:06:01.084668445 +0000
+@@ -446,6 +446,7 @@
+ static_cast<SourceSurface*>(srcBuffer)->Release();
+ }
+
++#ifdef MOZ_TREE_CAIRO
+ void SourceSnapshotDetached(cairo_surface_t *nullSurf)
+ {
+ gfxImageSurface* origSurf =
+@@ -453,6 +454,7 @@
+
+ origSurf->SetData(&kSourceSurface, NULL, NULL);
+ }
++#endif
+
+ RefPtr<SourceSurface>
+ gfxPlatform::GetSourceSurfaceForSurface(DrawTarget *aTarget, gfxASurface *aSurface)
+@@ -522,6 +524,7 @@
+ imgSurface->Stride(),
+ format);
+
++ #ifdef MOZ_TREE_CAIRO
+ cairo_surface_t *nullSurf =
+ cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
+ cairo_surface_set_user_data(nullSurf,
+@@ -530,6 +533,7 @@
+ NULL);
+ cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
+ cairo_surface_destroy(nullSurf);
++ #endif
+ }
+
+ srcBuffer->AddRef();
diff --git a/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in b/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
index f203d1dce232..e62d7b8202a2 100644
--- a/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
+++ b/mail/thunderbird/files/patch-mozilla-js-src-Makefile.in
@@ -1,15 +1,15 @@
---- mozilla/js/src/Makefile.in.orig 2011-07-06 05:09:22.000000000 +0200
-+++ mozilla/js/src/Makefile.in 2011-07-06 22:23:46.363233778 +0200
-@@ -416,7 +416,7 @@
- # END enclude sources for V8 dtoa
- #############################################
+--- mozilla/js/src/Makefile.in.orig 2012-03-15 20:40:13.000000000 +0100
++++ mozilla/js/src/Makefile.in 2012-03-16 10:03:18.000000000 +0100
+@@ -352,7 +352,7 @@
+ # For architectures without YARR JIT, PCRE is faster than the YARR
+ # interpreter (bug 684559).
--ifeq (,$(filter arm% sparc %86 x86_64,$(TARGET_CPU)))
-+ifeq (,$(filter arm% sparc %86 amd64 x86_64,$(TARGET_CPU)))
+-ifeq (,$(filter arm% sparc %86 x86_64 mips%,$(TARGET_CPU)))
++ifeq (,$(filter arm% sparc %86 amd64 x86_64 mips%,$(TARGET_CPU)))
- VPATH += $(srcdir)/assembler \
- $(srcdir)/assembler/wtf \
-@@ -469,6 +469,9 @@
+ VPATH += $(srcdir)/yarr/pcre \
+ $(NULL)
+@@ -418,6 +418,9 @@
else
#CPPSRCS += only_on_x86.cpp
endif
@@ -19,12 +19,12 @@
endif
ifeq (arm, $(TARGET_CPU))
#CPPSRCS += only_on_arm.cpp
-@@ -793,7 +796,7 @@
+@@ -737,7 +740,7 @@
endif # WINNT
ifeq ($(OS_ARCH),FreeBSD)
-EXTRA_LIBS += -pthread
+EXTRA_LIBS += -pthread -lc
endif
- ifeq ($(OS_ARCH),IRIX)
- ifdef USE_N32
+ ifeq ($(OS_ARCH),Linux)
+ EXTRA_LIBS += -ldl