aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird3
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2008-04-22 13:32:58 +0800
committerdelphij <delphij@FreeBSD.org>2008-04-22 13:32:58 +0800
commit1565e9061ac9ac79ff8d8ea8b7f6a498471d60e9 (patch)
tree268c6580fa1b9688c9a871611b448faef110db4f /mail/thunderbird3
parent1bfca1cccb726be3d94fbc88845495bdc191fb4f (diff)
downloadfreebsd-ports-gnome-1565e9061ac9ac79ff8d8ea8b7f6a498471d60e9.tar.gz
freebsd-ports-gnome-1565e9061ac9ac79ff8d8ea8b7f6a498471d60e9.tar.zst
freebsd-ports-gnome-1565e9061ac9ac79ff8d8ea8b7f6a498471d60e9.zip
Mask FP_X_DNML not only on i386, but also on amd64. This fixes mysterious
crashes of thunderbird with SIGFPE, one of symptom of it is that this prevents enigmail-thunderbird from being able to be used on recent FreeBSD versions with thunderbird. PR: ports/122975 Approved by: maintainer (marcus as gnome@)
Diffstat (limited to 'mail/thunderbird3')
-rw-r--r--mail/thunderbird3/Makefile2
-rw-r--r--mail/thunderbird3/files/patch-Double.cpp10
2 files changed, 6 insertions, 6 deletions
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 627ad3ef360e..b116fab70393 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 2.0.0.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird3/files/patch-Double.cpp b/mail/thunderbird3/files/patch-Double.cpp
index 5cd13e4ff4fe..ac04c24a6ac1 100644
--- a/mail/thunderbird3/files/patch-Double.cpp
+++ b/mail/thunderbird3/files/patch-Double.cpp
@@ -1,20 +1,20 @@
---- extensions/transformiix/source/base/Double.cpp.orig Thu Jan 30 09:26:46 2003
-+++ extensions/transformiix/source/base/Double.cpp Sun Nov 16 01:46:42 2003
-@@ -51,10 +51,10 @@
+--- extensions/transformiix/source/base/Double.cpp.orig 2006-06-22 12:13:00.000000000 -0700
++++ extensions/transformiix/source/base/Double.cpp 2008-04-21 14:04:37.540570448 -0700
+@@ -52,10 +52,10 @@
//A trick to handle IEEE floating point exceptions on FreeBSD - E.D.
#ifdef __FreeBSD__
#include <ieeefp.h>
-#ifdef __alpha__
-fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP;
-#else
-+#if defined(__i386__)
++#if defined(__i386__) || defined(__amd64__)
fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP|FP_X_DNML;
+#else
+fp_except_t allmask = FP_X_INV|FP_X_OFL|FP_X_UFL|FP_X_DZ|FP_X_IMP;
#endif
fp_except_t oldmask = fpsetmask(~allmask);
#endif
-@@ -75,22 +75,31 @@
+@@ -115,22 +115,31 @@
#define TX_DOUBLE_HI32_EXPMASK 0x7ff00000
#define TX_DOUBLE_HI32_MANTMASK 0x000fffff