aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-14 08:37:47 +0800
committermarcus <marcus@FreeBSD.org>2004-10-14 08:37:47 +0800
commit429a8ae39cdc9b78c11d50609a94a68306bb3aaf (patch)
treef86f549f6dca7c67c996d06fb95f75d6200b7525 /mail/thunderbird
parent5a9891199f13e389c4031691ffb40b006334cbaf (diff)
downloadfreebsd-ports-gnome-429a8ae39cdc9b78c11d50609a94a68306bb3aaf.tar.gz
freebsd-ports-gnome-429a8ae39cdc9b78c11d50609a94a68306bb3aaf.tar.zst
freebsd-ports-gnome-429a8ae39cdc9b78c11d50609a94a68306bb3aaf.zip
Fix build with Perl < 5.6.1.
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile4
-rw-r--r--mail/thunderbird/files/extra-patch-config_make-jars.pl10
2 files changed, 14 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index c9208c79a91d..d8771737fe86 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -57,6 +57,10 @@ OPTIONS= DEBUG "Build a debugging image" off \
IGNORE= "core dumps at runtime"
.endif # ${ARCH} == "alpha" && ${OSVERSION} < 500035
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
+.endif # ${PERL_LEVEL} < 500600
+
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
diff --git a/mail/thunderbird/files/extra-patch-config_make-jars.pl b/mail/thunderbird/files/extra-patch-config_make-jars.pl
new file mode 100644
index 000000000000..a558607ca459
--- /dev/null
+++ b/mail/thunderbird/files/extra-patch-config_make-jars.pl
@@ -0,0 +1,10 @@
+--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
++++ config/make-jars.pl Wed Oct 13 16:17:07 2004
+@@ -40,6 +40,7 @@
+ last if ($arg eq "--");
+ }
+ my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
++splice @ARGV, $ddindex, $#ARGV;
+
+ getopts("d:s:t:f:avlD:o:p:xz:");
+