aboutsummaryrefslogtreecommitdiffstats
path: root/mail/thunderbird
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2007-01-19 06:37:11 +0800
committermezz <mezz@FreeBSD.org>2007-01-19 06:37:11 +0800
commit62f59f2d063f45a4582c89b7395d52f6a1f29c84 (patch)
treef8d50a41b3f30d5b9df4216f07cc516f2c7f2037 /mail/thunderbird
parent97a057c1bf0dc61e4afeda42ecbcd8e098f552e4 (diff)
downloadfreebsd-ports-gnome-62f59f2d063f45a4582c89b7395d52f6a1f29c84.tar.gz
freebsd-ports-gnome-62f59f2d063f45a4582c89b7395d52f6a1f29c84.tar.zst
freebsd-ports-gnome-62f59f2d063f45a4582c89b7395d52f6a1f29c84.zip
Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was started to reproduce with least 2.10.7 version of gtk2. PR: ports/107689 Reported by: a few users Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=355248 https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1] http://bugzilla.gnome.org/show_bug.cgi?id=394525
Diffstat (limited to 'mail/thunderbird')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp18
2 files changed, 19 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 87999415623c..acd11e267ec5 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -8,6 +8,7 @@
PORTNAME= thunderbird
DISTVERSION= 1.5.0.9
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= thunderbird/releases/${DISTVERSION}/source
diff --git a/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp b/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/mail/thunderbird/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void