aboutsummaryrefslogtreecommitdiffstats
path: root/mail/tkrat2/Makefile
diff options
context:
space:
mode:
authorhoek <hoek@FreeBSD.org>1997-11-15 06:51:10 +0800
committerhoek <hoek@FreeBSD.org>1997-11-15 06:51:10 +0800
commitf8d304148d79951d232d158149770450207019c1 (patch)
tree162809a8c6d56795e1ac0fa9d82b8654aa5a0cfe /mail/tkrat2/Makefile
parentbe24a7ef07e429dd9fdcc6098f8d45aad22468a4 (diff)
downloadfreebsd-ports-gnome-f8d304148d79951d232d158149770450207019c1.tar.gz
freebsd-ports-gnome-f8d304148d79951d232d158149770450207019c1.tar.zst
freebsd-ports-gnome-f8d304148d79951d232d158149770450207019c1.zip
Tkrat, Tcl/Tk mail reader. For those Tcl fans of you, this
mail reader is for you! :) Described by submitter as "Tk-ized pine". PR: ports/4343 ports/4857 (please limit one pr per port and send followups to original pr) Submitted by: Bruce Gingery <bgingery@gtcs.com>
Diffstat (limited to 'mail/tkrat2/Makefile')
-rw-r--r--mail/tkrat2/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail/tkrat2/Makefile b/mail/tkrat2/Makefile
new file mode 100644
index 000000000000..d91728242172
--- /dev/null
+++ b/mail/tkrat2/Makefile
@@ -0,0 +1,43 @@
+# New ports collection Makefile for: TkRat
+# Version required: 1.0.5
+# Date created: 24 October 1997
+# Whom: Bruce Gingery <bgingery@gtcs.com>
+#
+# $Id$
+#
+
+DISTNAME= tkrat-1.0.5
+CATEGORIES= mail tk80
+MASTER_SITES= ftp://ftp.md.chalmers.se/pub/tkrat/ \
+ ftp://ftp.sunet.se/pub/unix/mail/tkrat/
+# NOTE: "fetch" fails on FreeBSD 2.2.1 for "no-login", but ncftp succeeds
+# from commandline, or script invocation.
+
+MAINTAINER= bgingery@gtcs.com
+
+BUILD_DEPENDS= tclsh:${PORTSDIR}/lang/tcl80
+LIB_DEPENDS= c-client\\.2\\.1:${PORTSDIR}/mail/imap-uw \
+ tk80\\.1:${PORTSDIR}/x11/tk80
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-shared=yes \
+ --with-tcl-config=${PREFIX}/lib/tcl8.0 \
+ --with-tk-config=${PREFIX}/lib/tk8.0
+
+DOCFILES= CONFIGURATION COPYRIGHT README doc/interface doc/userprocs \
+ doc/userproc.example
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Copying documents to ${PREFIX}/${PORTDOCDIR}"
+ @${MKDIR} ${PREFIX}/share/doc/tkrat
+.for f in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/tkrat
+.endfor
+.else
+ @${ECHO_MSG} "===> Not copying available documents"
+.endif
+ @${MKDIR} ${PREFIX}/lib/ratatosk
+ ${INSTALL_DATA} ${FILESDIR}/ratatoskrc ${PREFIX}/lib/ratatosk
+
+.include <bsd.port.mk>