aboutsummaryrefslogtreecommitdiffstats
path: root/mail/turba
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-12-03 10:40:12 +0800
committersteve <steve@FreeBSD.org>2001-12-03 10:40:12 +0800
commit83a9841a7c0a8ef8482c99fe0cbf8ddf39141095 (patch)
tree178b685e1b4d4b9d7d4f9fb422d04fd4c1ea085e /mail/turba
parentdc80b5a0a44103f1c0955780b95e96e470373be3 (diff)
downloadfreebsd-ports-gnome-83a9841a7c0a8ef8482c99fe0cbf8ddf39141095.tar.gz
freebsd-ports-gnome-83a9841a7c0a8ef8482c99fe0cbf8ddf39141095.tar.zst
freebsd-ports-gnome-83a9841a7c0a8ef8482c99fe0cbf8ddf39141095.zip
Adding turba version 1.0.
The Horde contact management application. PR: 32089, 32152 Submitted by: Thierry Thomas <thierry@thomas.as>
Diffstat (limited to 'mail/turba')
-rw-r--r--mail/turba/Makefile133
-rw-r--r--mail/turba/distinfo1
-rw-r--r--mail/turba/files/httpd.conf.turba32
-rw-r--r--mail/turba/files/patch-aa9
-rw-r--r--mail/turba/files/patch-ab35
-rw-r--r--mail/turba/files/patch-ac16
-rw-r--r--mail/turba/pkg-comment1
-rw-r--r--mail/turba/pkg-deinstall12
-rw-r--r--mail/turba/pkg-descr11
-rw-r--r--mail/turba/pkg-message17
-rw-r--r--mail/turba/pkg-plist176
11 files changed, 443 insertions, 0 deletions
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
new file mode 100644
index 000000000000..58bfc5427dcd
--- /dev/null
+++ b/mail/turba/Makefile
@@ -0,0 +1,133 @@
+# Ports collection makefile for: turba
+# Date created: Sat Nov 16, 2001
+# Whom: Thierry Thomas (<thierry@thomas.as>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= turba
+PORTVERSION= 1.0
+CATEGORIES= mail www
+MASTER_SITES= ftp://ftp.horde.org/pub/turba/tarballs/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-RC2
+
+MAINTAINER= thierry@thomas.as
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_LDAP : if you do not need OpenLDAP;
+# - WITH_LDAP1 : if you prefer OpenLDAP1.
+#
+# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
+#
+#-----------------------------------------------------------------------
+
+.if !defined(WITHOUT_LDAP)
+.if defined(WITH_LDAP1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap \
+ lber.1:${PORTSDIR}/net/openldap
+.else
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
+ lber.2:${PORTSDIR}/net/openldap2
+.endif
+.endif
+
+RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde-devel
+
+NO_BUILD= yes
+DOCS= COPYING README docs/CHANGES docs/CREDITS \
+ docs/INSTALL docs/turba.dia docs/turba.pdf
+CONFFILE= attributes.php conf.php html.php menu.php \
+ prefs.php sources.php
+
+LHORDEDIR?= www/horde
+LTURBADIR?= ${LHORDEDIR}/turba
+
+PLIST_SUB= HORDEDIR=${LHORDEDIR} TURBADIR=${LTURBADIR}
+
+HORDEDIR= ${PREFIX}/${LHORDEDIR}
+TURBADIR= ${PREFIX}/${LTURBADIR}
+CONFDIR= ${TURBADIR}/config
+
+APACHE_CNFDIR?= ${LOCALBASE}/etc/apache
+APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
+
+pre-install:
+# N.B.: database dependencies are binded with mod_php#, neither by Horde nor Turba.
+.if !defined(WITHOUT_SUPPORTED_DB)
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "mysqlclient.10" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "pq.2" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "sybdb.0" ; then \
+ if ! ${LDCONFIG} -r | ${GREP} -q -e "ct.0" ; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please configure PHP with a database support." ; \
+ ${ECHO_MSG} "MySQL, PostgreSQL and Sybase (CTLIB or DBLIB)" ; \
+ ${ECHO_MSG} "can be used with PHP AND Turba." ; \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "(If everything will run on this machine, do not" ; \
+ ${ECHO_MSG} " forget to install the database server-side!)" ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi ; \
+ fi ; \
+ fi ; \
+ fi
+.endif
+.if !defined(WITHOUT_LDAP)
+.if defined(WITH_LDAP1)
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "ldap.1"; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+.else
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "ldap.2"; then \
+ ${ECHO_MSG} "" ; \
+ ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
+ ${ECHO_MSG} "" ; \
+ ${FALSE} ; \
+ fi
+.endif
+.endif
+
+do-install:
+ ${MKDIR} ${TURBADIR}
+ ${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${TURBADIR}
+ ${CP} -Rp ${WRKSRC}/locale ${WRKSRC}/scripts ${WRKSRC}/templates ${TURBADIR}
+ ${CP} -Rp ${WRKSRC}/po ${TURBADIR}
+ ${CP} -p ${WRKSRC}/*.php ${TURBADIR}
+.for FILE in ${CONFFILE}
+ @if [ ! -f ${CONFDIR}/${FILE} ]; then \
+ ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
+ fi
+.endfor
+ ${CHOWN} -R www:www ${TURBADIR}
+ ${CHMOD} -R o-rwx ${CONFDIR}
+ @(if [ -f ${APACHE_CONF} ] ; then \
+ (if [ ! -f ${APACHE_CONF}.beforeTurba ] ; then \
+ ${ECHO} "===> Updating ${APACHE_CONF}..." ; \
+ ${CP} -p ${FILESDIR}/httpd.conf.turba ${WRKDIR}/httpd.conf.turba ; \
+ ${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" ${WRKDIR}/httpd.conf.turba ; \
+ ${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeTurba ; \
+ ${GREP} -qw 'Added for Turba' ${APACHE_CONF} || ${CAT} ${WRKDIR}/httpd.conf.turba >> ${APACHE_CONF} ; \
+ fi) ; \
+ fi)
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ @${ECHO} "Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE} | \
+ ${SED} -e "s:%%TURBADIR%%:${TURBADIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g;s:%%CONFDIR%%:${CONFDIR}:g;s:%%APACHE_CONF%%:${APACHE_CONF}:g"
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/mail/turba/distinfo b/mail/turba/distinfo
new file mode 100644
index 000000000000..5bdabef90faa
--- /dev/null
+++ b/mail/turba/distinfo
@@ -0,0 +1 @@
+MD5 (turba-1.0-RC2.tar.gz) = df5a7b63a9a5d6ad598d537bc57560e6
diff --git a/mail/turba/files/httpd.conf.turba b/mail/turba/files/httpd.conf.turba
new file mode 100644
index 000000000000..95683ab9cd5c
--- /dev/null
+++ b/mail/turba/files/httpd.conf.turba
@@ -0,0 +1,32 @@
+
+# Added for Turba
+#
+# For security, don't serve pages from the Turba configuration and
+# library directories.
+#
+<Directory "/home/httpd/html/horde/turba/config">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/turba/lib">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/turba/locale">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/turba/po">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/turba/scripts">
+ order deny,allow
+ deny from all
+</Directory>
+<Directory "/home/httpd/html/horde/turba/templates">
+ order deny,allow
+ deny from all
+</Directory>
+# End of Turba configuration ================
+
diff --git a/mail/turba/files/patch-aa b/mail/turba/files/patch-aa
new file mode 100644
index 000000000000..1a51d8aec31c
--- /dev/null
+++ b/mail/turba/files/patch-aa
@@ -0,0 +1,9 @@
+--- config/conf.php.dist.orig Fri Sep 28 23:29:55 2001
++++ config/conf.php.dist Sat Nov 17 21:38:00 2001
+@@ -29,5 +29,6 @@
+ // example providing a link to IMP (an email program) would be:
+ // $conf['menu']['apps'] = array('imp');
+ $conf['menu']['apps'] = array();
++//UNCOMMENTWHENINSTIMP$conf['menu']['apps'] = array('imp');
+
+ ?>
diff --git a/mail/turba/files/patch-ab b/mail/turba/files/patch-ab
new file mode 100644
index 000000000000..f76a7c518225
--- /dev/null
+++ b/mail/turba/files/patch-ab
@@ -0,0 +1,35 @@
+--- config/sources.php.dist.orig Sun Nov 4 01:42:12 2001
++++ config/sources.php.dist Sun Nov 18 17:25:08 2001
+@@ -83,21 +83,25 @@
+ 'title' => 'Local SQL',
+ 'type' => 'sql',
+ 'params' => array(
+- 'phptype' => 'pgsql',
+- 'hostspec' => '',
+- 'username' => '',
+- 'password' => '',
++// 'phptype' => 'pgsql',
++ 'phptype' => 'mysql',
++ 'hostspec' => 'localhost',
++ 'username' => 'hordemgr',
++ 'password' => 'hordemgr',
+ 'database' => 'horde',
+ 'options' => '',
+- 'tty' => '',
+- 'port' => '5432',
+- 'protocol' => 'unix',
++// 'tty' => '',
++// Default port: 5432 for pgsql (PostGres), 3306 for mysql
++// 'port' => '5432',
++// 'port' => '3306',
++// 'protocol' => 'unix',
+ 'table' => 'turba_objects'
+ ),
+ 'map' => array(
+ '__key' => 'object_id',
+ '__owner' => 'owner_id',
+ 'name' => 'object_name',
++ 'alias' => 'object_alias',
+ 'email' => 'object_email',
+ 'homeAddress' => 'object_homeAddress',
+ 'workAddress' => 'object_workAddress',
diff --git a/mail/turba/files/patch-ac b/mail/turba/files/patch-ac
new file mode 100644
index 000000000000..74914cb6d40e
--- /dev/null
+++ b/mail/turba/files/patch-ac
@@ -0,0 +1,16 @@
+--- config/prefs.php.dist.orig Mon Oct 22 09:09:23 2001
++++ config/prefs.php.dist Sun Nov 18 01:21:42 2001
+@@ -16,4 +16,13 @@
+ 'type' => 'select',
+ 'desc' => _("Select your preferred language:")
+ );
++
++// Addressbook
++$_prefs['searchsource'] = array(
++ 'value' => 'localsql',
++ 'locked' => false,
++ 'shared' => true,
++ 'type' => 'select',
++ 'desc' => _("from")
++);
+ ?>
diff --git a/mail/turba/pkg-comment b/mail/turba/pkg-comment
new file mode 100644
index 000000000000..aa37eca86b3d
--- /dev/null
+++ b/mail/turba/pkg-comment
@@ -0,0 +1 @@
+The Horde contact management application
diff --git a/mail/turba/pkg-deinstall b/mail/turba/pkg-deinstall
new file mode 100644
index 000000000000..da0aafe5b418
--- /dev/null
+++ b/mail/turba/pkg-deinstall
@@ -0,0 +1,12 @@
+#!/bin/sh
+# Try to restore httpd.conf when deinstalling Turba
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -f ${PKG_PREFIX}/etc/apache/httpd.conf.beforeTurba ] ; then
+ echo "Restoring httpd.conf..."
+ cp ${PKG_PREFIX}/etc/apache/httpd.conf ${PKG_PREFIX}/etc/apache/httpd.conf.deinstTurba
+ mv ${PKG_PREFIX}/etc/apache/httpd.conf.beforeTurba ${PKG_PREFIX}/etc/apache/httpd.conf
+fi
diff --git a/mail/turba/pkg-descr b/mail/turba/pkg-descr
new file mode 100644
index 000000000000..7c363e6d373a
--- /dev/null
+++ b/mail/turba/pkg-descr
@@ -0,0 +1,11 @@
+Turba is the Horde contact management application. It is currently in
+the development stages, and makes heavy use of the Horde framework to
+provide integration with other applications.
+
+Right now, Turba is a fairly complete basic contact management
+application. SQL and LDAP backends are available and fairly well tested.
+You can define the fields in your addressbooks in a very flexible way,
+just by changing the config files.
+And there are Horde API functions to add and search for contacts.
+
+WWW: http://horde.org/turba/
diff --git a/mail/turba/pkg-message b/mail/turba/pkg-message
new file mode 100644
index 000000000000..50c95efe8be8
--- /dev/null
+++ b/mail/turba/pkg-message
@@ -0,0 +1,17 @@
+************************************************************************
+Turba has been installed in %%TURBADIR%% with your blank
+configuration files.
+
+Horde must be configured; if not, see
+%%PORTSDIR%%/www/horde-devel/pkg-message.
+
+Then, you will have to tune the configuration files located in
+%%CONFDIR%%/, specially the files conf.php and
+sources.php.
+
+You have to create a table in your database; please see
+%%TURBADIR%%/scripts/drivers.
+
+If %%APACHE_CONF%% has been updated,
+you have to restart Apache.
+************************************************************************
diff --git a/mail/turba/pkg-plist b/mail/turba/pkg-plist
new file mode 100644
index 000000000000..a0c8d2752f6c
--- /dev/null
+++ b/mail/turba/pkg-plist
@@ -0,0 +1,176 @@
+%%PORTDOCS%%share/doc/turba/CHANGES
+%%PORTDOCS%%share/doc/turba/COPYING
+%%PORTDOCS%%share/doc/turba/CREDITS
+%%PORTDOCS%%share/doc/turba/INSTALL
+%%PORTDOCS%%share/doc/turba/README
+%%PORTDOCS%%share/doc/turba/turba.dia
+%%PORTDOCS%%share/doc/turba/turba.pdf
+%%TURBADIR%%/addobject.php
+%%TURBADIR%%/addobjectaction.php
+%%TURBADIR%%/advanced.php
+%%TURBADIR%%/config/attributes.php
+%%TURBADIR%%/config/attributes.php.dist
+%%TURBADIR%%/config/conf.php
+%%TURBADIR%%/config/conf.php.dist
+%%TURBADIR%%/config/conf.php.dist.orig
+%%TURBADIR%%/config/html.php
+%%TURBADIR%%/config/html.php.dist
+%%TURBADIR%%/config/menu.php
+%%TURBADIR%%/config/menu.php.dist
+%%TURBADIR%%/config/prefs.php
+%%TURBADIR%%/config/prefs.php.dist
+%%TURBADIR%%/config/prefs.php.dist.orig
+%%TURBADIR%%/config/sources.php
+%%TURBADIR%%/config/sources.php.dist
+%%TURBADIR%%/config/sources.php.dist.orig
+%%TURBADIR%%/config/turba.dt
+%%TURBADIR%%/data.php
+%%TURBADIR%%/deleteobject.php
+%%TURBADIR%%/displayobject.php
+%%TURBADIR%%/editobject.php
+%%TURBADIR%%/editobjectaction.php
+%%TURBADIR%%/graphics/add.gif
+%%TURBADIR%%/graphics/group.gif
+%%TURBADIR%%/graphics/search.gif
+%%TURBADIR%%/graphics/turba.gif
+%%TURBADIR%%/index.php
+%%TURBADIR%%/lib/AbstractObject.php
+%%TURBADIR%%/lib/Driver.php
+%%TURBADIR%%/lib/Driver/ldap.php
+%%TURBADIR%%/lib/Driver/sql.php
+%%TURBADIR%%/lib/Group.php
+%%TURBADIR%%/lib/List.php
+%%TURBADIR%%/lib/List/Plain.php
+%%TURBADIR%%/lib/List/Tree.php
+%%TURBADIR%%/lib/ListView.php
+%%TURBADIR%%/lib/ListView/Rolodex.php
+%%TURBADIR%%/lib/ListView/Tree.php
+%%TURBADIR%%/lib/Object.php
+%%TURBADIR%%/lib/ObjectView.php
+%%TURBADIR%%/lib/ObjectView/List.php
+%%TURBADIR%%/lib/ObjectView/PhotoID.php
+%%TURBADIR%%/lib/Source.php
+%%TURBADIR%%/lib/Turba.php
+%%TURBADIR%%/lib/api.php
+%%TURBADIR%%/lib/base.php
+%%TURBADIR%%/lib/version.php
+%%TURBADIR%%/locale/cs_CZ/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/de_DE/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/el_GR/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/es_ES/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/fr_FR/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/it_IT/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/ko_KR/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/nl_NL/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/pl_PL/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/pt_BR/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/ru_koi/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/ru_win/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/sv_SE/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/zh_CN/LC_MESSAGES/turba.mo
+%%TURBADIR%%/locale/zh_TW/LC_MESSAGES/turba.mo
+%%TURBADIR%%/menu.php
+%%TURBADIR%%/po/Makefile
+%%TURBADIR%%/po/README
+%%TURBADIR%%/po/cs_CZ.po
+%%TURBADIR%%/po/de_DE.po
+%%TURBADIR%%/po/el_GR.po
+%%TURBADIR%%/po/es_ES.po
+%%TURBADIR%%/po/extract.pl
+%%TURBADIR%%/po/fr_FR.po
+%%TURBADIR%%/po/it_IT.po
+%%TURBADIR%%/po/ko_KR.po
+%%TURBADIR%%/po/nl_NL.po
+%%TURBADIR%%/po/pl_PL.po
+%%TURBADIR%%/po/pt_BR.po
+%%TURBADIR%%/po/ru_koi.po
+%%TURBADIR%%/po/ru_win.po
+%%TURBADIR%%/po/shtool
+%%TURBADIR%%/po/sv_SE.po
+%%TURBADIR%%/po/xgettext.sh
+%%TURBADIR%%/po/zh_CN.po
+%%TURBADIR%%/po/zh_TW.po
+%%TURBADIR%%/scripts/drivers/turba.sql
+%%TURBADIR%%/search.php
+%%TURBADIR%%/status.php
+%%TURBADIR%%/templates/add/add.inc
+%%TURBADIR%%/templates/add/noadd.inc
+%%TURBADIR%%/templates/add/select.inc
+%%TURBADIR%%/templates/advanced/criteria.inc
+%%TURBADIR%%/templates/advanced/foot.inc
+%%TURBADIR%%/templates/advanced/head.inc
+%%TURBADIR%%/templates/advanced/results_head.inc
+%%TURBADIR%%/templates/common-footer.inc
+%%TURBADIR%%/templates/common-header.inc
+%%TURBADIR%%/templates/data/export.inc
+%%TURBADIR%%/templates/data/import.inc
+%%TURBADIR%%/templates/display/display.inc
+%%TURBADIR%%/templates/edit/edit.inc
+%%TURBADIR%%/templates/index/css.inc
+%%TURBADIR%%/templates/index/notconfigured.inc
+%%TURBADIR%%/templates/menu/menu.inc
+%%TURBADIR%%/templates/search/foot.inc
+%%TURBADIR%%/templates/search/head.inc
+%%TURBADIR%%/templates/search/oldrow.inc
+%%TURBADIR%%/templates/search/row.inc
+%%TURBADIR%%/templates/wml/common-footer.inc
+%%TURBADIR%%/templates/wml/common-header.inc
+%%TURBADIR%%/templates/wml/menu/menu.inc
+%%TURBADIR%%/templates/wml/search/foot.inc
+%%TURBADIR%%/templates/wml/search/head.inc
+%%TURBADIR%%/templates/wml/search/row.inc
+%%PORTDOCS%%@dirrm share/doc/turba
+@dirrm %%TURBADIR%%/config
+@dirrm %%TURBADIR%%/graphics
+@dirrm %%TURBADIR%%/lib/Driver
+@dirrm %%TURBADIR%%/lib/List
+@dirrm %%TURBADIR%%/lib/ListView
+@dirrm %%TURBADIR%%/lib/ObjectView
+@dirrm %%TURBADIR%%/lib
+@dirrm %%TURBADIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/cs_CZ
+@dirrm %%TURBADIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/de_DE
+@dirrm %%TURBADIR%%/locale/el_GR/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/el_GR
+@dirrm %%TURBADIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/es_ES
+@dirrm %%TURBADIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/fr_FR
+@dirrm %%TURBADIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/it_IT
+@dirrm %%TURBADIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/ko_KR
+@dirrm %%TURBADIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/nl_NL
+@dirrm %%TURBADIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/pl_PL
+@dirrm %%TURBADIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/pt_BR
+@dirrm %%TURBADIR%%/locale/ru_koi/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/ru_koi
+@dirrm %%TURBADIR%%/locale/ru_win/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/ru_win
+@dirrm %%TURBADIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/sv_SE
+@dirrm %%TURBADIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/zh_CN
+@dirrm %%TURBADIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%TURBADIR%%/locale/zh_TW
+@dirrm %%TURBADIR%%/locale
+@dirrm %%TURBADIR%%/po
+@dirrm %%TURBADIR%%/scripts/drivers
+@dirrm %%TURBADIR%%/scripts
+@dirrm %%TURBADIR%%/templates/add
+@dirrm %%TURBADIR%%/templates/advanced
+@dirrm %%TURBADIR%%/templates/data
+@dirrm %%TURBADIR%%/templates/display
+@dirrm %%TURBADIR%%/templates/edit
+@dirrm %%TURBADIR%%/templates/index
+@dirrm %%TURBADIR%%/templates/menu
+@dirrm %%TURBADIR%%/templates/search
+@dirrm %%TURBADIR%%/templates/wml/menu
+@dirrm %%TURBADIR%%/templates/wml/search
+@dirrm %%TURBADIR%%/templates/wml
+@dirrm %%TURBADIR%%/templates
+@dirrm %%TURBADIR%%
>-8/+12 * return correct values in g_return_val_if_fail.Rodrigo Moya2003-03-273-3/+8 * add a parameter(TC_CORBA_string) to the bonobo_widget_get_property.Jack Jia2003-03-262-1/+7 * Update for e_notice moveDan Winship2003-03-255-15/+38 * Utility wrapper around icalparser.Dan Winship2003-03-256-85/+54 * Fixes #32248JP Rosevear2003-03-222-1/+10 * Fixes #31660JP Rosevear2003-03-222-11/+88 * calcomponents are gobjects now (calconduit_load_configuration): ref andJP Rosevear2003-03-213-2/+20 * use a GtkMessageDialog and deal correctly with the dialog's reponses.Rodrigo Moya2003-03-212-4/+14 * Fixes #39770Rodrigo Moya2003-03-202-5/+15 * removed activation of shell_client. (importer_destroy_cb): no need toRodrigo Moya2003-03-202-28/+7 * removed. (load_file_fn, vcal_load_file_fn): use physical_uri instead ofRodrigo Moya2003-03-203-92/+14 * Replace "evolution:menu-name" prop with "evolution:menu_name". [#39692]Ettore Perazzoli2003-03-202-2/+8 * use GtkMessageDialog instead of gnome_question_dialog, and deal correctlyRodrigo Moya2003-03-192-4/+15 * Fixes #34505Rodrigo Moya2003-03-182-7/+34 * Fixes #34095Hans Petter Jansson2003-03-189-7/+46 * Fixes #39757Hans Petter Jansson2003-03-182-6/+18 * Fixes #39736Hans Petter Jansson2003-03-182-1/+8 * Fixes #39740Rodrigo Moya2003-03-156-342/+18 * set_release on the sequence we create.Rodrigo Moya2003-03-152-0/+4 * don't leak the string sequence returned by CalFactory_uriList.Rodrigo Moya2003-03-142-1/+8 * use a weak ref instead of connecting to backend's "destroy" signal.Rodrigo Moya2003-03-132-9/+12 * don't use GNOME_STOCK_* defines, but GTK_STOCK_*.Rodrigo Moya2003-03-132-3/+8 * corrected button ordering and changed the return type to be aRodrigo Moya2003-03-134-10/+25 * Update for timezone dialog API changes.Dan Winship2003-03-123-102/+38 * issue more descriptive warnings.Rodrigo Moya2003-03-122-2/+7 * if we already have the client loaded, don't remove it, just increment itsRodrigo Moya2003-03-103-50/+72 * create the array to be returned only once.Rodrigo Moya2003-03-072-3/+8 * ref the CalClient. (notify_dialog_cb): unref the CalClient.Rodrigo Moya2003-03-062-0/+7 * new function. (alarm_notify_dialog): made it return a pointer to theRodrigo Moya2003-03-064-37/+144 * Fixes #31382Rodrigo Moya2003-03-062-2/+10 * fix defaults and descriptions to match what calendar-config wants them toJP Rosevear2003-03-062-30/+35 * g_objectify ref/unrefJP Rosevear2003-03-054-7/+16 * override finalize, not destroy (start_calendar_server): take itip as aJP Rosevear2003-03-052-46/+138 * cast CalClient's to GObject, not GtkObject.Rodrigo Moya2003-03-052-4/+9 * don't let the user change to an email organizer if the back end is not anJP Rosevear2003-03-052-3/+11 * Fixes #37881JP Rosevear2003-03-052-2/+52 * Fixes #37881JP Rosevear2003-03-052-1/+8 * Fixes #37883JP Rosevear2003-03-052-1/+8 * Fixes #37806, #37697JP Rosevear2003-03-052-4/+14 * implementJP Rosevear2003-03-059-20/+164 * call cal_client_get_cal_address instead of cal_client_get_email_addressJP Rosevear2003-03-0510-44/+75 * fix commentJP Rosevear2003-03-052-1/+5 * update FIXME noteJP Rosevear2003-03-052-3/+6 * fix copyrightJP Rosevear2003-03-053-7/+15 * Partially Fixes #23606 (from Jack Jia <jack.jia@sun.com>)JP Rosevear2003-03-053-2/+22 * Shush.JP Rosevear2003-03-051-1/+3 * Commit missed files.JP Rosevear2003-03-052-0/+126 * If only the pipe wouldn't break.JP Rosevear2003-03-0551-2399/+3298 * Merging in 1.2 stuffJP Rosevear2003-03-053-32/+237 * Fixes #35598JP Rosevear2003-03-051-0/+463 * gui/dialogs/alarm-page.c gui/dialogs/event-page.cHans Petter Jansson2003-03-048-7/+19 * Do importers after the other dirs, as it relies on generated files fromHans Petter Jansson2003-03-022-1/+7 * Shlibify.Hans Petter Jansson2003-03-015-60/+59 * build libcal-dialogs as an uninstalled shared library ($(IDL_GENERATED_H),Dan Winship2003-03-014-13/+19 * Forgot to mention server file move.Hans Petter2003-03-011-0/+3 * Add calendar/importers/Makefile to output.Hans Petter Jansson2003-03-015-6/+20 * Remove libalarm.a, which was not being used by the calendar.Dan Winship2003-03-014-17/+23 * link to versist libtool objectJP Rosevear2003-02-283-2/+8 * This makes alarm notification work.Hans Petter Jansson2003-02-272-1/+8 * This makes creating appointments and tasks from the "New" button work.Hans Petter Jansson2003-02-272-6/+16 * Fixes Ximian #37895.Hans Petter Jansson2003-02-273-3/+13 * Fixes Ximian #38306.Hans Petter Jansson2003-02-272-19/+44 * Use fixed margins of 5% of page width/height. This is the same cheat asHans Petter Jansson2003-02-262-12/+43 * Get default view from correct key.Hans Petter Jansson2003-02-262-1/+6 * Show start/end-of-day widgets.Hans Petter Jansson2003-02-262-0/+7 * Don't warn if calendar isn't loaded... Doesn't seem to hurt, but thisHans Petter Jansson2003-02-245-5/+28 * gconf settings upgradesMichael Zucci2003-02-2413-419/+224 * dont unref accounts anymore. (change_status): itipAddress -> EAccount.Not Zed2003-02-241-1/+1 * dont unref accounts anymore. (change_status): itipAddress -> EAccount.Not Zed2003-02-242-2/+148 * Appease the compiler. (gnome_calendar_update_paned_quanta): Don't actuallyHans Petter Jansson2003-02-244-2/+34 * CVS server broke again. Here's the rest...Hans Petter Jansson2003-02-231-2/+2 * Eliminate e_utf8_to_gtk_string ().Hans Petter Jansson2003-02-237-18/+40 * Show the custom widgets, since libglade appears to not want to do that.Hans Petter Jansson2003-02-233-10/+44 * Add an iteration statement. Fixes hang in wombat.Hans Petter Jansson2003-02-232-0/+7 * Commit fixes from Grzegorz Goawski <grzegol@pld.org.pl>.Hans Petter Jansson2003-02-232-28/+35 * GObject, not GtkObject. (calendar_model_destroy): ->Hans Petter Jansson2003-02-227-30/+58 * Make libversit a shared library, update stuff for that, and clean upDan Winship2003-02-225-20/+27 * Add GConf schemas.Hans Petter Jansson2003-02-213-2/+365 * Make libemiscwidgets, libefilterbar, and libetimezonedialog dynamicDan Winship2003-02-212-2/+8 * revert previous changeDan Winship2003-02-206-22/+9 * Remove libversit. We haven't depended on that in forever.Dan Winship2003-02-206-9/+22 * Split $(CORBA_GENERATED_H) rule from the $(CORBA_GENERATED_C) rule to thatEttore Perazzoli2003-02-204-10/+23 * add .server.in filesDan Winship2003-02-201-0/+1 * Enable printing for calendar and tasks.Hans Petter Jansson2003-02-123-217/+189 * Don't use gtk_scrolled_window_set_scrollbar_spacing() anymore.Hans Petter Jansson2003-02-122-1/+5 * Don't try to make an error string from an uninitialized GnomeVFSResult.Hans Petter Jansson2003-02-112-4/+15 * Make the CORBA IDL compilation work with parallel makes. Likewise.Ettore Perazzoli2003-02-114-19/+61 * remove this file, as it's generated now Add this file to generate theRodney Dawes2003-02-083-3/+13 * Fixes #37706Rodrigo Moya2003-02-082-2/+25 * Use e_auto_kill_popup_menu_on_selection_done() instead ofEttore Perazzoli2003-02-073-2/+10 * show the widget before returning it.Dan Winship2003-02-072-1/+8 * s/PACKAGE/GETTEXT_PACKAGE/ in gettext initDan Winship2003-02-072-2/+7 * makefile and warnings fixesDan Winship2003-02-061-0/+105 * Update this some although it's not currently being builtDan Winship2003-02-061-6/+4 * Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir,Dan Winship2003-02-0613-41/+35 * Use privlibexecdir. (INCLUDES): Remove cruft. (gladedir, serversdir):Dan Winship2003-02-063-19/+11 * Remove cruft. Rename ICONSDIR to IMAGESDIR. (gladedir, etspecdir): RemoveDan Winship2003-02-066-20/+11 * Define in terms of privincludedirDan Winship2003-02-063-8/+4 * Remove cruft. (libcal_utilincludedir): Define in terms of privincludedirDan Winship2003-02-061-2/+1 * Remove cruft. (pcsincludedir): Define in terms of privincludedirDan Winship2003-02-062-3/+1 * s/BonoboXObject/BonoboObject/Dan Winship2003-02-065-18/+24 * array of localized month day names ("1st" - "31st")Dan Winship2003-02-067-75/+294 * The CVS server exited after applying everything from my last commit,Hans Petter2003-02-051-10/+22 * Rename to e_meeting_time_selector_on_invite_others_button_expose() andHans Petter Jansson2003-02-052-9/+26 * Fix badly formatted ChangeLog entry. This has been bothering me since itHans Petter2003-02-051-2/+2 * Use PangoLayout to draw text.Hans Petter Jansson2003-02-052-12/+23 * updated for e scroll frame --> gtk scrolled windowRadek Doulik2003-02-052-18/+18 * Skip setting the "font_gdk" arg for now.Hans Petter Jansson2003-02-026-0/+29 * Fixes #35572Ronald Kuetemeier2003-01-312-0/+9 * CalClient and CalComponent are GObjects.Chris Toshok2003-01-273-19/+26 * fix warning. (get_default_timezone): BonoboConfigDatabase ->Chris Toshok2003-01-27