aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail-devel
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2002-09-05 22:30:21 +0800
committerroam <roam@FreeBSD.org>2002-09-05 22:30:21 +0800
commita31d7d5ca2489a43a72c1a6a7a899369fcd3ffb6 (patch)
treedd119207f5fe0fe6ddb697b734780943149845f9 /mail/vpopmail-devel
parent105b985e22703e0fad901a72a73b03ef3d9a4f58 (diff)
downloadfreebsd-ports-gnome-a31d7d5ca2489a43a72c1a6a7a899369fcd3ffb6.tar.gz
freebsd-ports-gnome-a31d7d5ca2489a43a72c1a6a7a899369fcd3ffb6.tar.zst
freebsd-ports-gnome-a31d7d5ca2489a43a72c1a6a7a899369fcd3ffb6.zip
Update to vpopmail-5.3.8.
There are two new configuration knobs: - WITHOUT_USERS_BIG_DIR disables the use of 'big' directories for users, thereby saving a little on disk space and inode usage; IMO, the savings are negligible; - WITHOUT_SEEKABLE disables the newly introduced ability of vdelivermail to examine its input stream for seekability, and read it all into a file to make it seekable. This works quite fine in the tests that I have done, so there seems to be no need to enable it on FreeBSD; however, if things should go wrong (in particular, if delivering mail to your virtual domains seems to fail), try rebuilding vpopmail with this knob. Prompted by: David Phillips <david@acz.org>
Diffstat (limited to 'mail/vpopmail-devel')
-rw-r--r--mail/vpopmail-devel/Makefile13
-rw-r--r--mail/vpopmail-devel/distinfo2
-rw-r--r--mail/vpopmail-devel/files/patch-vchkpw.c11
3 files changed, 12 insertions, 14 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index 42fc4d779f1d..7e67388b9bc1 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.3.6
-PORTREVISION= 1
+PORTVERSION= 5.3.8
CATEGORIES= mail
MASTER_SITES= http://www.inter7.com/devel/
@@ -49,6 +48,8 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_DIR} \
# WITH_QMAIL_EXT - enables qmail-like user-* address extesions processing
# WITHOUT_FILE_LOCKING - disable file locking
# WITH_FILE_SYNC - enables immediate synching (may decrease performance)
+# WITHOUT_USERS_BIG_DIR - disables using big directories for users
+# WITHOUT_SEEKABLE - disables vdelivermail's attempt to make its input seekable
#
# Set these to the values you'd prefer
#
@@ -229,6 +230,14 @@ CONFIGURE_ARGS+= --enable-file-sync=y
CONFIGURE_ARGS+= --enable-auth-logging=n
.endif
+.if defined(WITHOUT_USERS_BIG_DIR)
+CONFIGURE_ARGS+= --enable-users-big-dir=n
+.endif
+
+.if defined(WITHOUT_SEEKABLE)
+CONFIGURE_ARGS+= --enable-make-seekable=n
+.endif
+
#
# This port doesn't honour PREFIX, it honours vpopmail's home directory.
# Since we create vpopmail if it doesn't exist, we set it so that it
diff --git a/mail/vpopmail-devel/distinfo b/mail/vpopmail-devel/distinfo
index 43e2e617c5aa..7333521b0c20 100644
--- a/mail/vpopmail-devel/distinfo
+++ b/mail/vpopmail-devel/distinfo
@@ -1 +1 @@
-MD5 (vpopmail-5.3.6.tar.gz) = 00afe01169a2ea4285548528dc7eb2bb
+MD5 (vpopmail-5.3.8.tar.gz) = 60eba65641d863a3aa2bf85b221ac05d
diff --git a/mail/vpopmail-devel/files/patch-vchkpw.c b/mail/vpopmail-devel/files/patch-vchkpw.c
deleted file mode 100644
index 7fb12ce26c91..000000000000
--- a/mail/vpopmail-devel/files/patch-vchkpw.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- vchkpw.c.orig Thu Jun 13 15:05:53 2002
-+++ vchkpw.c Thu Jun 13 15:06:16 2002
-@@ -556,7 +556,7 @@
- pw_gid = pw->pw_gid;
- pw_dir = pw->pw_dir;
- #ifdef POP_AUTH_OPEN_RELAY
-- if ( (strcmp(LocalPort, "25") != 0) && (strcmp(LocalPort, "465") != 0)) {
-+ if ( (LocalPort != 25) && (LocalPort != 465)) {
- open_smtp_relay();
- }
- #endif