aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2009-03-16 21:51:24 +0800
committerroam <roam@FreeBSD.org>2009-03-16 21:51:24 +0800
commit651c1f37d8b0f89ee14f8a2a4c45a11eeee55800 (patch)
tree6cbdf95baa5c381de0c4c9b4f189d681d58dd8f1 /mail/vpopmail/Makefile
parent6d620d1e5c3fd8c66f2cff5c363ebac8115f1876 (diff)
downloadfreebsd-ports-gnome-651c1f37d8b0f89ee14f8a2a4c45a11eeee55800.tar.gz
freebsd-ports-gnome-651c1f37d8b0f89ee14f8a2a4c45a11eeee55800.tar.zst
freebsd-ports-gnome-651c1f37d8b0f89ee14f8a2a4c45a11eeee55800.zip
Update to vpopmail-5.4.27.
Internally, use quilt for patch management. Add two Makefile knobs for the locations of the Courier IMAP server's imaplogin and imapd binaries, just in case anyone would want to test the new authvchkpw utility :)
Diffstat (limited to 'mail/vpopmail/Makefile')
-rw-r--r--mail/vpopmail/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 4ebcc576fbe3..4015b7925716 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vpopmail
-PORTVERSION= 5.4.26
-PORTREVISION= 1
+PORTVERSION= 5.4.27
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +17,8 @@ COMMENT= Easy virtual domain and authentication package for use with qmail
BUILD_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
RUN_DEPENDS= ${LOCALBASE}/bin/tcprules:${PORTSDIR}/sysutils/ucspi-tcp
+PATCH_STRIP= -p1
+
USE_QMAIL= yes
CONFLICTS= vpopmail-devel-5.*
@@ -119,6 +120,14 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_PREFIX} \
# WITH_SYBASE_APP - the app for connecting to the Sybase server (vpopmail)
# WITH_SYBASE_DB - the name of the Sybase database to connect to (vpopmail)
#
+# Courier IMAP configuration options for authvchkpw
+#
+# WARNING: This is NOT TESTED, not in the least.
+# Please report any success or failure to the port maintainer,
+# Peter Pentchev <roam@FreeBSD.org>
+#
+# WITH_COURIER_IMAPLOGIN - the path to the imaplogin program
+# WITH_COURIER_IMAPD - the path to the imapd program
RELAYCLEAR?= 30
SPAM_THRESHOLD?=15
@@ -322,10 +331,14 @@ CONFIGURE_ARGS+= --enable-spamassassin \
--enable-spamc-prog=${LOCALBASE}/bin/spamc \
--enable-spam-threshold=${SPAM_THRESHOLD}
.if defined(WITH_SPAMFOLDER)
-CONFIGURE_ARGS+= --enable-spam-junkfolder
+CONFIGURE_ARGS+= --enable-spam-junkfolder
.endif
.endif
+WITH_COURIER_IMAPLOGIN?= ${LOCALBASE}/sbin/imaplogin
+WITH_VPOPMAIL_AUTHVCHKPW?= ${PREFIX}/vpopmail/bin/authvchkpw
+WITH_COURIER_IMAPD?= ${LOCALBASE}/bin/imapd
+
DOCS= README README.activedirectory README.filelocking \
README.ipaliasdomains README.ldap README.maildrop \
README.mysql \
@@ -387,6 +400,9 @@ pre-configure:
${REINPLACE_CMD} -E -e "s/(#define SYBASE_DATABASE.*)vpopmail(.*)/\1${WITH_SYBASE_DB}\2/" ${WRKSRC}/vsybase.h
.endif
.endif
+ ${REINPLACE_CMD} -E -e "s@(#define PATH_IMAPLOGIN.*)VPOPMAILDIR.*@\1\"${WITH_COURIER_IMAPLOGIN}\"@" ${WRKSRC}/authvchkpw.c
+ ${REINPLACE_CMD} -E -e "s@(#define PATH_AUTHVCHKPW.*)VPOPMAILDIR.*@\1\"${WITH_VPOPMAIL_AUTHVCHKPW}\"@" ${WRKSRC}/authvchkpw.c
+ ${REINPLACE_CMD} -E -e "s@(#define PATH_IMAPD.*)VPOPMAILDIR.*@\1\"${WITH_COURIER_IMAPD}\"@" ${WRKSRC}/authvchkpw.c
${MKDIR} ${VCFGDIR}
post-install: