aboutsummaryrefslogtreecommitdiffstats
path: root/mail/vpopmail/files/patch-Makefile.in
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-10-05 19:49:17 +0800
committerroam <roam@FreeBSD.org>2006-10-05 19:49:17 +0800
commitaa77fcbce1b6a9de728c2055f88058dec2bda253 (patch)
tree434aa1c8a14f5df12f91bc723850c93164369778 /mail/vpopmail/files/patch-Makefile.in
parent169fb2cbad392103b1ca0289644983b4d736f382 (diff)
downloadfreebsd-ports-gnome-aa77fcbce1b6a9de728c2055f88058dec2bda253.tar.gz
freebsd-ports-gnome-aa77fcbce1b6a9de728c2055f88058dec2bda253.tar.zst
freebsd-ports-gnome-aa77fcbce1b6a9de728c2055f88058dec2bda253.zip
Update to vpopmail-5.4.17. In the process:
- add a new knob, WITH_SQL_REMOVE_DELETED, for explicitly activating the new code for removing entries from the SQL log file when a user or domain is deleted; - add real NOPORTDOCS support and install the README.* files in addition to the doc_html/ and man_html/ directories if NOPORTDOCS is not set; - fix a couple of spelling and grammar errors in the new README.vpopmaild; - add several sanity checks; - remove the last traces of the ActiveDirectory backend; - various other minor changes.
Diffstat (limited to 'mail/vpopmail/files/patch-Makefile.in')
-rw-r--r--mail/vpopmail/files/patch-Makefile.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/mail/vpopmail/files/patch-Makefile.in b/mail/vpopmail/files/patch-Makefile.in
index 832a3ad85535..6b3a5f599775 100644
--- a/mail/vpopmail/files/patch-Makefile.in
+++ b/mail/vpopmail/files/patch-Makefile.in
@@ -1,6 +1,16 @@
---- Makefile.in.orig Sat Sep 17 02:37:34 2005
-+++ Makefile.in Thu Jun 15 16:58:59 2006
-@@ -101,7 +101,6 @@
+diff -urN -x .svn ../../vendor/vpopmail/Makefile.in ./Makefile.in
+--- ../../vendor/vpopmail/Makefile.in Tue Oct 3 17:40:12 2006
++++ ./Makefile.in Wed Oct 4 15:48:16 2006
+@@ -97,7 +97,7 @@
+
+ COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c
+
+-CONFIG_CLEAN_FILES = vauth.c
++CONFIG_CLEAN_FILES = vauth.c cdb/conf-cc cdb/conf-ld cdb/compile cdb/load
+
+ MYSQLCONF = $(DESTDIR)@vpopmaildir@/etc/vpopmail.mysql
+ VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default
+@@ -106,7 +106,6 @@
libvpopmail_a_SOURCES = $(COMMONSOURCES)
libvpopmail_a_LIBADD = cdb/*.o
@@ -8,7 +18,7 @@
vpopmailbindir = @vpopmaildir@/bin
vpopmailbin_PROGRAMS = vchkpw vdelivermail clearopensmtp vadddomain \
-@@ -861,6 +860,8 @@
+@@ -880,6 +879,8 @@
echo "-L@vpopmaildir@/lib -lvpopmail @auth_libs@ @LIBS@" > \
$(DESTDIR)@vpopmaildir@/etc/lib_deps
@@ -17,7 +27,7 @@
if test ! -r $(VLIMITS); then \
$(INSTALL) -o @vpopuser@ -m 0644 -g @vpopgroup@ \
vlimits.default $(VLIMITS); \
-@@ -878,7 +879,6 @@
+@@ -897,7 +898,6 @@
echo "# settings for each line:" >> $(MYSQLCONF); \
echo "# host|port|user|password|database" >> $(MYSQLCONF); \
echo "#" >> $(MYSQLCONF); \