aboutsummaryrefslogtreecommitdiffstats
path: root/mail/wbl/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-15 21:44:11 +0800
committergarga <garga@FreeBSD.org>2006-07-15 21:44:11 +0800
commitcb7a884b73d9017332db59e1332ac6452e840a00 (patch)
tree1f77f1fda4a593f8b1fc5e14b16e0d21e796f3d3 /mail/wbl/Makefile
parentec10a1f9acd1dbfef47cb96b849190c11e60dc92 (diff)
downloadfreebsd-ports-gnome-cb7a884b73d9017332db59e1332ac6452e840a00.tar.gz
freebsd-ports-gnome-cb7a884b73d9017332db59e1332ac6452e840a00.tar.zst
freebsd-ports-gnome-cb7a884b73d9017332db59e1332ac6452e840a00.zip
wbl is a really simple tool that can be used in a .qmail file for managing
a white/black list of email addresses. It only does one thing--it checks for entries in ~/.wbl that it uses as a regex against the From: field of an incoming email. If it matches a line with a +, it forwards the email to the white list, if it matches a line with a - it forwards the email to the blacklist. Questions, feedback, comments may be sent to the author. Author: Caskey Dickson <caskey@technocage.com> WWW: http://www.technocage.com/~caskey/wbl/
Diffstat (limited to 'mail/wbl/Makefile')
-rw-r--r--mail/wbl/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/wbl/Makefile b/mail/wbl/Makefile
new file mode 100644
index 000000000000..43fc5dbaf294
--- /dev/null
+++ b/mail/wbl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: wbl
+# Date created: 2006-07-15
+# Whom: Renato Botelho <garga@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wbl
+PORTVERSION= 1.1
+CATEGORIES= mail
+MASTER_SITES= http://www.technocage.com/~caskey/wbl/download/
+
+MAINTAINER= garga@localhost.bsd
+COMMENT= Simple tool to manage white/black list on qmail
+
+USE_BZIP2= yes
+USE_PERL5_RUN= yes
+USE_QMAIL_RUN= yes
+NO_BUILD= yes
+
+PORTDOCS= CHANGELOG COPYING README
+PLIST_FILES= bin/wbl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' \
+ -e 's,/var/qmail,${QMAIL_PREFIX},g' \
+ -e 's,/bin/cat,${CAT},g' \
+ ${WRKSRC}/wbl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/wbl ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>