aboutsummaryrefslogtreecommitdiffstats
path: root/mail/wmymail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /mail/wmymail
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'mail/wmymail')
-rw-r--r--mail/wmymail/Makefile4
-rw-r--r--mail/wmymail/files/patch-Makefile6
2 files changed, 4 insertions, 6 deletions
diff --git a/mail/wmymail/Makefile b/mail/wmymail/Makefile
index 9ca7e1929615..0db07cf0e8cf 100644
--- a/mail/wmymail/Makefile
+++ b/mail/wmymail/Makefile
@@ -6,7 +6,7 @@
PORTNAME= wmymail
PORTVERSION= 0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail x11
MASTER_SITES= http://yath.mine.nu/wmymail/ \
http://dockapps.org/files/65/96/
@@ -17,8 +17,6 @@ COMMENT= Check inbox using a WindowMaker DockApp
LIB_DEPENDS= dockapp.2:${PORTSDIR}/x11-wm/libdockapp
RUN_DEPENDS= fetchmail:${PORTSDIR}/mail/fetchmail
-USE_X_PREFIX= yes
-
NOMAN=
PLIST_FILES= bin/wmymail
diff --git a/mail/wmymail/files/patch-Makefile b/mail/wmymail/files/patch-Makefile
index f2512ee08a39..98d70fa456c6 100644
--- a/mail/wmymail/files/patch-Makefile
+++ b/mail/wmymail/files/patch-Makefile
@@ -17,9 +17,9 @@
-DISTFILES = Makefile README README.old ChangeLog wmymail.c raw-envelope.jpg
+SRCS= wmymail.c
+
-+CFLAGS+= -I${X11BASE}/include -O2 -Wall
++CFLAGS+= -I${LOCALBASE}/include -O2 -Wall
+LDADD+= -lXpm -lX11 -lXext -ldockapp
-+LDADD+= -L${X11BASE}/lib
++LDADD+= -L${LOCALBASE}/lib
-default all target: wmymail
+NOMAN=
@@ -29,7 +29,7 @@
-wmymail: wmymail.o
- $(CC) $< $(CFLAGS) $(LIBS) -o $@
-+BINDIR?= ${X11BASE}/bin
++BINDIR?= ${LOCALBASE}/bin
-wmymail.o: wmymail.c $(XPMS)
- $(CC) $(CFLAGS) $(MY_INCS) -o $@ -c $<