aboutsummaryrefslogtreecommitdiffstats
path: root/mail/xpbiff
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-07-01 06:16:06 +0800
committerdanfe <danfe@FreeBSD.org>2007-07-01 06:16:06 +0800
commit956e597df4a1f8f4ecbae2d7bfd1aa1191005319 (patch)
treeebb163ee60698fe4899808cea372060a99c71ff5 /mail/xpbiff
parent4aec882196558e08a52fb6007936807c0b1854cf (diff)
downloadfreebsd-ports-gnome-956e597df4a1f8f4ecbae2d7bfd1aa1191005319.tar.gz
freebsd-ports-gnome-956e597df4a1f8f4ecbae2d7bfd1aa1191005319.tar.zst
freebsd-ports-gnome-956e597df4a1f8f4ecbae2d7bfd1aa1191005319.zip
- Fix the build with modern GCC [1]
- Unquote BROKEN message per portlint(1) Reported by: pointyhat (logs) [1]
Diffstat (limited to 'mail/xpbiff')
-rw-r--r--mail/xpbiff/Makefile2
-rw-r--r--mail/xpbiff/files/LocPixmap.c3
2 files changed, 3 insertions, 2 deletions
diff --git a/mail/xpbiff/Makefile b/mail/xpbiff/Makefile
index 72dc58d7e053..f6c080c42784 100644
--- a/mail/xpbiff/Makefile
+++ b/mail/xpbiff/Makefile
@@ -31,7 +31,7 @@ YOUBINBINDIR= ${LOCALBASE}
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not compile on !i386
.endif
do-extract:
diff --git a/mail/xpbiff/files/LocPixmap.c b/mail/xpbiff/files/LocPixmap.c
index 30d37d435079..7c89f3b5d32f 100644
--- a/mail/xpbiff/files/LocPixmap.c
+++ b/mail/xpbiff/files/LocPixmap.c
@@ -45,6 +45,8 @@
* LocatePixmapFile - read a pixmap file using the normal defaults
*/
+static char **split_path_string();
+
Pixmap LocatePixmapFile (screen, name, srcname, srcnamelen,
widthp, heightp, mask)
Screen *screen;
@@ -63,7 +65,6 @@ Pixmap LocatePixmapFile (screen, name, srcname, srcnamelen,
unsigned int width, height;
int xhot, yhot;
int i;
- static char **split_path_string();
/*