aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-07-03 01:50:00 +0800
committerdelphij <delphij@FreeBSD.org>2012-07-03 01:50:00 +0800
commit0f68acd83ecfb0a8298614da824a2f39d4a2a17f (patch)
tree1dc93bc97fa81d6cb10c32addffe978c052775c1 /mail
parent9e549730879a6118c811936dfd95fc8da1456c23 (diff)
downloadfreebsd-ports-gnome-0f68acd83ecfb0a8298614da824a2f39d4a2a17f.tar.gz
freebsd-ports-gnome-0f68acd83ecfb0a8298614da824a2f39d4a2a17f.tar.zst
freebsd-ports-gnome-0f68acd83ecfb0a8298614da824a2f39d4a2a17f.zip
* Enable support of gzip- and bzip2-compressed mbox.
PR: ports/169128 Submitted by: gjb Approved by: maintainer timeout
Diffstat (limited to 'mail')
-rw-r--r--mail/mairix/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/mail/mairix/Makefile b/mail/mairix/Makefile
index 9bbffa30cd76..fc7d422b92d7 100644
--- a/mail/mairix/Makefile
+++ b/mail/mairix/Makefile
@@ -22,6 +22,26 @@ MAN5= mairixrc.5
PLIST_FILES= bin/mairix %%EXAMPLESDIR%%/dotmairixrc.eg
PLIST_DIRS= %%EXAMPLESDIR%%
+OPTIONS_DEFINE= GZIP BZIP
+GZIP_DESC= Enable gzip mbox support
+BZIP_DESC= Enable bzip2 mbox support
+
+OPTIONS_DEFAULT=
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGZIP}
+CONFIGURE_ARGS+= --enable-gzip-mbox
+.else
+CONFIGURE_ARGS+= --disable-gzip-mbox
+.endif
+
+.if ${PORT_OPTIONS:MBZIP}
+CONFIGURE_ARGS+= --enable-bzip-mbox
+.else
+CONFIGURE_ARGS+= --disable-bzip-mbox
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mairix ${PREFIX}/bin
${MKDIR} ${EXAMPLESDIR}