aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-01-04 13:26:10 +0800
committerdinoex <dinoex@FreeBSD.org>2012-01-04 13:26:10 +0800
commit1b7444d512230a80188616b69c34e4f4b959277c (patch)
tree1270141f1474be62d02ede20d73ba4019a36d260 /mail
parent75275b5064d0e52574f638fa34903f0523f3ed22 (diff)
downloadfreebsd-ports-gnome-1b7444d512230a80188616b69c34e4f4b959277c.tar.gz
freebsd-ports-gnome-1b7444d512230a80188616b69c34e4f4b959277c.tar.zst
freebsd-ports-gnome-1b7444d512230a80188616b69c34e4f4b959277c.zip
- fix build with gcc46
Diffstat (limited to 'mail')
-rw-r--r--mail/pantomime/Makefile4
-rw-r--r--mail/pantomime/files/NSString+Extensions.m.patch19
2 files changed, 23 insertions, 0 deletions
diff --git a/mail/pantomime/Makefile b/mail/pantomime/Makefile
index 7956d35946fa..a1f1a3a83deb 100644
--- a/mail/pantomime/Makefile
+++ b/mail/pantomime/Makefile
@@ -25,4 +25,8 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
DEFAULT_LIBVERSION= 1.2
+.if !defined(WITH_GNUSTEP_DEVEL)
+EXTRA_PATCHES= ${FILESDIR}/NSString+Extensions.m.patch
+.endif
+
.include <bsd.port.mk>
diff --git a/mail/pantomime/files/NSString+Extensions.m.patch b/mail/pantomime/files/NSString+Extensions.m.patch
new file mode 100644
index 000000000000..a98522cf83d4
--- /dev/null
+++ b/mail/pantomime/files/NSString+Extensions.m.patch
@@ -0,0 +1,19 @@
+--- Framework/Pantomime/NSString+Extensions.m.orig 2011-06-05 06:45:21.000000000 +0200
++++ Framework/Pantomime/NSString+Extensions.m 2012-01-02 22:46:00.000000000 +0100
+@@ -38,7 +38,15 @@
+ #include <CoreFoundation/CFString.h>
+ #include <CoreFoundation/CFStringEncodingExt.h>
+ #else
+-#include <GNUstepBase/Additions.h>
++#import <GNUstepBase/GSVersionMacros.h>
++#import <GNUstepBase/GNUstep.h>
++
++#import <GNUstepBase/GSFunctions.h>
++#import <GNUstepBase/GSLocale.h>
++#import <GNUstepBase/GSLock.h>
++#import <GNUstepBase/GSMime.h>
++#import <GNUstepBase/GSXML.h>
++#import <GNUstepBase/Unicode.h>
+ #endif
+
+ #include <ctype.h>