aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-08 05:33:28 +0800
committermm <mm@FreeBSD.org>2011-07-08 05:33:28 +0800
commit24ac6d6c37c530c6e6b9952aea9b99d9f6796624 (patch)
treef31c79cad38906bc72c3bc1e1b4f3391b91aa380 /mail
parentd939df749b601cdd28d7f9f8c26e78c087a7e6aa (diff)
downloadfreebsd-ports-gnome-24ac6d6c37c530c6e6b9952aea9b99d9f6796624.tar.gz
freebsd-ports-gnome-24ac6d6c37c530c6e6b9952aea9b99d9f6796624.tar.zst
freebsd-ports-gnome-24ac6d6c37c530c6e6b9952aea9b99d9f6796624.zip
Update horde4-turba to new Horde 4 framework
Approved by: beech (maintainer, private chat)
Diffstat (limited to 'mail')
-rw-r--r--mail/horde4-turba/Makefile67
-rw-r--r--mail/horde4-turba/distinfo4
-rw-r--r--mail/horde4-turba/files/patch-config::sources.php.dist210
-rw-r--r--mail/horde4-turba/files/pkg-message.in21
-rw-r--r--mail/horde4-turba/pkg-descr14
-rw-r--r--mail/horde4-turba/pkg-plist399
6 files changed, 59 insertions, 656 deletions
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index b9bf7e9d27f6..f93f9ff008aa 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -6,23 +6,60 @@
#
PORTNAME= turba
-PORTVERSION= 2.3.5
-DISTVERSIONSUFFIX=
-PORTREVISION= 1
-CATEGORIES= mail www
+PORTVERSION= 3.0.4
+PKGNAMEPREFIX= horde-
+CATEGORIES= www pear
-MAINTAINER= beech@FreeBSD.org
-COMMENT= Contact management application
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Horde web based address book
-USE_HORDE= base
-USE_PHP= ldap
-USE_GETTEXT= yes
+CONFLICTS= horde-3*
-PORTDOCS= README CHANGES CREDITS INSTALL LDAP RELEASE_NOTES TODO UPGRADING
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE
-pre-patch:
- @${REINPLACE_CMD} -e "s:/usr/bin/ldapadd:${LOCALBASE}/bin/ldapadd:" \
- ${WRKSRC}/scripts/ldap/addou.pl
+OPTIONS= FACEBOOK "Support connections with Facebook" Off \
+ IMSP "Support IMSP addressbooks" Off \
+ LDAP "Support LDAP Addressbooks" Off
-.include "${.CURDIR}/../../www/horde-base/bsd.horde.mk"
-.include <bsd.port.mk>
+USE_PHP= gettext hash json
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ horde \
+ Horde_Auth \
+ Horde_Core \
+ Horde_Data \
+ Horde_Date \
+ Horde_Exception \
+ Horde_Form \
+ Horde_Group \
+ Horde_History \
+ Horde_Icalendar \
+ Horde_Mail \
+ Horde_Mime \
+ Horde_Nls \
+ Horde_Perms \
+ Horde_Prefs \
+ Horde_Serialize \
+ Horde_Share \
+ Horde_Support \
+ Horde_Url \
+ Horde_Util \
+ Horde_View
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FACEBOOK)
+USE_HORDE_RUN+= Horde_Service_Facebook
+.endif
+
+.if defined(WITH_IMSP)
+USE_HORDE_RUN+= Horde_Imsp
+.endif
+
+.if defined(WITH_LDAP)
+USE_HORDE_RUN+= Horde_Ldap
+.endif
+
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/mail/horde4-turba/distinfo b/mail/horde4-turba/distinfo
index 8adffac3050c..9b10234ce3cf 100644
--- a/mail/horde4-turba/distinfo
+++ b/mail/horde4-turba/distinfo
@@ -1,2 +1,2 @@
-SHA256 (turba-h3-2.3.5.tar.gz) = 5e11d9d3a5fe3edc46af96aeec7e587746af873e0bf8dbf3482596e4c5cce383
-SIZE (turba-h3-2.3.5.tar.gz) = 2535036
+SHA256 (Horde/turba-3.0.4.tgz) = 75a62f09277f14204b914639760c04f961edf27e2ad8462c338f1ae8f2f56c43
+SIZE (Horde/turba-3.0.4.tgz) = 2116875
diff --git a/mail/horde4-turba/files/patch-config::sources.php.dist b/mail/horde4-turba/files/patch-config::sources.php.dist
deleted file mode 100644
index aeb73b0e369d..000000000000
--- a/mail/horde4-turba/files/patch-config::sources.php.dist
+++ /dev/null
@@ -1,210 +0,0 @@
---- config/sources.php.dist.orig 2007-11-19 08:05:01.000000000 -0900
-+++ config/sources.php.dist 2007-12-03 23:35:17.000000000 -0900
-@@ -636,105 +636,108 @@
- // configuration at all - in case we don't have at least a 3.0.6 Horde
- // install. (In that case, be sure to change the params array below to suit
- // your needs.
--if (!empty($GLOBALS['conf']['imsp']['enabled']) ||
-- !isset($GLOBALS['conf']['imsp']['enabled'])) {
-- // First, get the user name to login to IMSP server with.
-- $_imsp_auth_user = $GLOBALS['prefs']->getValue('imsp_auth_user');
-- $_imsp_auth_pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
-- if (!strlen($_imsp_auth_user)) {
-- $_imsp_auth_user = Auth::getBareAuth();
-- $_imsp_auth_pass = Auth::getCredential('password');
-- }
-- $cfgSources['imsp'] = array(
-- 'title' => _("IMSP"),
-- 'type' => 'imsp',
-- 'params' => array(
-- 'server' => $GLOBALS['conf']['imsp']['server'],
-- 'port' => $GLOBALS['conf']['imsp']['port'],
-- 'auth_method' => $GLOBALS['conf']['imsp']['auth_method'],
-- // socket, command, and auth_mechanism are for imtest driver.
-- 'socket' => isset($GLOBALS['conf']['imsp']['socket']) ?
-- $GLOBALS['conf']['imsp']['socket'] . $_imsp_auth_user . '.sck' :
-- '',
-- 'command' => isset($GLOBALS['conf']['imsp']['command']) ?
-- $GLOBALS['conf']['imsp']['command'] : '' ,
-- 'auth_mechanism' => isset($GLOBALS['conf']['imsp']['auth_mechanism']) ?
-- $GLOBALS['conf']['imsp']['auth_mechanism'] : '',
-- 'username' => $_imsp_auth_user,
-- 'password' => $_imsp_auth_pass,
-- 'name' => $_imsp_auth_user,
-- 'group_id_field' => 'group',
-- 'group_id_value' => 'group',
-- 'contact_ownership' => false,
-- // Dynamically generated acl rights for current user.
-- 'my_rights' => '',
-- ),
-- 'map' => array(
-- '__key' => 'name',
-- '__type' => '__type',
-- '__members' => '__members',
-- '__owner' => '__owner',
-- '__uid' => '__uid',
-- 'name' => 'fullname',
-- 'email' => 'email',
-- 'alias' => 'alias',
-- 'company' => 'company',
-- 'notes' => 'notes',
-- 'workPhone' => 'phone-work',
-- 'fax' => 'fax',
-- 'homePhone' => 'phone-home',
-- 'cellPhone' => 'cellphone',
-- 'freebusyUrl' => 'freebusyUrl'
-- ),
-- 'search' => array(
-- 'name',
-- 'email',
-- 'alias',
-- 'company',
-- 'homePhone'
-- ),
-- 'strict' => array(),
-- 'export' => true,
-- 'browse' => true,
-- 'use_shares' => false,
-- );
--
-- /**
-- * Get any other address books this user might be privy to.
-- * The values for attributes such as 'export' and 'browse' for books
-- * that are added below will be the same as the values set in the default
-- * book above. Any entries defined explicitly in cfgSources[]
-- * will override any entries gathered dynamically below.
-- */
-- if (empty($cfgSources['imsp']['use_shares'])) {
-- require_once 'Net/IMSP/Utils.php';
-- $result = Net_IMSP_Utils::getAllBooks($cfgSources['imsp']);
--
-- if (!is_a($result, 'PEAR_Error')) {
-- $resultCount = count($result);
-- for ($i = 0; $i < $resultCount; $i++) {
-- // Make sure we didn't define this source explicitly,
-- // but set the acls from the server regardless.
-- $dup = false;
-- foreach ($cfgSources as $key => $thisSource) {
-- if (($thisSource['type'] == 'imsp') &&
-- ($thisSource['params']['name'] == $result[$i]['params']['name'])) {
--
-- $dup = true;
-- $acl = $result[$i]['params']['my_rights'];
-- $cfgSources[$key]['params']['my_rights'] = $acl;
-- break;
-- }
-- }
-- if (!$dup) {
-- $cfgSources[$result[$i]['params']['name']] = $result[$i];
-- }
-- }
-- } else {
-- $notification->push($result);
-- }
-- }
--}
-+//UNCOMMENTIFIMSPif (!empty($GLOBALS['conf']['imsp']['enabled']) ||
-+//UNCOMMENTIFIMSP !isset($GLOBALS['conf']['imsp']['enabled'])) {
-+//UNCOMMENTIFIMSP // First, get the user name to login to IMSP server with.
-+//UNCOMMENTIFIMSP $uid = $GLOBALS['prefs']->getValue('imsp_auth_user');
-+//UNCOMMENTIFIMSP $pass = $GLOBALS['prefs']->getValue('imsp_auth_pass');
-+//UNCOMMENTIFIMSP if (!strlen($uid)) {
-+//UNCOMMENTIFIMSP $uid = Auth::getBareAuth();
-+//UNCOMMENTIFIMSP $pass = Auth::getCredential('password');
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP // Note we always use the horde username to append to the key even if we
-+//UNCOMMENTIFIMSP // have an alternate username set in prefs. This is to prevent the
-+//UNCOMMENTIFIMSP // (fringe) case where an IMSP username for one user might be a valid
-+//UNCOMMENTIFIMSP // horde username for another user.
-+//UNCOMMENTIFIMSP $cfgKey = 'IMSP_' . Auth::getAuth();
-+//UNCOMMENTIFIMSP $cfgSources[$cfgKey] = array(
-+//UNCOMMENTIFIMSP 'title' => _("IMSP"),
-+//UNCOMMENTIFIMSP 'type' => 'imsp',
-+//UNCOMMENTIFIMSP 'params' => array(
-+//UNCOMMENTIFIMSP 'server' => $GLOBALS['conf']['imsp']['server'],
-+//UNCOMMENTIFIMSP 'port' => $GLOBALS['conf']['imsp']['port'],
-+//UNCOMMENTIFIMSP 'auth_method' => $GLOBALS['conf']['imsp']['auth_method'],
-+//UNCOMMENTIFIMSP // socket, command, and auth_mechanism are for imtest driver.
-+//UNCOMMENTIFIMSP 'socket' => isset($GLOBALS['conf']['imsp']['socket']) ?
-+//UNCOMMENTIFIMSP $GLOBALS['conf']['imsp']['socket'] . $uid . '.sck' :
-+//UNCOMMENTIFIMSP '',
-+//UNCOMMENTIFIMSP 'command' => isset($GLOBALS['conf']['imsp']['command']) ?
-+//UNCOMMENTIFIMSP $GLOBALS['conf']['imsp']['command'] : '' ,
-+//UNCOMMENTIFIMSP 'auth_mechanism' => isset($GLOBALS['conf']['imsp']['auth_mechanism']) ?
-+//UNCOMMENTIFIMSP $GLOBALS['conf']['imsp']['auth_mechanism'] : '',
-+//UNCOMMENTIFIMSP 'username' => $uid,
-+//UNCOMMENTIFIMSP 'password' => $pass,
-+//UNCOMMENTIFIMSP 'name' => $uid,
-+//UNCOMMENTIFIMSP 'group_id_field' => 'group',
-+//UNCOMMENTIFIMSP 'group_id_value' => 'group',
-+//UNCOMMENTIFIMSP 'contact_ownership' => false,
-+//UNCOMMENTIFIMSP // Dynamically generated acl rights for current user.
-+//UNCOMMENTIFIMSP 'my_rights' => '',
-+//UNCOMMENTIFIMSP // Flags this as the user's 'root' IMSP address book.
-+//UNCOMMENTIFIMSP 'is_root' => true
-+//UNCOMMENTIFIMSP ),
-+//UNCOMMENTIFIMSP 'map' => array(
-+//UNCOMMENTIFIMSP '__key' => 'name',
-+//UNCOMMENTIFIMSP '__type' => '__type',
-+//UNCOMMENTIFIMSP '__members' => '__members',
-+//UNCOMMENTIFIMSP '__owner' => '__owner',
-+//UNCOMMENTIFIMSP '__uid' => '__uid',
-+//UNCOMMENTIFIMSP 'name' => 'fullname',
-+//UNCOMMENTIFIMSP 'email' => 'email',
-+//UNCOMMENTIFIMSP 'alias' => 'alias',
-+//UNCOMMENTIFIMSP 'company' => 'company',
-+//UNCOMMENTIFIMSP 'notes' => 'notes',
-+//UNCOMMENTIFIMSP 'workPhone' => 'phone-work',
-+//UNCOMMENTIFIMSP 'fax' => 'fax',
-+//UNCOMMENTIFIMSP 'homePhone' => 'phone-home',
-+//UNCOMMENTIFIMSP 'cellPhone' => 'cellphone',
-+//UNCOMMENTIFIMSP 'freebusyUrl' => 'freebusyUrl'
-+//UNCOMMENTIFIMSP ),
-+//UNCOMMENTIFIMSP 'search' => array(
-+//UNCOMMENTIFIMSP 'name',
-+//UNCOMMENTIFIMSP 'email',
-+//UNCOMMENTIFIMSP 'alias',+//UNCOMMENTIFIMSP 'company',
-+//UNCOMMENTIFIMSP 'homePhone'
-+//UNCOMMENTIFIMSP ),
-+//UNCOMMENTIFIMSP 'strict' => array(),
-+//UNCOMMENTIFIMSP 'export' => true,
-+//UNCOMMENTIFIMSP 'browse' => true,
-+//UNCOMMENTIFIMSP );
-+//UNCOMMENTIFIMSP
-+//UNCOMMENTIFIMSP /**
-+//UNCOMMENTIFIMSP * Get any other address books this user might be privy to.
-+//UNCOMMENTIFIMSP * The values for attributes such as 'export' and 'browse' for books
-+//UNCOMMENTIFIMSP * that are added below will be the same as the values set in the default
-+//UNCOMMENTIFIMSP * book above. Any entries defined explicitly in cfgSources[]
-+//UNCOMMENTIFIMSP * will override any entries gathered dynamically below.
-+//UNCOMMENTIFIMSP */
-+//UNCOMMENTIFIMSP require_once 'Net/IMSP/Utils.php';
-+//UNCOMMENTIFIMSP $result = Net_IMSP_Utils::getAllBooks($cfgSources[$cfgKey]);
-+//UNCOMMENTIFIMSP $count = 2;
-+//UNCOMMENTIFIMSP if (!is_a($result, 'PEAR_Error')) {
-+//UNCOMMENTIFIMSP $resultCount = count($result);
-+//UNCOMMENTIFIMSP for ($i = 0; $i < $resultCount; $i++) {
-+//UNCOMMENTIFIMSP // Make sure we didn't define this source explicitly,
-+//UNCOMMENTIFIMSP // but set the acls from the server regardless.
-+//UNCOMMENTIFIMSP $dup = false;
-+//UNCOMMENTIFIMSP foreach ($cfgSources as $key => $thisSource) {
-+//UNCOMMENTIFIMSP if (($thisSource['type'] == 'imsp') &&
-+//UNCOMMENTIFIMSP ($thisSource['params']['name'] == $result[$i]['params']['name'])) {
-+//UNCOMMENTIFIMSP
-+//UNCOMMENTIFIMSP $dup = true;
-+//UNCOMMENTIFIMSP $acl = $result[$i]['params']['my_rights'];
-+//UNCOMMENTIFIMSP $cfgSources[$key]['params']['my_rights'] = $acl;
-+//UNCOMMENTIFIMSP break;
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP if (!$dup) {
-+//UNCOMMENTIFIMSP $cfgSources[sprintf('IMSP_%d', $count++)] = $result[$i];
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP } else {
-+//UNCOMMENTIFIMSP $notification->push($result);
-+//UNCOMMENTIFIMSP }
-+//UNCOMMENTIFIMSP}
- /* End IMSP sources. */
-
- /* Begin Kolab sources. */
diff --git a/mail/horde4-turba/files/pkg-message.in b/mail/horde4-turba/files/pkg-message.in
deleted file mode 100644
index fac46bfb9f28..000000000000
--- a/mail/horde4-turba/files/pkg-message.in
+++ /dev/null
@@ -1,21 +0,0 @@
-************************************************************************
-Turba has been installed in %%HORDIR%% with your blank
-configuration files.
-
-Horde must be configured; if not, see `pkg_info -Dx horde'.
-
-Then, you might have to tune the configuration files located in
-%%HORCFG%%/, specially the file sources.php.
-
-Warning: if you don't use some source, deactivate it, or you could
-******** experience bad response times!
- When upgrading from Turba 2.0.x, please read UPGRADING.
-
-Then, you must login to Horde as a Horde Administrator to finish the
-configuration.
-
-You have to create a table in your database; please see
-%%HORDIR%%/scripts/.
-You might create a LDAP schema: please see the doc LDAP.
-
-************************************************************************
diff --git a/mail/horde4-turba/pkg-descr b/mail/horde4-turba/pkg-descr
index 7ad5e825db08..bad8d402f189 100644
--- a/mail/horde4-turba/pkg-descr
+++ b/mail/horde4-turba/pkg-descr
@@ -1,10 +1,6 @@
-Turba is the Horde contact management application. It makes heavy use
-of the Horde framework to provide integration with other applications.
+Turba is the Horde contact management application. Leveraging the Horde
+framework to provide seamless integration with IMP and other Horde
+applications, it supports storing contacts in SQL, LDAP, Kolab, and IMSP
+address books.
-Turba is a fairly complete basic contact management application.
-SQL and LDAP backends are available.
-You can define the fields in your addressbooks in a very flexible way,
-just by changing the config files.
-And there are Horde API functions to add and search for contacts.
-
-WWW: http://horde.org/turba/
+WWW: http://www.horde.org/apps/turba/
diff --git a/mail/horde4-turba/pkg-plist b/mail/horde4-turba/pkg-plist
deleted file mode 100644
index 515fc0b5a300..000000000000
--- a/mail/horde4-turba/pkg-plist
+++ /dev/null
@@ -1,399 +0,0 @@
-%%HORDIR%%/add.php
-%%HORDIR%%/addressbooks/create.php
-%%HORDIR%%/addressbooks/delete.php
-%%HORDIR%%/addressbooks/edit.php
-%%HORDIR%%/addressbooks/index.php
-%%HORDIR%%/browse.php
-%%HORDIR%%/config/.htaccess
-%%HORDIR%%/config/attributes.php.dist
-%%HORDIR%%/config/conf.xml
-%%HORDIR%%/config/hooks.php.dist
-%%HORDIR%%/config/menu.php.dist
-%%HORDIR%%/config/mime_drivers.php.dist
-%%HORDIR%%/config/prefs.php.dist
-%%HORDIR%%/config/sources.php.dist
-%%HORDIR%%/contact.php
-%%HORDIR%%/data.php
-%%HORDIR%%/delete.php
-%%HORDIR%%/deletefile.php
-%%HORDIR%%/edit.php
-%%HORDIR%%/index.php
-%%HORDIR%%/js/QuickFinder.js
-%%HORDIR%%/js/contact_tabs.js
-%%HORDIR%%/js/dragdrop.js
-%%HORDIR%%/js/effects.js
-%%HORDIR%%/js/prototype.js
-%%HORDIR%%/js/redbox.js
-%%HORDIR%%/js/scriptaculous.js
-%%HORDIR%%/js/src/QuickFinder.js
-%%HORDIR%%/js/src/contact_tabs.js
-%%HORDIR%%/js/src/dragdrop.js
-%%HORDIR%%/js/src/effects.js
-%%HORDIR%%/js/src/prototype.js
-%%HORDIR%%/js/src/redbox.js
-%%HORDIR%%/js/src/scriptaculous.js
-%%HORDIR%%/js/src/tables.js
-%%HORDIR%%/js/tables.js
-%%HORDIR%%/lib/.htaccess
-%%HORDIR%%/lib/Block/minisearch.php
-%%HORDIR%%/lib/Block/tree_menu.php
-%%HORDIR%%/lib/Data/ldif.php
-%%HORDIR%%/lib/Driver/favourites.php
-%%HORDIR%%/lib/Driver/group.php
-%%HORDIR%%/lib/Driver/imsp.php
-%%HORDIR%%/lib/Driver/kolab.php
-%%HORDIR%%/lib/Driver/ldap.php
-%%HORDIR%%/lib/Driver/null.php
-%%HORDIR%%/lib/Driver/prefs.php
-%%HORDIR%%/lib/Driver/share.php
-%%HORDIR%%/lib/Driver/sql.php
-%%HORDIR%%/lib/Driver/vbook.php
-%%HORDIR%%/lib/Driver.php
-%%HORDIR%%/lib/Forms/AddContact.php
-%%HORDIR%%/lib/Forms/Contact.php
-%%HORDIR%%/lib/Forms/CreateAddressBook.php
-%%HORDIR%%/lib/Forms/DeleteAddressBook.php
-%%HORDIR%%/lib/Forms/EditAddressBook.php
-%%HORDIR%%/lib/Forms/EditContact.php
-%%HORDIR%%/lib/Group.php
-%%HORDIR%%/lib/List.php
-%%HORDIR%%/lib/ListView.php
-%%HORDIR%%/lib/Maintenance/Task/upgradelists.php
-%%HORDIR%%/lib/Maintenance/Task/upgradeprefs.php
-%%HORDIR%%/lib/Object/Group.php
-%%HORDIR%%/lib/Object.php
-%%HORDIR%%/lib/Turba.php
-%%HORDIR%%/lib/Views/Browse.php
-%%HORDIR%%/lib/Views/Contact.php
-%%HORDIR%%/lib/Views/DeleteContact.php
-%%HORDIR%%/lib/Views/EditContact.php
-%%HORDIR%%/lib/api.php
-%%HORDIR%%/lib/base.php
-%%HORDIR%%/lib/prefs.php
-%%HORDIR%%/lib/tests/ApiTest.php
-%%HORDIR%%/lib/tests/BrowsePageTest.php
-%%HORDIR%%/lib/tests/DriverTest.php
-%%HORDIR%%/lib/tests/GroupTest.php
-%%HORDIR%%/lib/tests/KolabTest.php
-%%HORDIR%%/lib/tests/KolabTestBase.php
-%%HORDIR%%/lib/tests/ListTest.php
-%%HORDIR%%/lib/tests/ListViewTest.php
-%%HORDIR%%/lib/tests/TestBase.php
-%%HORDIR%%/lib/tests/ViewBrowseTest.php
-%%HORDIR%%/lib/tests/az.png
-%%HORDIR%%/lib/tests/bug_6518.phpt
-%%HORDIR%%/lib/tests/import.ldif
-%%HORDIR%%/lib/tests/importCRLF.ldif
-%%HORDIR%%/lib/tests/ldif_exportFile.phpt
-%%HORDIR%%/lib/tests/ldif_importFile.phpt
-%%HORDIR%%/lib/tests/ldif_importFileCRLF.phpt
-%%HORDIR%%/lib/tests/tohash.phpt
-%%HORDIR%%/lib/tests/tovcard.phpt
-%%HORDIR%%/lib/version.php
-%%HORDIR%%/locale/.htaccess
-%%HORDIR%%/locale/ar_SY/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/bg_BG/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/ca_ES/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/ca_ES/help.xml
-%%HORDIR%%/locale/cs_CZ/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/da_DK/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/de_DE/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/de_DE/help.xml
-%%HORDIR%%/locale/el_GR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/en_US/help.xml
-%%HORDIR%%/locale/es_ES/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/es_ES/help.xml
-%%HORDIR%%/locale/et_EE/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/eu_ES/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/eu_ES/help.xml
-%%HORDIR%%/locale/fa_IR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/fa_IR/help.xml
-%%HORDIR%%/locale/fi_FI/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/fi_FI/help.xml
-%%HORDIR%%/locale/fr_FR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/fr_FR/help.xml
-%%HORDIR%%/locale/gl_ES/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/hr_HR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/hr_HR/help.xml
-%%HORDIR%%/locale/hu_HU/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/is_IS/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/it_IT/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/ja_JP/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/ko_KR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/lt_LT/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/lv_LV/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/mk_MK/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/nb_NO/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/nl_NL/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/nn_NO/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/pl_PL/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/pt_BR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/pt_BR/help.xml
-%%HORDIR%%/locale/pt_PT/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/pt_PT/help.xml
-%%HORDIR%%/locale/ro_RO/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/ru_RU/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/sk_SK/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/sk_SK/help.xml
-%%HORDIR%%/locale/sl_SI/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/sv_SE/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/tr_TR/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/tr_TR/help.xml
-%%HORDIR%%/locale/uk_UA/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/zh_CN/LC_MESSAGES/turba.mo
-%%HORDIR%%/locale/zh_TW/LC_MESSAGES/turba.mo
-%%HORDIR%%/minisearch.php
-%%HORDIR%%/po/.htaccess
-%%HORDIR%%/po/README
-%%HORDIR%%/po/ar_SY.po
-%%HORDIR%%/po/bg_BG.po
-%%HORDIR%%/po/ca_ES.po
-%%HORDIR%%/po/cs_CZ.po
-%%HORDIR%%/po/da_DK.po
-%%HORDIR%%/po/de_DE.po
-%%HORDIR%%/po/el_GR.po
-%%HORDIR%%/po/es_ES.po
-%%HORDIR%%/po/et_EE.po
-%%HORDIR%%/po/eu_ES.po
-%%HORDIR%%/po/fa_IR.po
-%%HORDIR%%/po/fi_FI.po
-%%HORDIR%%/po/fr_FR.po
-%%HORDIR%%/po/gl_ES.po
-%%HORDIR%%/po/hr_HR.po
-%%HORDIR%%/po/hu_HU.po
-%%HORDIR%%/po/is_IS.po
-%%HORDIR%%/po/it_IT.po
-%%HORDIR%%/po/ja_JP.po
-%%HORDIR%%/po/ko_KR.po
-%%HORDIR%%/po/lt_LT.po
-%%HORDIR%%/po/lv_LV.po
-%%HORDIR%%/po/mk_MK.po
-%%HORDIR%%/po/nb_NO.po
-%%HORDIR%%/po/nl_NL.po
-%%HORDIR%%/po/nn_NO.po
-%%HORDIR%%/po/pl_PL.po
-%%HORDIR%%/po/pt_BR.po
-%%HORDIR%%/po/pt_PT.po
-%%HORDIR%%/po/ro_RO.po
-%%HORDIR%%/po/ru_RU.po
-%%HORDIR%%/po/sk_SK.po
-%%HORDIR%%/po/sl_SI.po
-%%HORDIR%%/po/sv_SE.po
-%%HORDIR%%/po/tr_TR.po
-%%HORDIR%%/po/turba.pot
-%%HORDIR%%/po/uk_UA.po
-%%HORDIR%%/po/zh_CN.po
-%%HORDIR%%/po/zh_TW.po
-%%HORDIR%%/scripts/.htaccess
-%%HORDIR%%/scripts/Turba.reg
-%%HORDIR%%/scripts/import_squirrelmail_file_abook.php
-%%HORDIR%%/scripts/import_squirrelmail_sql_abook.php
-%%HORDIR%%/scripts/import_vcards.php
-%%HORDIR%%/scripts/ldap/addou
-%%HORDIR%%/scripts/ldap/addou.pl
-%%HORDIR%%/scripts/ldap/core.schema.patch
-%%HORDIR%%/scripts/ldap/rfc2739.schema
-%%HORDIR%%/scripts/sql/test.xml
-%%HORDIR%%/scripts/sql/turba.mssql.sql
-%%HORDIR%%/scripts/sql/turba.oci8.sql
-%%HORDIR%%/scripts/sql/turba.pgsql.sql
-%%HORDIR%%/scripts/sql/turba.sql
-%%HORDIR%%/scripts/sql/turba.xml
-%%HORDIR%%/scripts/upgrades/1.1_to_1.2.sql
-%%HORDIR%%/scripts/upgrades/1.2_to_2.0.oci8.sql
-%%HORDIR%%/scripts/upgrades/1.2_to_2.0.sql
-%%HORDIR%%/scripts/upgrades/2.1_to_2.2_add_sql_share_tables.mssql.sql
-%%HORDIR%%/scripts/upgrades/2.1_to_2.2_add_sql_share_tables.oci8.sql
-%%HORDIR%%/scripts/upgrades/2.1_to_2.2_add_sql_share_tables.pgsql.sql
-%%HORDIR%%/scripts/upgrades/2.1_to_2.2_add_sql_share_tables.sql
-%%HORDIR%%/scripts/upgrades/2.1_to_2.2_sql_schema.php
-%%HORDIR%%/scripts/upgrades/2.2.1_to_2.3.oci8.sql
-%%HORDIR%%/scripts/upgrades/2.2.1_to_2.3.pgsql.sql
-%%HORDIR%%/scripts/upgrades/2.2.1_to_2.3.sql
-%%HORDIR%%/scripts/upgrades/2.3_to_2.3.3.pgsql.sql
-%%HORDIR%%/scripts/upgrades/2007-06-17_flatten_shares.php
-%%HORDIR%%/scripts/upgrades/2008-09-23_fix_group_uid.sql
-%%HORDIR%%/scripts/upgrades/convert_datatree_shares_to_sql.php
-%%HORDIR%%/scripts/upgrades/create_default_histories.php
-%%HORDIR%%/scripts/upgrades/public_to_horde_share.php
-%%HORDIR%%/search.php
-%%HORDIR%%/templates/.htaccess
-%%HORDIR%%/templates/addressbook_list.php
-%%HORDIR%%/templates/block/minisearch.inc
-%%HORDIR%%/templates/browse/actions.inc
-%%HORDIR%%/templates/browse/column_footers.inc
-%%HORDIR%%/templates/browse/column_headers.inc
-%%HORDIR%%/templates/browse/contactrow.inc
-%%HORDIR%%/templates/browse/header.inc
-%%HORDIR%%/templates/browse/javascript.inc
-%%HORDIR%%/templates/browse/row.inc
-%%HORDIR%%/templates/browse/search.inc
-%%HORDIR%%/templates/browse/search_criteria.inc
-%%HORDIR%%/templates/browse/search_vbook.inc
-%%HORDIR%%/templates/common-header.inc
-%%HORDIR%%/templates/data/export.inc
-%%HORDIR%%/templates/data/import.inc
-%%HORDIR%%/templates/list/alphaPager.inc
-%%HORDIR%%/templates/list/numPager.inc
-%%HORDIR%%/templates/menu.inc
-%%HORDIR%%/templates/prefs/addressbookselect.inc
-%%HORDIR%%/templates/prefs/columnselect.inc
-%%HORDIR%%/templates/prefs/imsp_opt.inc
-%%HORDIR%%/test.php
-%%HORDIR%%/themes/bluewhite/screen.css
-%%HORDIR%%/themes/graphics/az.png
-%%HORDIR%%/themes/graphics/az_secondary.png
-%%HORDIR%%/themes/graphics/contact.png
-%%HORDIR%%/themes/graphics/favicon.ico
-%%HORDIR%%/themes/graphics/group.png
-%%HORDIR%%/themes/graphics/menu/browse.png
-%%HORDIR%%/themes/graphics/menu/new.png
-%%HORDIR%%/themes/graphics/new.png
-%%HORDIR%%/themes/graphics/redbox_spinner.gif
-%%HORDIR%%/themes/graphics/search.png
-%%HORDIR%%/themes/graphics/turba.png
-%%HORDIR%%/themes/graphics/za.png
-%%HORDIR%%/themes/graphics/za_secondary.png
-%%HORDIR%%/themes/ideas/screen.css
-%%HORDIR%%/themes/screen.css
-%%HORDIR%%/themes/silver/graphics/az.png
-%%HORDIR%%/themes/silver/graphics/az_secondary.png
-%%HORDIR%%/themes/silver/graphics/contact.png
-%%HORDIR%%/themes/silver/graphics/favicon.ico
-%%HORDIR%%/themes/silver/graphics/group.png
-%%HORDIR%%/themes/silver/graphics/menu/browse.png
-%%HORDIR%%/themes/silver/graphics/menu/new.png
-%%HORDIR%%/themes/silver/graphics/new.png
-%%HORDIR%%/themes/silver/graphics/turba.png
-%%HORDIR%%/themes/silver/graphics/za.png
-%%HORDIR%%/themes/silver/graphics/za_secondary.png
-%%HORDIR%%/themes/silver/screen.css
-%%HORDIR%%/themes/silver/themed_graphics
-%%HORDIR%%/themes/tango-blue/graphics/az_secondary.png
-%%HORDIR%%/themes/tango-blue/graphics/contact.png
-%%HORDIR%%/themes/tango-blue/graphics/favicon.ico
-%%HORDIR%%/themes/tango-blue/graphics/group.png
-%%HORDIR%%/themes/tango-blue/graphics/menu/browse.png
-%%HORDIR%%/themes/tango-blue/graphics/menu/new.png
-%%HORDIR%%/themes/tango-blue/graphics/new.png
-%%HORDIR%%/themes/tango-blue/graphics/turba.png
-%%HORDIR%%/themes/tango-blue/graphics/za_secondary.png
-%%HORDIR%%/themes/tango-blue/themed_graphics
-%%HORDIR%%/vcard.php
-%%HORDIR%%/view.php
-@dirrm %%HORDIR%%/addressbooks
-@dirrmtry %%HORDIR%%/config
-@dirrm %%HORDIR%%/js/src
-@dirrm %%HORDIR%%/js
-@dirrm %%HORDIR%%/lib/Block
-@dirrm %%HORDIR%%/lib/Data
-@dirrm %%HORDIR%%/lib/Driver
-@dirrm %%HORDIR%%/lib/Forms
-@dirrm %%HORDIR%%/lib/Maintenance/Task
-@dirrm %%HORDIR%%/lib/Maintenance
-@dirrm %%HORDIR%%/lib/Object
-@dirrm %%HORDIR%%/lib/Views
-@dirrm %%HORDIR%%/lib/tests
-@dirrm %%HORDIR%%/lib
-@dirrm %%HORDIR%%/locale/ar_SY/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ar_SY
-@dirrm %%HORDIR%%/locale/bg_BG/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/bg_BG
-@dirrm %%HORDIR%%/locale/ca_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ca_ES
-@dirrm %%HORDIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/cs_CZ
-@dirrm %%HORDIR%%/locale/da_DK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/da_DK
-@dirrm %%HORDIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/de_DE
-@dirrm %%HORDIR%%/locale/el_GR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/el_GR
-@dirrm %%HORDIR%%/locale/en_US
-@dirrm %%HORDIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/es_ES
-@dirrm %%HORDIR%%/locale/et_EE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/et_EE
-@dirrm %%HORDIR%%/locale/eu_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/eu_ES
-@dirrm %%HORDIR%%/locale/fa_IR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fa_IR
-@dirrm %%HORDIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fi_FI
-@dirrm %%HORDIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/fr_FR
-@dirrm %%HORDIR%%/locale/gl_ES/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/gl_ES
-@dirrm %%HORDIR%%/locale/hr_HR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/hr_HR
-@dirrm %%HORDIR%%/locale/hu_HU/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/hu_HU
-@dirrm %%HORDIR%%/locale/is_IS/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/is_IS
-@dirrm %%HORDIR%%/locale/it_IT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/it_IT
-@dirrm %%HORDIR%%/locale/ja_JP/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ja_JP
-@dirrm %%HORDIR%%/locale/ko_KR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ko_KR
-@dirrm %%HORDIR%%/locale/lt_LT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/lt_LT
-@dirrm %%HORDIR%%/locale/lv_LV/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/lv_LV
-@dirrm %%HORDIR%%/locale/mk_MK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/mk_MK
-@dirrm %%HORDIR%%/locale/nb_NO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nb_NO
-@dirrm %%HORDIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nl_NL
-@dirrm %%HORDIR%%/locale/nn_NO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/nn_NO
-@dirrm %%HORDIR%%/locale/pl_PL/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pl_PL
-@dirrm %%HORDIR%%/locale/pt_BR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pt_BR
-@dirrm %%HORDIR%%/locale/pt_PT/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/pt_PT
-@dirrm %%HORDIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ro_RO
-@dirrm %%HORDIR%%/locale/ru_RU/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/ru_RU
-@dirrm %%HORDIR%%/locale/sk_SK/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sk_SK
-@dirrm %%HORDIR%%/locale/sl_SI/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sl_SI
-@dirrm %%HORDIR%%/locale/sv_SE/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/sv_SE
-@dirrm %%HORDIR%%/locale/tr_TR/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/tr_TR
-@dirrm %%HORDIR%%/locale/uk_UA/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/uk_UA
-@dirrm %%HORDIR%%/locale/zh_CN/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/zh_CN
-@dirrm %%HORDIR%%/locale/zh_TW/LC_MESSAGES
-@dirrm %%HORDIR%%/locale/zh_TW
-@dirrm %%HORDIR%%/locale
-@dirrm %%HORDIR%%/po
-@dirrm %%HORDIR%%/scripts/ldap
-@dirrm %%HORDIR%%/scripts/sql
-@dirrm %%HORDIR%%/scripts/upgrades
-@dirrm %%HORDIR%%/scripts
-@dirrm %%HORDIR%%/templates/block
-@dirrm %%HORDIR%%/templates/browse
-@dirrm %%HORDIR%%/templates/data
-@dirrm %%HORDIR%%/templates/list
-@dirrm %%HORDIR%%/templates/prefs
-@dirrm %%HORDIR%%/templates
-@dirrm %%HORDIR%%/themes/bluewhite
-@dirrm %%HORDIR%%/themes/graphics/menu
-@dirrm %%HORDIR%%/themes/graphics
-@dirrm %%HORDIR%%/themes/ideas
-@dirrm %%HORDIR%%/themes/silver/graphics/menu
-@dirrm %%HORDIR%%/themes/silver/graphics
-@dirrm %%HORDIR%%/themes/silver
-@dirrm %%HORDIR%%/themes/tango-blue/graphics/menu
-@dirrm %%HORDIR%%/themes/tango-blue/graphics
-@dirrm %%HORDIR%%/themes/tango-blue
-@dirrm %%HORDIR%%/themes
-@dirrmtry %%HORDIR%%
-@dirrmtry %%HORBAS%%