aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2006-11-03 00:05:29 +0800
committerbarner <barner@FreeBSD.org>2006-11-03 00:05:29 +0800
commit3510ee1df081de136bb59eebd6ba27fbc0d1d0bd (patch)
tree1326c38cba209c9fedf45ecde044c42ce7ff97a9 /mail
parent3cea42d39374f436fefe7d51fb1218eea20e4a9a (diff)
downloadfreebsd-ports-gnome-3510ee1df081de136bb59eebd6ba27fbc0d1d0bd.tar.gz
freebsd-ports-gnome-3510ee1df081de136bb59eebd6ba27fbc0d1d0bd.tar.zst
freebsd-ports-gnome-3510ee1df081de136bb59eebd6ba27fbc0d1d0bd.zip
- Update to fetchmail 6.3.5. See here for the release notes:
http://developer.berlios.de/project/shownotes.php?group_id=1824&release_id=11358 - OPTIONize [1] - GSSAPI support (requires Kerberos). [1] - Removed POP2 from port's default configuration [1] Requested by: Stefan Thurner <thurners@nicsys.de> [1]
Diffstat (limited to 'mail')
-rw-r--r--mail/fetchmail/Makefile77
-rw-r--r--mail/fetchmail/distinfo9
2 files changed, 68 insertions, 18 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 8c489095e228..67cd6839dea9 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -10,16 +10,20 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
-PORTVERSION= 6.3.4
-PORTREVISION= 3
+PORTVERSION= 6.3.5
CATEGORIES= mail ipv6
-MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
+MASTER_SITES= ${MASTER_SITE_BERLIOS}/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
http://home.leo.org/~barner/freebsd/distfiles/
MASTER_SITE_SUBDIR= fetchmail
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+PATCH_SITES= ${MASTER_SITE_BERLIOS}/fetchmail/ \
+ http://home.leo.org/~barner/freebsd/distfiles/
+PATCHFILES= fm635-daemon-logfile.patch
MAINTAINER= barner@FreeBSD.org
-COMMENT= Batch mail retrieval utility for IMAP/POP2/POP3/ETRN/ODMR
+COMMENT= Batch mail retrieval utility for IMAP/POP3/ETRN/ODMR
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root.crt:${PORTSDIR}/security/ca-roots
@@ -31,7 +35,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-POP2 --enable-SDPS \
+CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
--with-hesiod=no --enable-fallback=no
# bsd.openssl.mk will add the LDFLAGS to CONFIGURE_ENV:
LDFLAGS= -L${LOCALBASE}/lib
@@ -41,6 +45,12 @@ MAKE_ENV+= ${CONFIGURE_ENV}
MAN1= fetchmail.1
MLINKS= fetchmail.1 fetchmailconf.1
+OPTIONS= X11 "Python/Tkinter dependencies for fetchmailconf" off \
+ NLS "National language support (NLS)." on \
+ NTLM "Building in support for NTLM/MSN authentication." off \
+ POP2 "Build pop2 support (obsolete)." off \
+ GSSAPI "Build GSSAPI support (requires KRB5_HOME to be set)" off
+
.if defined(WITH_X11)
USE_PYTHON= yes
RUN_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
@@ -48,6 +58,11 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_tkinter.so:${POR
.include <bsd.port.pre.mk>
+# Pop2 is obsolete
+.if defined(WITH_POP2)
+CONFIGURE_ARGS+=--enable-POP2
+.endif
+
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
DOCS= FAQ FEATURES NEWS NOTES README README.SSL \
@@ -65,8 +80,18 @@ PLIST_SUB+= NLS="@comment "
.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
CONFIGURE_ARGS += --with-kerberos5=${KRB5_HOME}
+
+.if defined(WITH_GSSAPI)
+CONFIGURE_ARGS+=--with-gssapi=${KRB5_HOME}
+.endif
+
.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4)
CONFIGURE_ARGS += --with-kerberos=/usr
+
+.if defined(WITH_GSSAPI)
+CONFIGURE_ARGS+=--with-gssapi=/usr
+.endif
+
.endif
.if defined(WITH_NTLM)
@@ -85,22 +110,45 @@ pre-patch:
${WRKDIR}/fetchmailconf
pre-configure:
-.if defined(WITH_NTLM)
- @${ECHO_CMD} "Building in support for NTLM/MSN authentication."
+
+ @${ECHO_CMD} ""
+
+.if ${OSVERSION} >= 500000
+.if defined(KRB5_HOME)
+ @${ECHO_CMD} "Using Kerberos V support in ${KRB5_HOME}."
.else
- @${ECHO_CMD} "Add -DWITH_NTLM to add support for NTLM/MSN authentication."
+ @${ECHO_CMD} "Use KRB5_HOME=<directory> to enable Kerberos V support in <directory> (usually /usr)."
.endif
-.if defined(WITH_X11)
- @${ECHO_CMD} "Adding Python/Tkinter dependencies for fetchmailconf."
+
+.else
+# FreeBSD 4
+.if defined(MAKE_KERBEROS4)
+.if exists(/usr/lib/libkrb.a)
+ @${ECHO_CMD} "Enabling Kerberos IV support in /usr."
.else
- @${ECHO_CMD} "Add -DWITH_X11 to add Python/Tkinter dependencies for fetchmailconf."
+ @${ECHO_CMD} "Kerberos IV is not installed on your system."
.endif
-.if defined(WITHOUT_NLS)
- @${ECHO_CMD} "Using national language support (NLS)."
.else
- @${ECHO_CMD} "You can use -DWITHOUT_NLS to suppress national language support (NLS)."
+ @${ECHO_CMD} "Use -DMAKE_KERBEROS4 to enable Kerberos IV support."
+.endif
.endif
+.if defined(WITH_GSSAPI)
+.if defined(KRB5_HOME)
+ @${ECHO_CMD} "Enabling GSSAPI support in ${KRB5_HOME}."
+.elif defined(MAKE_KERBEROS4)
+.if exists(/usr/lib/libkrb.a)
+ @${ECHO_CMD} "Enabling GSSAPI support in /usr."
+.else
+ @${ECHO_CMD} "Unable to detect Kerberos in your system. Disabling GSSAPI support."
+.endif
+.else
+ @${ECHO_CMD} "GSSAPI requires Kerberos which is not enabled in your current configuration."
+.endif
+.endif
+
+ @${ECHO_CMD} ""
+
pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -118,5 +166,4 @@ post-install:
${CP} -p ${PREFIX}/etc/fetchmailrc.sample ${PREFIX}/etc/fetchmailrc ; \
fi
-
.include <bsd.port.post.mk>
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index 663cbbb71563..298208f5fb46 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,6 @@
-MD5 (fetchmail-6.3.4.tar.bz2) = 35ded0414fcff79b492d6ade2ce48911
-SHA256 (fetchmail-6.3.4.tar.bz2) = a090cfc47949e4ea5eebd46c82e82be35cdc743488e6d7258089591521b5db4f
-SIZE (fetchmail-6.3.4.tar.bz2) = 1210405
+MD5 (fetchmail-6.3.5.tar.bz2) = e8dc5cd8e80677bb60e397d6171d12ec
+SHA256 (fetchmail-6.3.5.tar.bz2) = 0af641629fc1b7ee2561eccd5ecd0efea20fea935656d155886061c530114f2b
+SIZE (fetchmail-6.3.5.tar.bz2) = 1237821
+MD5 (fm635-daemon-logfile.patch) = 4b37403e91d2732902f33fa15ab43a68
+SHA256 (fm635-daemon-logfile.patch) = ff9048ae9f75be12ee67b6a37fa0b5fdd05287fd741191cfddac304c293dfd08
+SIZE (fm635-daemon-logfile.patch) = 581