aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-05-06 11:22:32 +0800
committerlioux <lioux@FreeBSD.org>2001-05-06 11:22:32 +0800
commit39d7b81f3112d62ea306ed1fae232e7484b529f3 (patch)
treed11941c4684f1670b50d1dfe35adab9e03349cb3 /mail
parent15c88e9e602fb03ee1e46e0e616f6bc3443fb7fd (diff)
downloadfreebsd-ports-gnome-39d7b81f3112d62ea306ed1fae232e7484b529f3.tar.gz
freebsd-ports-gnome-39d7b81f3112d62ea306ed1fae232e7484b529f3.tar.zst
freebsd-ports-gnome-39d7b81f3112d62ea306ed1fae232e7484b529f3.zip
Conditional extra patches if WITH_POPPASSD is defined.
Submitted by: Hajimu Umemoto <ume@mahoroba.org>
Diffstat (limited to 'mail')
-rw-r--r--mail/qpopper/files/extra-patch-password::Makefile.in11
-rw-r--r--mail/qpopper/files/extra-patch-password::poppassd.c28
2 files changed, 39 insertions, 0 deletions
diff --git a/mail/qpopper/files/extra-patch-password::Makefile.in b/mail/qpopper/files/extra-patch-password::Makefile.in
new file mode 100644
index 000000000000..142418485028
--- /dev/null
+++ b/mail/qpopper/files/extra-patch-password::Makefile.in
@@ -0,0 +1,11 @@
+--- password/Makefile.in.orig Mon Mar 19 20:26:18 2001
++++ password/Makefile.in Sat May 5 18:51:06 2001
+@@ -76,7 +76,7 @@
+ all: ${poppassd}
+
+ poppassd: ${OBJS} ${common_dir}/libcommon.a
+- ${CC} -o poppassd ${OBJS} ${NETWORK_LIBS} \
++ ${CC} -o poppassd ${OBJS} ${LIBS} \
+ ${common_dir}/libcommon.a
+
+ .c.o:
diff --git a/mail/qpopper/files/extra-patch-password::poppassd.c b/mail/qpopper/files/extra-patch-password::poppassd.c
new file mode 100644
index 000000000000..fb2b9c73a4d4
--- /dev/null
+++ b/mail/qpopper/files/extra-patch-password::poppassd.c
@@ -0,0 +1,28 @@
+--- password/poppassd.c.orig Sat May 5 18:50:05 2001
++++ password/poppassd.c Sat May 5 18:52:59 2001
+@@ -284,6 +284,8 @@
+
+ static char *P1[] =
+ {
++ "changing local password for *\nold password: ", /* FreeBSD */
++ "changing nis password for *\nold password: ", /* FreeBSD NIS */
+ "changing password for *\nold password: ", /* shadow */
+ "enter login password: ", /* Solaris */
+ "old smb password: ", /* smb */
+@@ -301,6 +303,7 @@
+
+ static char *P3[] =
+ {
++ "retype new password: ", /* FreeBSD */
+ "re-enter new password:*", /* shadow */
+ "re-enter new password: ",
+ "retype new smb password: ", /* smb */
+@@ -309,6 +312,8 @@
+
+ static char *P4[] =
+ {
++ "passwd: updating the database...\npasswd: done ", /* FreeBSD */
++ "nis password has been changed * ", /* FreeBSD NIS */
+ "password changed. ", /* shadow */
+ "password changed ", /* smb */
+ ""