aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-12-10 03:24:52 +0800
committerale <ale@FreeBSD.org>2005-12-10 03:24:52 +0800
commit41604a0f0d82280948cab0ad263522cd6969d6f1 (patch)
treec92d5ad743f770a008b8555c05f3f1723eb36467 /mail
parentc77ed4f552b975e069cc5960a2a5c8c8c76a6f54 (diff)
downloadfreebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.tar.gz
freebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.tar.zst
freebsd-ports-gnome-41604a0f0d82280948cab0ad263522cd6969d6f1.zip
Remove pear ports obsolated by devel/pear and switch
dependencies of all the other pear ports. Discussed with: thierry, antonio@php.net
Diffstat (limited to 'mail')
-rw-r--r--mail/pear-Contact_Vcard_Build/Makefile4
-rw-r--r--mail/pear-Contact_Vcard_Parse/Makefile4
-rw-r--r--mail/pear-MIME_Type/Makefile4
-rw-r--r--mail/pear-Mail/Makefile4
-rw-r--r--mail/pear-Mail_Mime/Makefile4
-rw-r--r--mail/pear-Mail_Queue/Makefile2
-rw-r--r--mail/pear-Net_Cyrus/Makefile2
-rw-r--r--mail/pear-Net_IMAP/Makefile2
-rw-r--r--mail/pear-Net_LMTP/Makefile2
9 files changed, 14 insertions, 14 deletions
diff --git a/mail/pear-Contact_Vcard_Build/Makefile b/mail/pear-Contact_Vcard_Build/Makefile
index 8c87ea69d0f0..d3ecaf0e7ee3 100644
--- a/mail/pear-Contact_Vcard_Build/Makefile
+++ b/mail/pear-Contact_Vcard_Build/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR class to build (create) and fetch vCard 2.1 and 3.0 text blocks
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
FILES= Contact_Vcard_Build.php
@@ -20,5 +20,5 @@ TESTS= test.php
_TESTSDIR= .
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Contact_Vcard_Parse/Makefile b/mail/pear-Contact_Vcard_Parse/Makefile
index 64db5001c990..c0c7b188f30d 100644
--- a/mail/pear-Contact_Vcard_Parse/Makefile
+++ b/mail/pear-Contact_Vcard_Parse/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR class to parse vCard 2.1 and 3.0 files
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
FILES= Contact_Vcard_Parse.php
@@ -20,5 +20,5 @@ TESTS= test.php test.vcf
_TESTSDIR= .
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-MIME_Type/Makefile b/mail/pear-MIME_Type/Makefile
index 87c79a6b654f..bd2d818d5d27 100644
--- a/mail/pear-MIME_Type/Makefile
+++ b/mail/pear-MIME_Type/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR class for dealing with MIME types
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
LATEST_LINK= pear-${PORTNAME}
@@ -35,7 +35,7 @@ post-extract:
RUN_DEPENDS+= ${PEARDIR}/System/Command.php:${PORTSDIR}/devel/pear-System_Command
.endif
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
post-patch:
.for file in ${FILES}
diff --git a/mail/pear-Mail/Makefile b/mail/pear-Mail/Makefile
index 7b85f046445a..458e413a6cda 100644
--- a/mail/pear-Mail/Makefile
+++ b/mail/pear-Mail/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR class that provides multiple interfaces for sending emails
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
FILES= Mail.php Mail/mail.php Mail/null.php Mail/sendmail.php \
@@ -28,5 +28,5 @@ OPTIONS= PEAR_NET_SMTP "PEAR::Net_SMTP support" off
RUN_DEPENDS+= ${PEARDIR}/Net/SMTP.php:${PORTSDIR}/net/pear-Net_SMTP
.endif
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_Mime/Makefile b/mail/pear-Mail_Mime/Makefile
index 3b3903e66886..92d17caf5003 100644
--- a/mail/pear-Mail_Mime/Makefile
+++ b/mail/pear-Mail_Mime/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= mail www pear
MAINTAINER= antonio@php.net
COMMENT= PEAR classes to create and decode MIME messages
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
CATEGORY= Mail
@@ -21,5 +21,5 @@ DATA= xmail.dtd xmail.xsl
_DATADIR= .
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_Queue/Makefile b/mail/pear-Mail_Queue/Makefile
index 5b44971f2686..a4b5eaf6f77b 100644
--- a/mail/pear-Mail_Queue/Makefile
+++ b/mail/pear-Mail_Queue/Makefile
@@ -23,5 +23,5 @@ DOCS= add_example.php base.php mdb_mail_queue_schema.xml \
mysql.sql pgsql.sql send_example.php TODO README
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Net_Cyrus/Makefile b/mail/pear-Net_Cyrus/Makefile
index 5b9adfaf0eb3..76caaa21da7b 100644
--- a/mail/pear-Net_Cyrus/Makefile
+++ b/mail/pear-Net_Cyrus/Makefile
@@ -20,5 +20,5 @@ CATEGORY= Net
FILES= Cyrus.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Net_IMAP/Makefile b/mail/pear-Net_IMAP/Makefile
index 7f83d05e6626..2acc7e9a100d 100644
--- a/mail/pear-Net_IMAP/Makefile
+++ b/mail/pear-Net_IMAP/Makefile
@@ -19,5 +19,5 @@ CATEGORY= Net
FILES= IMAP.php IMAPProtocol.php
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Net_LMTP/Makefile b/mail/pear-Net_LMTP/Makefile
index 21b3acc2fe79..698246f27224 100644
--- a/mail/pear-Net_LMTP/Makefile
+++ b/mail/pear-Net_LMTP/Makefile
@@ -21,5 +21,5 @@ TESTS= test_lmtp.php
_TESTSDIR= .
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>