aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-13 11:31:32 +0800
committerrafan <rafan@FreeBSD.org>2008-03-13 11:31:32 +0800
commit416e0319a0923e39402560d920e7a71ebb1bff89 (patch)
tree7c10c5a452676998ec49240914729e8f23393e36 /mail
parentb642bf13e540eba0662b54b7d70bd71ac5570cb6 (diff)
downloadfreebsd-ports-gnome-416e0319a0923e39402560d920e7a71ebb1bff89.tar.gz
freebsd-ports-gnome-416e0319a0923e39402560d920e7a71ebb1bff89.tar.zst
freebsd-ports-gnome-416e0319a0923e39402560d920e7a71ebb1bff89.zip
- Update to 3.2
PR: ports/121267 Submitted by: Hans Fredrik Nordhaug <hans at nordhaug.priv.no> (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/ezmlm-web/Makefile52
-rw-r--r--mail/ezmlm-web/distinfo6
-rw-r--r--mail/ezmlm-web/pkg-plist129
3 files changed, 150 insertions, 37 deletions
diff --git a/mail/ezmlm-web/Makefile b/mail/ezmlm-web/Makefile
index ffedb27c2463..964c42b3035a 100644
--- a/mail/ezmlm-web/Makefile
+++ b/mail/ezmlm-web/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= ezmlm-web
-PORTVERSION= 3.1.4
+PORTVERSION= 3.2
CATEGORIES= mail www
-MASTER_SITES= https://systemausfall.org/toolforge/ezmlm-web/download/
+MASTER_SITES= https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-3.2/
MAINTAINER= hans@nordhaug.priv.no
COMMENT= Manage ezmlm-idx mailing lists through the web (using CGI)
@@ -17,34 +17,32 @@ RUN_DEPENDS= ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx \
${SITE_PERL}/Mail/Ezmlm.pm:${PORTSDIR}/mail/p5-Mail-Ezmlm \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
-# Change these to suit your setup. You can do this via the environment
-# CGI_BIN is the location relative to ${PREFIX} of your webservers' cgi-bin
-# EZMLM_DIR is the base relative to ${PREFIX} in which ezmlm was installed
-#
-CGI_BIN?= www/cgi-bin.default
-
-USE_PERL5= YES
-PLIST_SUB= CGI_BIN=${CGI_BIN}
-
-EXAMPLES= htaccess.sample webusers.sample index.c
-DOCS= INSTALL INSTALL.clearsilver README TODO UPGRADING changelog copyright
+EXAMPLES= apache.conf.dist ezmlmwebrc.dist ezmlmwebrc.minimal-dist \
+ htaccess.dist multidomain.conf.dist webusers.dist
+DOCS= INSTALL README TODO UPGRADING changelog copyright
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} -o ezmlm-web index.c
+USE_GMAKE= yes
+USE_PERL5= yes
+PERL_CONFIGURE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|/etc/ezmlm|${PREFIX}/etc/ezmlm|' \
- -e 's|/usr/local|${PREFIX}|g' -e 's|prefex|prefix|g' \
- ${WRKSRC}/ezmlm-web.cgi ${WRKSRC}/ezmlmwebrc ${WRKSRC}/index.c
-
-do-install:
- ${MKDIR} ${PREFIX}/${CGI_BIN} ${PREFIX}/etc/ezmlm
- ${INSTALL_SCRIPT} ${WRKSRC}/ezmlm-web.cgi ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/ezmlmwebrc ${PREFIX}/etc/ezmlm/ezmlmwebrc.sample
- ${INSTALL_PROGRAM} -o alias -g qmail -m 4755 ${WRKSRC}/ezmlm-web ${PREFIX}/${CGI_BIN}
- ${MKDIR} ${EXAMPLESDIR}
+ ${REINPLACE_CMD} -e 's|local/share|share|' \
+ -e 's|$$SHAREDIR/www-data|${WWWDIR}|' \
+ ${WRKSRC}/Makefile.PL
+ ${REINPLACE_CMD} -e 's|/usr/local/share/ezmlm-web/www-data/|${WWWDIR}/|' \
+ ${WRKSRC}/examples/apache.conf.dist
+ ${REINPLACE_CMD} -e 's|/etc/ezmlm|${PREFIX}/etc/ezmlm|' -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/ezmlm-web.cgi ${WRKSRC}/examples/ezmlmwebrc.dist ${WRKSRC}/suid-wrapper/index.h
+
+.if defined(PACKAGE_BUILDING)
+CONFIGURE_ENV= BSD_BATCH_INSTALL=yes
+.endif
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR} ${PREFIX}/etc/ezmlm-web
+ ${INSTALL_DATA} ${WRKSRC}/examples/ezmlmwebrc.dist ${PREFIX}/etc/ezmlm-web/ezmlmwebrc.sample
.for file in ${EXAMPLES}
- ${INSTALL_MAN} ${WRKSRC}/${file} ${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -53,4 +51,6 @@ do-install:
.endfor
.endif
+MAN1= ezmlm-web.cgi.1p
+
.include <bsd.port.mk>
diff --git a/mail/ezmlm-web/distinfo b/mail/ezmlm-web/distinfo
index 5231a94ea717..0fee31c5a208 100644
--- a/mail/ezmlm-web/distinfo
+++ b/mail/ezmlm-web/distinfo
@@ -1,3 +1,3 @@
-MD5 (ezmlm-web-3.1.4.tar.gz) = 97a8318f14c9cc6fec119558d36c35e1
-SHA256 (ezmlm-web-3.1.4.tar.gz) = ac9d14a7bba9d24b01c2cf740b205a9c992782e09be0005c865a450025942f10
-SIZE (ezmlm-web-3.1.4.tar.gz) = 51533
+MD5 (ezmlm-web-3.2.tar.gz) = 4960958871d9a131c85a2e0a25ff9027
+SHA256 (ezmlm-web-3.2.tar.gz) = 97aae5c09ff4749bf35d38e43ac6b5ea6636b105ab458ea527cdd3a63f645db0
+SIZE (ezmlm-web-3.2.tar.gz) = 100541
diff --git a/mail/ezmlm-web/pkg-plist b/mail/ezmlm-web/pkg-plist
index f42370ac7d49..aecfd2e03c6b 100644
--- a/mail/ezmlm-web/pkg-plist
+++ b/mail/ezmlm-web/pkg-plist
@@ -1,16 +1,129 @@
-bin/ezmlm-web.cgi
-%%CGI_BIN%%/ezmlm-web
-etc/ezmlm/ezmlmwebrc.sample
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ezmlm-web/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ezmlm-web
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL.clearsilver
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%PORTDOCS%%%%DOCSDIR%%/changelog
%%PORTDOCS%%%%DOCSDIR%%/copyright
-%%EXAMPLESDIR%%/htaccess.sample
-%%EXAMPLESDIR%%/index.c
-%%EXAMPLESDIR%%/webusers.sample
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/apache.conf.dist
+%%EXAMPLESDIR%%/ezmlmwebrc.dist
+%%EXAMPLESDIR%%/ezmlmwebrc.minimal-dist
+%%EXAMPLESDIR%%/htaccess.dist
+%%EXAMPLESDIR%%/multidomain.conf.dist
+%%EXAMPLESDIR%%/webusers.dist
@dirrm %%EXAMPLESDIR%%
-@dirrmtry %%CGI_BIN%%
+bin/ezmlm-web.wrapper
+bin/ezmlm-web-make-suid
+bin/ezmlm-web.cgi
+etc/ezmlm-web/ezmlmwebrc.sample
+share/ezmlm-web/lang/de.hdf
+share/ezmlm-web/lang/en.hdf
+share/ezmlm-web/lang/es.hdf
+share/ezmlm-web/lang/it.hdf
+share/ezmlm-web/lang/ja.hdf
+share/ezmlm-web/lang/pt.hdf
+share/ezmlm-web/lang/pt_BR.hdf
+share/ezmlm-web/lang/sl.hdf
+share/ezmlm-web/template/config_options/admin_edit_text.cs
+share/ezmlm-web/template/config_options/admin_enabled.cs
+share/ezmlm-web/template/config_options/admin_get_subscribers.cs
+share/ezmlm-web/template/config_options/admin_path.cs
+share/ezmlm-web/template/config_options/archive_access.cs
+share/ezmlm-web/template/config_options/archive_deny_unknown.cs
+share/ezmlm-web/template/config_options/archive_enabled.cs
+share/ezmlm-web/template/config_options/archive_mod_only.cs
+share/ezmlm-web/template/config_options/archive_remove_private_header.cs
+share/ezmlm-web/template/config_options/block_deny.cs
+share/ezmlm-web/template/config_options/block_nonmod_post.cs
+share/ezmlm-web/template/config_options/block_others_archive.cs
+share/ezmlm-web/template/config_options/block_others_post.cs
+share/ezmlm-web/template/config_options/charset_select.cs
+share/ezmlm-web/template/config_options/confirm_post.cs
+share/ezmlm-web/template/config_options/confirm_selection.cs
+share/ezmlm-web/template/config_options/confirm_sub.cs
+share/ezmlm-web/template/config_options/confirm_unsub.cs
+share/ezmlm-web/template/config_options/copylines.cs
+share/ezmlm-web/template/config_options/create_listaddress.cs
+share/ezmlm-web/template/config_options/create_listname.cs
+share/ezmlm-web/template/config_options/digest_enabled.cs
+share/ezmlm-web/template/config_options/digest_settings.cs
+share/ezmlm-web/template/config_options/from_address.cs
+share/ezmlm-web/template/config_options/gnupg_keycomment.cs
+share/ezmlm-web/template/config_options/gnupg_keyexpires.cs
+share/ezmlm-web/template/config_options/gnupg_keyname.cs
+share/ezmlm-web/template/config_options/gnupg_keysize.cs
+share/ezmlm-web/template/config_options/gnupg_plain_without_key.cs
+share/ezmlm-web/template/config_options/gnupg_sign_messages.cs
+share/ezmlm-web/template/config_options/headeradd.cs
+share/ezmlm-web/template/config_options/headerfilter.cs
+share/ezmlm-web/template/config_options/lang_select.cs
+share/ezmlm-web/template/config_options/mailman_requests.cs
+share/ezmlm-web/template/config_options/mainlist.cs
+share/ezmlm-web/template/config_options/mimefilter.cs
+share/ezmlm-web/template/config_options/mimereject.cs
+share/ezmlm-web/template/config_options/mod_post.cs
+share/ezmlm-web/template/config_options/mod_post_path.cs
+share/ezmlm-web/template/config_options/mod_sub.cs
+share/ezmlm-web/template/config_options/mod_sub_path.cs
+share/ezmlm-web/template/config_options/msgsize_max.cs
+share/ezmlm-web/template/config_options/msgsize_min.cs
+share/ezmlm-web/template/config_options/mysql.cs
+share/ezmlm-web/template/config_options/owner_address.cs
+share/ezmlm-web/template/config_options/posting_selection.cs
+share/ezmlm-web/template/config_options/prefix.cs
+share/ezmlm-web/template/config_options/public.cs
+share/ezmlm-web/template/config_options/reply_to_self.cs
+share/ezmlm-web/template/config_options/subscribe_selection.cs
+share/ezmlm-web/template/config_options/trailer.cs
+share/ezmlm-web/template/config_options/warn_remove.cs
+share/ezmlm-web/template/config_options/webusers.cs
+share/ezmlm-web/template/ui/easy.hdf
+share/ezmlm-web/template/ui/expert.hdf
+share/ezmlm-web/template/ui/normal.hdf
+share/ezmlm-web/template/config_admin.cs
+share/ezmlm-web/template/config_all.cs
+share/ezmlm-web/template/config_archive.cs
+share/ezmlm-web/template/config_encryption.cs
+share/ezmlm-web/template/config_main.cs
+share/ezmlm-web/template/config_posting.cs
+share/ezmlm-web/template/config_processing.cs
+share/ezmlm-web/template/config_subscription.cs
+share/ezmlm-web/template/domain_select.cs
+share/ezmlm-web/template/footer.cs
+share/ezmlm-web/template/gnupg_convert.cs
+share/ezmlm-web/template/gnupg_generate_key.cs
+share/ezmlm-web/template/gnupg_import.cs
+share/ezmlm-web/template/gnupg_public.cs
+share/ezmlm-web/template/gnupg_secret.cs
+share/ezmlm-web/template/header.cs
+share/ezmlm-web/template/interface_select.cs
+share/ezmlm-web/template/help_tag_substitution.cs
+share/ezmlm-web/template/language_select.cs
+share/ezmlm-web/template/list_create.cs
+share/ezmlm-web/template/list_delete.cs
+share/ezmlm-web/template/list_select.cs
+share/ezmlm-web/template/macros.cs
+share/ezmlm-web/template/main.cs
+share/ezmlm-web/template/modpath_info.cs
+share/ezmlm-web/template/nav.cs
+share/ezmlm-web/template/show_subscription_log.cs
+share/ezmlm-web/template/subscribers.cs
+share/ezmlm-web/template/textfile_edit.cs
+share/ezmlm-web/template/textfiles.cs
+share/ezmlm-web/template/mime_type_examples.txt
+%%WWWDIR%%/color-blue-gray.css
+%%WWWDIR%%/color-red-blue.css
+%%WWWDIR%%/default.css
+%%WWWDIR%%/horiz_grad_blue.png
+%%WWWDIR%%/horiz_grad_blue_long.png
+%%WWWDIR%%/vert_grad_red.png
+@dirrmtry etc/ezmlm-web
+@dirrmtry share/ezmlm-web/www-data
+@dirrmtry share/ezmlm-web/template/ui
+@dirrmtry share/ezmlm-web/template/config_options
+@dirrmtry share/ezmlm-web/template
+@dirrmtry share/ezmlm-web/lang
+@dirrmtry share/ezmlm-web
+@dirrmtry %%WWWDIR%%